aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 00:29:13 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 00:29:13 +0000
commite8390e6e3c7cf23c6546db19b823f8b4fc9763b2 (patch)
tree0f9d2255cdc2514c08af673efe768018c7601866 /mail
parent653d6eb934c51460f3a70b764c488261192385cc (diff)
downloadports-e8390e6e3c7cf23c6546db19b823f8b4fc9763b2.tar.gz
ports-e8390e6e3c7cf23c6546db19b823f8b4fc9763b2.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/faces/Makefile2
-rw-r--r--mail/jamlib/Makefile2
-rw-r--r--mail/libetpan/Makefile2
-rw-r--r--mail/libnewmail/Makefile2
-rw-r--r--mail/libspf2-10/Makefile2
-rw-r--r--mail/libsrs/Makefile2
-rw-r--r--mail/libsrs2/Makefile2
-rw-r--r--mail/pop3lite/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/mail/faces/Makefile b/mail/faces/Makefile
index fa9052476e9e..ceec3e712a24 100644
--- a/mail/faces/Makefile
+++ b/mail/faces/Makefile
@@ -21,7 +21,7 @@ OPTIONS= X11 "X11/GTK support" on \
SOX "Sox audio support" off
WANT_GNOME= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= compface.1
MAN3= compface.3
diff --git a/mail/jamlib/Makefile b/mail/jamlib/Makefile
index 14d34641cffd..99fa3fede3ae 100644
--- a/mail/jamlib/Makefile
+++ b/mail/jamlib/Makefile
@@ -18,7 +18,7 @@ COMMENT= A JAM subroutine library
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
NO_INSTALL_MANPAGES= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN3= JAM_AddEmptyMessage.3 \
JAM_AddMessage.3 \
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 9ed2d3e727ee..4fd5307826ac 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -20,7 +20,7 @@ USE_ICONV= yes
USE_AUTOTOOLS= libtool:15 autoconf:259
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/mail/libnewmail/Makefile b/mail/libnewmail/Makefile
index e0a85c864ada..58ab6f5c7c60 100644
--- a/mail/libnewmail/Makefile
+++ b/mail/libnewmail/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls \
USE_AUTOTOOLS= libltdl:15
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --disable-doxygen --disable-lynx
diff --git a/mail/libspf2-10/Makefile b/mail/libspf2-10/Makefile
index f180e9cbe62b..abf9eef82b62 100644
--- a/mail/libspf2-10/Makefile
+++ b/mail/libspf2-10/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= ${PORTNAME}-1.2.*
LATEST_LINK= libspf2-10
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/mail/libsrs/Makefile b/mail/libsrs/Makefile
index 63e7f8bccb29..a1e1eac8ab7b 100644
--- a/mail/libsrs/Makefile
+++ b/mail/libsrs/Makefile
@@ -19,7 +19,7 @@ USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${PORTNAME}.3
USE_GMAKE= yes
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
LIBSRS_REV= 1
PLIST_SUB= PORTNAME=${PORTNAME} LIBSRS_REV=${LIBSRS_REV}
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${OPENSSLINC}" \
diff --git a/mail/libsrs2/Makefile b/mail/libsrs2/Makefile
index cb5638216b05..8c7c07e2c548 100644
--- a/mail/libsrs2/Makefile
+++ b/mail/libsrs2/Makefile
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= srs
MAINTAINER= mail-libsrs2-freebsd-ports@snowchyld.org
COMMENT= Sender Rewriting Scheme 2 C Implementation
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index dbbd3162cdb0..a98a9736a612 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -18,7 +18,7 @@ COMMENT= A flexible, modular RFC-compliant POP3 daemon
USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN5= pop3lite.conf.5
MAN8= pop3lite.8