aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2002-01-28 13:46:25 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2002-01-28 13:46:25 +0000
commit46c9d447c4088e51a83eb19dc6bfec2fccfb77e3 (patch)
tree91a9612c7053d30c0ca85d7e2cd2aa6076f5690e /mail
parente2f9b3f65fb46ddbe0d469a33b04e8088d162010 (diff)
downloadports-46c9d447c4088e51a83eb19dc6bfec2fccfb77e3.tar.gz
ports-46c9d447c4088e51a83eb19dc6bfec2fccfb77e3.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/exim-devel/Makefile9
-rw-r--r--mail/exim-old/Makefile9
-rw-r--r--mail/exim/Makefile9
3 files changed, 27 insertions, 0 deletions
diff --git a/mail/exim-devel/Makefile b/mail/exim-devel/Makefile
index d230bf2eca56..14d68828ae1d 100644
--- a/mail/exim-devel/Makefile
+++ b/mail/exim-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.952
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/Testing/ \
http://www.exim.org/ftp/Testing/ \
@@ -75,6 +76,10 @@ LDAP_LIB_TYPE?=OPENLDAP1
#
# Disable support for CDB-style lookups.
#WITHOUT_CDB= yes
+#
+# Disable support for the LMTP (RFC 2033 "SMTP over command pipe")
+# transport.
+#WITHOUT_LMTP
# You should not need to fiddle with anything below this point.
@@ -186,6 +191,10 @@ SEDLIST+= -e 's,^\# SUPPORT_MBX=,SUPPORT_MBX=,'
SEDLIST+= -e 's,^\# LOOKUP_CDB=,LOOKUP_CDB=,'
.endif
+.if !defined(WITHOUT_LMTP)
+SEDLIST+= -e 's,^\# TRANSPORT_LMTP=,TRANSPORT_LMTP=,'
+.endif
+
do-configure:
${MKDIR} ${WRKSRC}/Local
${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile
diff --git a/mail/exim-old/Makefile b/mail/exim-old/Makefile
index 3e79d6e9764a..bfcab9eb603a 100644
--- a/mail/exim-old/Makefile
+++ b/mail/exim-old/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.34
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim3/ \
http://www.exim.org/ftp/exim3/ \
@@ -71,6 +72,10 @@ LDAP_LIB_TYPE?=OPENLDAP1
#
# Disable support for CDB-style lookups.
#WITHOUT_CDB= yes
+#
+# Disable support for the LMTP (RFC 2033 "SMTP over command pipe")
+# transport.
+#WITHOUT_LMTP
# You should not need to fiddle with anything below this point.
@@ -178,6 +183,10 @@ SEDLIST+= -e 's,^\# SUPPORT_MBX=,SUPPORT_MBX=,'
SEDLIST+= -e 's,^\# LOOKUP_CDB=,LOOKUP_CDB=,'
.endif
+.if !defined(WITHOUT_LMTP)
+SEDLIST+= -e 's,^\# TRANSPORT_LMTP=,TRANSPORT_LMTP=,'
+.endif
+
do-configure:
${MKDIR} ${WRKSRC}/Local
${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 3e79d6e9764a..bfcab9eb603a 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.34
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/exim3/ \
http://www.exim.org/ftp/exim3/ \
@@ -71,6 +72,10 @@ LDAP_LIB_TYPE?=OPENLDAP1
#
# Disable support for CDB-style lookups.
#WITHOUT_CDB= yes
+#
+# Disable support for the LMTP (RFC 2033 "SMTP over command pipe")
+# transport.
+#WITHOUT_LMTP
# You should not need to fiddle with anything below this point.
@@ -178,6 +183,10 @@ SEDLIST+= -e 's,^\# SUPPORT_MBX=,SUPPORT_MBX=,'
SEDLIST+= -e 's,^\# LOOKUP_CDB=,LOOKUP_CDB=,'
.endif
+.if !defined(WITHOUT_LMTP)
+SEDLIST+= -e 's,^\# TRANSPORT_LMTP=,TRANSPORT_LMTP=,'
+.endif
+
do-configure:
${MKDIR} ${WRKSRC}/Local
${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile