aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-12-12 17:34:28 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-12-12 17:34:28 +0000
commit55422598cf11b2c1c86356d61f957da43f2e5360 (patch)
tree6416eb795d94084c7368352ce1627472f14f3efe /mail
parent42d5af0e832499a6e37be74e4878f012a4d4e8cf (diff)
Bugfix: reinitialize len before calling accept().
PR: ports/129260 Submitted by: Maxim Dounin <mdounin xx mdounin.ru> Bug: http://bugs.exim.org/show_bug.cgi?id=770
Notes
Notes: svn path=/head/; revision=224161
Diffstat (limited to 'mail')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src-daemon.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index dcb1708b14fc..ac852e675c63 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION?= ${EXIM_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_EXIM:S/$/:exim/}
MASTER_SITE_SUBDIR= exim4/:exim
diff --git a/mail/exim/files/patch-src-daemon.c b/mail/exim/files/patch-src-daemon.c
new file mode 100644
index 000000000000..d7148a33b040
--- /dev/null
+++ b/mail/exim/files/patch-src-daemon.c
@@ -0,0 +1,19 @@
+--- src/daemon.c.orig Sat Aug 30 03:49:46 2008
++++ src/daemon.c Mon Sep 1 00:46:09 2008
+@@ -1613,7 +1613,7 @@
+ struct sockaddr_in accepted;
+ #endif
+
+- EXIM_SOCKLEN_T len = sizeof(accepted);
++ EXIM_SOCKLEN_T len;
+ pid_t pid;
+
+ /* This code is placed first in the loop, so that it gets obeyed at the
+@@ -1808,6 +1808,7 @@
+ {
+ if (FD_ISSET(listen_sockets[sk], &select_listen))
+ {
++ len = sizeof(accepted);
+ accept_socket = accept(listen_sockets[sk],
+ (struct sockaddr *)&accepted, &len);
+ FD_CLR(listen_sockets[sk], &select_listen);