aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-07-30 01:34:53 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-07-30 01:34:53 +0000
commit87594aa042837e8f4ef075b1d26ff682cb6e14fc (patch)
treecd187241c064846076645c612fa866d50c93bad0 /mail
parentb9f86503bbe0f49a4cfcc293248e3de02016555b (diff)
downloadports-87594aa042837e8f4ef075b1d26ff682cb6e14fc.tar.gz
ports-87594aa042837e8f4ef075b1d26ff682cb6e14fc.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix27/Makefile7
-rw-r--r--mail/postfix27/distinfo4
-rw-r--r--mail/postfix27/files/pkg-install.in74
3 files changed, 6 insertions, 79 deletions
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index 8e275f48f808..c711e21560d9 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postfix
-PORTVERSION= 2.7.4
+PORTVERSION= 2.7.5
PORTEPOCH= 1
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
@@ -25,6 +25,8 @@ CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-689].* postfix-base-2.[0-689].*
postfix-current-2.* postfix-current-base-2.* sendmail-8.* \
sendmail+*-8.* smail-3.* zmailer-2.*
+USERS= postfix
+GROUPS= mail maildrop postfix
NO_LATEST_LINK= yes
USE_SUBMAKE= yes
USE_PERL5_BUILD=yes
@@ -335,9 +337,6 @@ do-configure:
CCARGS="${POSTFIX_CCARGS}" AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
-pre-su-install:
- @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
do-install:
@cd ${WRKSRC} && ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
config_directory=${ETCDIR} \
diff --git a/mail/postfix27/distinfo b/mail/postfix27/distinfo
index 3f6468434334..981ff708e505 100644
--- a/mail/postfix27/distinfo
+++ b/mail/postfix27/distinfo
@@ -1,5 +1,5 @@
-SHA256 (postfix/postfix-2.7.4.tar.gz) = 9bad5851e8a7c97890ee9465e7f675f7826d56361369d3e792a79eaf98ed2b11
-SIZE (postfix/postfix-2.7.4.tar.gz) = 3423968
+SHA256 (postfix/postfix-2.7.5.tar.gz) = 2fe408f49bc8540bc41b44f1b7ee7a27561f1baa4e25ef55645778ba96d15932
+SIZE (postfix/postfix-2.7.5.tar.gz) = 3425071
SHA256 (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = b67efb1ffbcae91f13bf3ed90a5181d4b5bc86ebe15753eaf9db8b2278f5bb16
SIZE (postfix/postfix-2.7.1-libspf2-1.2.x-4.patch.gz) = 8186
SHA256 (postfix/postfix-vda-2.7.2.patch) = f9b12376983833ef9305f7696e9792b62058f242ff2630aeb0866cf686f0a14b
diff --git a/mail/postfix27/files/pkg-install.in b/mail/postfix27/files/pkg-install.in
index f908a0a72e4c..b69a44a9d2f4 100644
--- a/mail/postfix27/files/pkg-install.in
+++ b/mail/postfix27/files/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/files/pkg-install.in,v 1.5 2011-01-24 23:38:35 sahil Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/files/pkg-install.in,v 1.6 2011-07-30 01:34:53 sahil Exp $
#
# If the POSTFIX_DEFAULT_MTA environment variable is set to YES, it
@@ -56,64 +56,6 @@ yesno() {
done
}
-if [ "$2" = "PRE-INSTALL" ]; then
- USER=postfix
- UID=125
- GROUP=postfix
- GID=125
- GROUP2=maildrop
- GID2=126
-
- if /usr/sbin/pw groupshow "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw groupshow "${GROUP2}" 2>/dev/null; then
- echo "You already have a group \"${GROUP2}\", so I will use it."
- else
- if /usr/sbin/pw groupadd ${GROUP2} -g ${GID2}; then
- echo "Added group \"${GROUP2}\"."
- else
- echo "Adding group \"${GROUP2}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if /usr/sbin/pw useradd ${USER} -u ${UID} -g ${GROUP} -h - -d /var/spool/postfix -s ${NOLOGIN} -c "Postfix Mail System"; then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw show group mail | grep -q "${USER}" 2>/dev/null; then
- echo "You already have user \"${USER}\" in group \"mail\", so I will use it."
- else
- echo "You need user \"${USER}\" added to group \"mail\"."
- if yesno "Would you like me to add it" y; then
- /usr/sbin/pw groupmod mail -m ${USER} || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-fi
-
if [ "$2" = "POST-INSTALL" ]; then
SAMPLES="main.cf master.cf"
for file in $SAMPLES
@@ -130,20 +72,6 @@ if [ "$2" = "POST-INSTALL" ]; then
upgrade-package
fi
-replace() {
- local orig repl
-
- orig=$1
- repl=$2
- if [ -e ${orig} ]; then
- /bin/mv -f ${orig} ${orig}.OFF
- /bin/chmod 0 ${orig}.OFF
- fi
- if [ -e ${repl} ]; then
- /bin/ln -s ${repl} ${orig}
- fi
-}
-
if [ "$2" = "POST-INSTALL" -a -z "${PACKAGE_BUILDING}" ]; then
egrep -q "^sendmail.*${PREFIX}/sbin/sendmail" ${MC} && \
egrep -q "^send-mail.*${PREFIX}/sbin/sendmail" ${MC} && \