aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2008-03-17 09:48:45 +0000
committerPeter Pentchev <roam@FreeBSD.org>2008-03-17 09:48:45 +0000
commit96a5acffcc56fe451512b1e3b3c3ddd11aba25f1 (patch)
tree761de0499af2ff76bb7e64e6e5c7ccf993c333d8 /mail
parent31509d7bdc579c83e4bfa05fdcf771b33be0d93c (diff)
Reinitialize the internal DeleteMail variable for each dot-qmail line
so that all delivery instructions are indeed executed and no messages are (partially) lost. Bump PORTREVISION. Submitted by: Michal Sviba <michal@myserver.cz> in e-mail message <47DBD588.4000906@myserver.cz>
Notes
Notes: svn path=/head/; revision=209185
Diffstat (limited to 'mail')
-rw-r--r--mail/vpopmail/Makefile1
-rw-r--r--mail/vpopmail/files/patch-vdelivermail.c16
2 files changed, 14 insertions, 3 deletions
diff --git a/mail/vpopmail/Makefile b/mail/vpopmail/Makefile
index c40438f4abe2..4c8e34e4e704 100644
--- a/mail/vpopmail/Makefile
+++ b/mail/vpopmail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vpopmail
PORTVERSION= 5.4.26
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/mail/vpopmail/files/patch-vdelivermail.c b/mail/vpopmail/files/patch-vdelivermail.c
index f62e677b7c1c..25dc2b6b406e 100644
--- a/mail/vpopmail/files/patch-vdelivermail.c
+++ b/mail/vpopmail/files/patch-vdelivermail.c
@@ -1,6 +1,6 @@
diff -urN -x .svn ../../vendor/vpopmail/vdelivermail.c ./vdelivermail.c
--- ../../vendor/vpopmail/vdelivermail.c 2007-10-07 23:44:14.000000000 +0300
-+++ ./vdelivermail.c 2007-12-25 04:36:55.000000000 +0200
++++ ./vdelivermail.c 2008-03-17 11:28:45.000000000 +0200
@@ -74,6 +74,7 @@
int is_spam();
#endif
@@ -105,7 +105,17 @@ diff -urN -x .svn ../../vendor/vpopmail/vdelivermail.c ./vdelivermail.c
if ( link( local_file_tmp, local_file_new ) == 0 ) {
/* file was successfully delivered, remove temp file */
if ( unlink(local_file_tmp) != 0 ) {
-@@ -1207,19 +1248,22 @@
+@@ -616,6 +657,9 @@
+ /* rewind the message */
+ lseek(0,0L,SEEK_SET);
+
++ /* reinitialize for each dot-qmail line */
++ DeleteMail = 0;
++
+ /* This is an command */
+ if ( *address == '|' ) {
+
+@@ -1207,19 +1251,22 @@
* * in the email headers for X-Spam-Level: which
* * we put in each spam email
* *
@@ -132,7 +142,7 @@ diff -urN -x .svn ../../vendor/vpopmail/vdelivermail.c ./vdelivermail.c
/* check for blank line, end of headers */
for(k=j,found=0;k<i;++k) {
-@@ -1242,13 +1286,19 @@
+@@ -1242,13 +1289,19 @@
}
if ( found == 0 ) {
InHeaders=0;