aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-06-19 17:39:21 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-06-19 17:39:21 +0000
commit07b5bd1477ec70c0eef4ed53bccb05f177135f69 (patch)
tree5a8d186c40e7c4dd60d0f70f4ec15e3364defc97 /mail
parent9185a9956f5f200a0b27878ac8c5961a52ec6158 (diff)
downloadports-07b5bd1477ec70c0eef4ed53bccb05f177135f69.tar.gz
ports-07b5bd1477ec70c0eef4ed53bccb05f177135f69.zip
* Removed options SSL, ISPELL, NOSPELL
* Added option ASPELL set as default * Modernized makefile PR: 219895 Submitted by: Marco Beishuizen <mbeis@xs4all.nl> (maintainer) Reviewed by: lifanov (mentor) Approved by: lifanov (mentor) Differential Revision: https://reviews.freebsd.org/D11263
Notes
Notes: svn path=/head/; revision=443900
Diffstat (limited to 'mail')
-rw-r--r--mail/alpine/Makefile161
-rw-r--r--mail/alpine/pkg-descr2
2 files changed, 61 insertions, 102 deletions
diff --git a/mail/alpine/Makefile b/mail/alpine/Makefile
index 86d81afebe5c..bdc36f375d52 100644
--- a/mail/alpine/Makefile
+++ b/mail/alpine/Makefile
@@ -2,7 +2,7 @@
PORTNAME?= alpine
PORTVERSION= 2.21
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= mail news ipv6
MASTER_SITES= http://alpine.freeiz.com/alpine/release/src/
DIST_SUBDIR= alpine-${PORTVERSION}
@@ -12,113 +12,76 @@ COMMENT?= Mail and news client descended from Pine
LICENSE= APACHE20
-OPTIONS_DEFINE= DOCS SSL THREADS MOUSE NLS ISPELL NOSPELL
-OPTIONS_DEFAULT+= SSL THREADS MOUSE
-SSL_DESC= Build with SSL (installs: security/openssl if pre 10.x)
-MOUSE_DESC= Enable mouse support for xterm
-ISPELL_DESC= Use ispell instead of aspell as default speller
-NOSPELL_DESC= Use no default speller (overrides both)
+USES+= ssl libtool ncurses tar:xz gettext-runtime
+GNU_CONFIGURE= yes
+MAKE_JOBS_UNSAFE= yes
+CONFIGURE_ARGS+= --with-debug-level=2 \
+ --enable-background-post \
+ --without-krb5 \
+ --without-tcl \
+ --with-system-pinerc=${PREFIX}/etc/alpine.conf \
+ --with-system-fixed-pinerc=${PREFIX}/etc/alpine.conf.fixed \
+ --with-password-prog=/usr/bin/passwd \
+ --with-system-mail-directory=/var/mail \
+ --with-ssl-dir=${OPENSSLDIR} \
+ --with-ssl-include-dir=${OPENSSLINC} \
+ --with-ssl-lib-dir=${OPENSSLLIB} \
+ --with-ssl-certs-dir=${OPENSSLDIR}/certs
+MAKE_ARGS+= CC="${CC}" CXX="${CXX}" GCCCFLAGS="${CFLAGS}"
-.if !defined(PICO_ALPINE_SLAVE)
+OPTIONS_DEFINE= ASPELL CONS25 DOCS IPV6 LDAP MAILDIR MOUSE PASSFILE NLS THREADS
+OPTIONS_DEFAULT= ASPELL MOUSE THREADS
+.if defined(PICO_ALPINE_SLAVE)
+OPTIONS_EXCLUDE= CONS25 IPV6 LDAP MAILDIR PASSFILE
+.endif
-OPTIONS_DEFINE+= PICO IPV6 LDAP PASSFILE CONS25 MAILDIR SSL
-OPTIONS_DEFAULT+= PICO SSL
-PICO_DESC= Build and install pico, the default editor
-PASSFILE_DESC= Support for a stored password file (DANGEROUS)
CONS25_DESC= Add a patch to support color for default console
MAILDIR_DESC= Add a patch for maildir support
-.endif
-
-USES+= libtool ncurses tar:xz gettext-runtime
-
-MAKE_JOBS_UNSAFE= yes
+PASSFILE_DESC= Support for a stored password file
-GNU_CONFIGURE= yes
+# Option ASPELL
+ASPELL_CONFIGURE_ON= --with-interactive-spellcheck=${LOCALBASE}/bin/aspell
+ASPELL_CONFIGURE_OFF= --with-simple-spellcheck
+ASPELL_BUILD_DEPENDS= aspell:textproc/aspell
+ASPELL_RUN_DEPENDS= aspell:textproc/aspell
-THREADS_CONFIGURE_WITH= pthread
-MOUSE_CONFIGURE_ENABLE= mouse
-NLS_CONFIGURE_ENABLE= nls
-IPV6_CONFIGURE_WITH= ipv6
-SSL_USES= ssl
+# Option CONS25
+CONS25_EXTRA_PATCHES= ${FILESDIR}/cons25-alpine_keymenu.c
-.if !defined(PICO_ALPINE_SLAVE)
+# Option IPV6
+IPV6_CONFIGURE_WITH= ipv6
-PORTDOCSbase= LICENSE NOTICE README
-PORTDOCSdoc= brochure.txt
-PORTDOCShtml= tech-notes/background.html tech-notes/cmd-line.html \
- tech-notes/config-notes.html tech-notes/config.html \
- tech-notes/index.html tech-notes/installation.html \
- tech-notes/introduction.html tech-notes/low-level.html \
- tech-notes/tech-notes.txt
-PORTDOCS= ${PORTDOCSbase} ${PORTDOCSdoc} ${PORTDOCShtml}
+# Option LDAP
+LDAP_USE= openldap=yes
+LDAP_CONFIGURE_WITH= ldap
+LDAP_CONFIGURE_ON= --with-ldap-dir=${LOCALBASE}
-CONFIGURE_ARGS+=--with-system-pinerc=${PREFIX}/etc/alpine.conf \
- --with-system-fixed-pinerc=${PREFIX}/etc/alpine.conf.fixed \
- --with-password-prog=/usr/bin/passwd \
- --with-system-mail-directory=/var/mail
+# Option MAILDIR
+MAILDIR_PATCH_SITES= http://alpine.freeiz.com/alpine/patches/alpine-${PORTVERSION}/
+MAILDIR_PATCHFILES+= maildir.patch.gz:-p1
-.endif
-CONFIGURE_ARGS+=--with-debug-level=2 \
- --enable-background-post --without-krb5 --without-tcl
+# Option MOUSE
+MOUSE_CONFIGURE_ENABLE= mouse
-MAKE_ARGS+= CC="${CC}" CXX="${CXX}" GCCCFLAGS="${CFLAGS}"
+# Option NLS
+NLS_CONFIGURE_ENABLE= nls
-.include <bsd.port.options.mk>
+# Option PASSFILE
+PASSFILE_CONFIGURE_WITH= passfile
+PASSFILE_CONFIGURE_ON= --with-passfile=.alpine.pwd
-.if ${PORT_OPTIONS:MSSL}
-CONFIGURE_ARGS+= --with-ssl-dir=${OPENSSLDIR} \
- --with-ssl-include-dir=${OPENSSLINC} \
- --with-ssl-lib-dir=${OPENSSLLIB} \
- --with-ssl-certs-dir=${OPENSSLDIR}/certs
-.else
-CONFIGURE_ARGS+= --without-ssl
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MSSL} && ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.if ! ${PORT_OPTIONS:MNOSPELL}
-.if ! ${PORT_OPTIONS:MISPELL}
-CONFIGURE_ARGS+=--with-interactive-spellcheck=${LOCALBASE}/bin/aspell
-BUILD_DEPENDS+= aspell:textproc/aspell
-RUN_DEPENDS+= aspell:textproc/aspell
-.else
-CONFIGURE_ARGS+= --with-interactive-spellcheck=${LOCALBASE}/bin/ispell
-BUILD_DEPENDS+= ispell:textproc/aspell-ispell
-RUN_DEPENDS+= ispell:textproc/aspell-ispell
-.endif
-.else
-CONFIGURE_ARGS+=--without-simple-spellcheck --without-interactive-spellcheck
-.endif
+# Option THREADS
+THREADS_CONFIGURE_WITH= pthread
.if !defined(PICO_ALPINE_SLAVE)
-.if ${PORT_OPTIONS:MPICO}
-RUN_DEPENDS+= pico:editors/pico-alpine
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= yes
-CONFIGURE_ARGS+= --with-ldap-dir=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-ldap
-.endif
-
-.if ${PORT_OPTIONS:MPASSFILE}
-ALPINE_PASSFILE?= .alpine.pwd
-CONFIGURE_ARGS+= --with-passfile=.alpine.pwd
-.endif
-
-.if ${PORT_OPTIONS:MMAILDIR}
-PATCH_SITES= http://alpine.freeiz.com/alpine/patches/alpine-${PORTVERSION}/
-PATCHFILES+= maildir.patch.gz:-p1
-.endif
-
-.if ${PORT_OPTIONS:MCONS25}
-EXTRA_PATCHES= ${FILESDIR}/cons25-alpine_keymenu.c
-.endif
+PORTDOCSbase= LICENSE NOTICE README
+PORTDOCSdoc= brochure.txt
+PORTDOCShtml= tech-notes/background.html tech-notes/cmd-line.html \
+ tech-notes/config-notes.html tech-notes/config.html \
+ tech-notes/index.html tech-notes/installation.html \
+ tech-notes/introduction.html tech-notes/low-level.html \
+ tech-notes/tech-notes.txt
+PORTDOCS= ${PORTDOCSbase} ${PORTDOCSdoc} ${PORTDOCShtml}
post-patch:
@${CP} ${WRKSRC}/imap/Makefile ${WRKSRC}/imap/Makefile.presed
@@ -152,7 +115,8 @@ post-patch:
post-install:
${STAGEDIR}${PREFIX}/bin/alpine -conf > ${STAGEDIR}${PREFIX}/etc/alpine.conf.sample
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
${INSTALL} -d ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DOCSDIR}/tech-notes
.for f in ${PORTDOCSbase}
${INSTALL_MAN} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
@@ -163,11 +127,6 @@ post-install:
.for f in ${PORTDOCShtml}
${INSTALL_MAN} ${WRKSRC}/doc/$f ${STAGEDIR}${DOCSDIR}/tech-notes
.endfor
-.endif
-
-# PKG_PREFIX=${STAGEDIR}${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-# @${CAT} ${PKGMESSAGE}
-
-.endif # !defined(PICO_ALPINE_SLAVE)
+.endif # !defined(PICO_ALPINE_SLAVE)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/alpine/pkg-descr b/mail/alpine/pkg-descr
index ad97b46c635e..dbbec3e97127 100644
--- a/mail/alpine/pkg-descr
+++ b/mail/alpine/pkg-descr
@@ -18,4 +18,4 @@ Alpine's basic feature set includes:
Alpine supports MIME (Multipurpose Internet Mail Extensions), an Internet
Standard for representing multipart and multimedia data in email.
-WWW: http://patches.freeiz.com/alpine/
+WWW: http://alpine.freeiz.com/alpine/