aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2005-04-15 06:31:28 +0000
committerDima Dorfman <dd@FreeBSD.org>2005-04-15 06:31:28 +0000
commit09fccf62cd170b854800238ad81b0ac56b05da1b (patch)
treef16d804c44dbefdd1cd29722bce4eac72b07ab1a /mail
parent956d0c341f6c6a91d6a681764c52e768a06851f7 (diff)
downloadports-09fccf62cd170b854800238ad81b0ac56b05da1b.tar.gz
ports-09fccf62cd170b854800238ad81b0ac56b05da1b.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/postgrey/Makefile6
-rw-r--r--mail/postgrey/distinfo4
-rw-r--r--mail/postgrey/files/postgrey.sh5
3 files changed, 8 insertions, 7 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index 1b4564d67d9b..ee4f2cbd5828 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= postgrey
-PORTVERSION= 1.18
+PORTVERSION= 1.21
CATEGORIES= mail
MASTER_SITES= http://isg.ee.ethz.ch/tools/postgrey/pub/
@@ -19,6 +19,7 @@ RUN_DEPENDS= ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
USE_PERL5= yes
USE_RC_SUBR= yes
+USE_REINPLACE= yes
NO_BUILD= yes
ETCFILES= whitelist_clients whitelist_recipients
@@ -52,6 +53,9 @@ pre-extract:
IGNORE= Needs perl 5.6.1 or higher, install lang/perl5.8 and try again
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s#/etc/#${PREFIX}/etc/#" ${WRKSRC}/postgrey
+
pre-install:
${SED} -e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%RC_SUBR%%#${RC_SUBR}#g' \
${FILESDIR}/postgrey.sh > ${WRKDIR}/postgrey.sh
diff --git a/mail/postgrey/distinfo b/mail/postgrey/distinfo
index 4abc7f88ef33..6816afb47d45 100644
--- a/mail/postgrey/distinfo
+++ b/mail/postgrey/distinfo
@@ -1,2 +1,2 @@
-MD5 (postgrey-1.18.tar.gz) = 90db6140ce09e63c5e0e84eb72d71648
-SIZE (postgrey-1.18.tar.gz) = 25699
+MD5 (postgrey-1.21.tar.gz) = 1274e073be5178445e0892a9dcc6fe98
+SIZE (postgrey-1.21.tar.gz) = 25934
diff --git a/mail/postgrey/files/postgrey.sh b/mail/postgrey/files/postgrey.sh
index 9908e9e2d991..63f47a2b08e6 100644
--- a/mail/postgrey/files/postgrey.sh
+++ b/mail/postgrey/files/postgrey.sh
@@ -36,10 +36,7 @@ stop_postcmd()
postgrey_enable=${postgrey_enable:-"NO"}
postgrey_pidfile=${postgrey_pidfile:-"/var/run/postgrey.pid"}
postgrey_flags=${postgrey_flags:-"--pidfile=${postgrey_pidfile} \
- --inet=10023 -d --user=postgrey --group=postgrey --dbdir=/var/db/postgrey \
- --whitelist-clients=%%PREFIX%%/etc/postfix/postgrey_whitelist_clients \
- --whitelist-clients=%%PREFIX%%/etc/postfix/postgrey_whitelist_clients.local \
- --whitelist-recipients=%%PREFIX%%/etc/postfix/postgrey_whitelist_recipients"}
+ --inet=10023 -d --user=postgrey --group=postgrey --dbdir=/var/db/postgrey"}
pidfile="${postgrey_pidfile}"