aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-03-31 23:59:15 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-03-31 23:59:15 +0000
commit34ffdea7245b8d99e8b1fe4a4e7b464390877008 (patch)
tree7253337ed94708a0722f79572d1690bc8937e1d0 /mail
parentf379a201bcb57f44e833324c24e76cd9f50d1631 (diff)
downloadports-34ffdea7245b8d99e8b1fe4a4e7b464390877008.tar.gz
ports-34ffdea7245b8d99e8b1fe4a4e7b464390877008.zip
mail/thunderbird: apply CVE-2018-5148 fix
Notes
Notes: svn path=/head/; revision=466104
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-bug144071740
2 files changed, 41 insertions, 0 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 00e2dcb8c00a..125a7c80ca33 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 52.7.0
+PORTREVISION= 1
CATEGORIES= mail news net-im ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1440717 b/mail/thunderbird/files/patch-bug1440717
new file mode 100644
index 000000000000..0bc2424c394a
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1440717
@@ -0,0 +1,40 @@
+commit ae9da5994b51
+Author: Nicolas Silva <nsilva@mozilla.com>
+Date: Mon Mar 12 13:36:00 2018 +0100
+
+ Bug 1440717 - Use RefPtr for CompositingRenderTargetOGL::mGL. r=Bas, a=ritu
+
+ --HG--
+ extra : source : b6d2d55223d2aa5cb85bbdf33075d1d38f2a9a30
+ extra : intermediate-source : 0ec90964e0bc479412a4da8a61d48b665211736e
+---
+ gfx/layers/opengl/CompositingRenderTargetOGL.cpp | 2 +-
+ gfx/layers/opengl/CompositingRenderTargetOGL.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
+index c05b8edfd346..a1521c56da87 100644
+--- mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
++++ mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.cpp
+@@ -60,7 +60,7 @@ CompositingRenderTargetOGL::BindRenderTarget()
+ msg.AppendPrintf("Framebuffer not complete -- CheckFramebufferStatus returned 0x%x, "
+ "GLContext=%p, IsOffscreen()=%d, mFBO=%d, aFBOTextureTarget=0x%x, "
+ "aRect.width=%d, aRect.height=%d",
+- result, mGL, mGL->IsOffscreen(), mFBO, mInitParams.mFBOTextureTarget,
++ result, mGL.get(), mGL->IsOffscreen(), mFBO, mInitParams.mFBOTextureTarget,
+ mInitParams.mSize.width, mInitParams.mSize.height);
+ NS_WARNING(msg.get());
+ }
+diff --git mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
+index 501701d6f1a3..071dc5cac1c2 100644
+--- mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
++++ mozilla/gfx/layers/opengl/CompositingRenderTargetOGL.h
+@@ -184,7 +184,7 @@ private:
+ * the target is always cleared at the end of a frame.
+ */
+ RefPtr<CompositorOGL> mCompositor;
+- GLContext* mGL;
++ RefPtr<GLContext> mGL;
+ GLuint mTextureHandle;
+ GLuint mFBO;
+ };