aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-09 23:54:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-09 23:54:16 +0000
commit309ee6a8ae8cf139346f6f3c3f2ca91ad5948b20 (patch)
tree09d94f96fbd79c1754eb3b0a785dfc44e4eed1e5 /mail
parent7c36a935776badded5c66cf0d9c4cb60212675ed (diff)
downloadports-309ee6a8ae8cf139346f6f3c3f2ca91ad5948b20.tar.gz
ports-309ee6a8ae8cf139346f6f3c3f2ca91ad5948b20.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter-current/Makefile62
-rw-r--r--mail/bogofilter-current/distinfo4
-rw-r--r--mail/bogofilter-current/pkg-install12
-rw-r--r--mail/bogofilter/Makefile62
-rw-r--r--mail/bogofilter/distinfo4
-rw-r--r--mail/bogofilter/pkg-install12
6 files changed, 74 insertions, 82 deletions
diff --git a/mail/bogofilter-current/Makefile b/mail/bogofilter-current/Makefile
index 23d2634226b1..f3506fd8aa71 100644
--- a/mail/bogofilter-current/Makefile
+++ b/mail/bogofilter-current/Makefile
@@ -1,12 +1,12 @@
# ports collection Makefile for: bogofilter
-# Whom: Matthias Andree <matthias.andree@web.de>
+# Whom: Matthias Andree <matthias.andree@gmx.de>
# Date created: 2002-10-17
#
# $FreeBSD$
#
PORTNAME= bogofilter
-PORTVERSION= 0.16.4
+PORTVERSION= 0.17.5
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,19 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@gmx.de
COMMENT= "Fast, teachable, learning spam detector"
-# There is a sibling port, bogofilter-tdb, which presets different
-# values for some of our variables
-WITH_DB_VER?= 4
-.if ${WITH_DB_VER} == 42
LIB_DEPENDS?= db-4.2:${PORTSDIR}/databases/db42
-libs= -ldb-4.2
-.else
-WITH_DB_VER= 4
-LIB_DEPENDS?= db4.0:${PORTSDIR}/databases/db4
-libs= -ldb4
-.endif
-
LIB_DEPENDS+= gsl.5:${PORTSDIR}/math/gsl
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
CONFLICTS?= bogofilter-tdb* bogofilter-qdbm*
@@ -36,31 +26,25 @@ USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db${WITH_DB_VER}" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="${libs}"
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db42" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-ldb-4.2"
+CONFIGURE_ENV+= PERL="${PERL}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install-strip prefix=${PREFIX}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-IGNORE= "Does not compile on alpha 5.x \(infinite loop in build\)"
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
${WRKSRC}/contrib/randomtrain \
${WRKSRC}/contrib/scramble \
${WRKSRC}/contrib/trainbogo.sh
-
-.if !defined(PKGNAMESUFFIX) && ${WITH_DB_VER} != 42
-pre-everything::
- @${ECHO} ""
- @${ECHO} "Use -DWITH_DB_VER=42 to link against db42 instead of the default db4"
- @${ECHO} ""
-.endif
+ ${REINPLACE_CMD} -e 's|^#!.*perl|#! ${PERL}|' \
+ ${WRKSRC}/src/tests/unsort.pl \
+ ${WRKSRC}/contrib/bogofilter-milter.pl \
+ ${WRKSRC}/contrib/bogominitrain.pl \
+ ${WRKSRC}/contrib/mime.get.rfc822 \
+ ${WRKSRC}/contrib/printmaildir.pl
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -72,19 +56,18 @@ post-build::
post-install::
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/contrib
- @${MKDIR} ${DOCSDIR}/html
- @${MKDIR} ${DOCSDIR}/programmer
- @${MKDIR} ${DOCSDIR}/xml
+.for i in contrib html programmer xml
+ @${MKDIR} ${DOCSDIR}/${i}
+.endfor
.for i in AUTHORS COPYING INSTALL NEWS README README.cvs \
doc/README.validation TODO \
CHANGES-* RELEASE.NOTES-* \
doc/integrating-with-postfix doc/integrating-with-qmail \
doc/bogofilter-tuning.HOWTO doc/bogofilter-SA-2002-01 METHODS \
doc/README.tdb
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
- ${INSTALL_MAN} ${WRKSRC}/trio/AUTHORS ${DOCSDIR}/AUTHORS.trio
+ ${INSTALL_DATA} ${WRKSRC}/trio/AUTHORS ${DOCSDIR}/AUTHORS.trio
.for i in contrib/bogo.R contrib/bogofilter-qfe \
contrib/randomtrain contrib/scramble \
contrib/mime.get.rfc822 contrib/printmaildir.pl \
@@ -92,12 +75,13 @@ post-install::
${INSTALL_SCRIPT} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
.for i in contrib/README.randomtrain contrib/dot-qmail-bogofilter-default
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/contrib/bogogrep ${DOCSDIR}/contrib/
- ${INSTALL_MAN} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
- ${INSTALL_MAN} ${WRKSRC}/doc/*.xml ${DOCSDIR}/xml
- ${INSTALL_MAN} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.xml ${DOCSDIR}/xml
+ ${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
.endif
+ ${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/bogofilter-current/distinfo b/mail/bogofilter-current/distinfo
index ce7d89f73374..aa53627cafb9 100644
--- a/mail/bogofilter-current/distinfo
+++ b/mail/bogofilter-current/distinfo
@@ -1,2 +1,2 @@
-MD5 (bogofilter-0.16.4.tar.bz2) = eafe4d23e3c2a01f72f854c90afb31ea
-SIZE (bogofilter-0.16.4.tar.bz2) = 614298
+MD5 (bogofilter-0.17.5.tar.bz2) = 9cdeebc3bb9edf9ef09a1b3f0bd09c42
+SIZE (bogofilter-0.17.5.tar.bz2) = 620413
diff --git a/mail/bogofilter-current/pkg-install b/mail/bogofilter-current/pkg-install
new file mode 100644
index 000000000000..c1fe0fc37f03
--- /dev/null
+++ b/mail/bogofilter-current/pkg-install
@@ -0,0 +1,12 @@
+if [ "$2" = "POST-INSTALL" ] && [ -e ${PKG_PREFIX}/etc/bogofilter.cf ] ; then
+cat - <<_EOF
+
+--------------------------------------------------------------------------
+The recent bogofilter versions have undergone substantial changes that can
+affect compatibility and may require that you change your configuration.
+
+See the RELEASE.NOTES-* files that shipped with bogofilter for details.
+--------------------------------------------------------------------------
+
+_EOF
+fi
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 23d2634226b1..f3506fd8aa71 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -1,12 +1,12 @@
# ports collection Makefile for: bogofilter
-# Whom: Matthias Andree <matthias.andree@web.de>
+# Whom: Matthias Andree <matthias.andree@gmx.de>
# Date created: 2002-10-17
#
# $FreeBSD$
#
PORTNAME= bogofilter
-PORTVERSION= 0.16.4
+PORTVERSION= 0.17.5
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,19 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@gmx.de
COMMENT= "Fast, teachable, learning spam detector"
-# There is a sibling port, bogofilter-tdb, which presets different
-# values for some of our variables
-WITH_DB_VER?= 4
-.if ${WITH_DB_VER} == 42
LIB_DEPENDS?= db-4.2:${PORTSDIR}/databases/db42
-libs= -ldb-4.2
-.else
-WITH_DB_VER= 4
-LIB_DEPENDS?= db4.0:${PORTSDIR}/databases/db4
-libs= -ldb4
-.endif
-
LIB_DEPENDS+= gsl.5:${PORTSDIR}/math/gsl
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
CONFLICTS?= bogofilter-tdb* bogofilter-qdbm*
@@ -36,31 +26,25 @@ USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
PATCH_STRIP= -p1
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
-CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db${WITH_DB_VER}" \
- LDFLAGS="-L${LOCALBASE}/lib" LIBS="${libs}"
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include/db42" \
+ LDFLAGS="-L${LOCALBASE}/lib" LIBS="-ldb-4.2"
+CONFIGURE_ENV+= PERL="${PERL}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install-strip prefix=${PREFIX}
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-IGNORE= "Does not compile on alpha 5.x \(infinite loop in build\)"
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
${WRKSRC}/contrib/randomtrain \
${WRKSRC}/contrib/scramble \
${WRKSRC}/contrib/trainbogo.sh
-
-.if !defined(PKGNAMESUFFIX) && ${WITH_DB_VER} != 42
-pre-everything::
- @${ECHO} ""
- @${ECHO} "Use -DWITH_DB_VER=42 to link against db42 instead of the default db4"
- @${ECHO} ""
-.endif
+ ${REINPLACE_CMD} -e 's|^#!.*perl|#! ${PERL}|' \
+ ${WRKSRC}/src/tests/unsort.pl \
+ ${WRKSRC}/contrib/bogofilter-milter.pl \
+ ${WRKSRC}/contrib/bogominitrain.pl \
+ ${WRKSRC}/contrib/mime.get.rfc822 \
+ ${WRKSRC}/contrib/printmaildir.pl
.if !defined(NOPORTDOCS)
PORTDOCS= *
@@ -72,19 +56,18 @@ post-build::
post-install::
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/contrib
- @${MKDIR} ${DOCSDIR}/html
- @${MKDIR} ${DOCSDIR}/programmer
- @${MKDIR} ${DOCSDIR}/xml
+.for i in contrib html programmer xml
+ @${MKDIR} ${DOCSDIR}/${i}
+.endfor
.for i in AUTHORS COPYING INSTALL NEWS README README.cvs \
doc/README.validation TODO \
CHANGES-* RELEASE.NOTES-* \
doc/integrating-with-postfix doc/integrating-with-qmail \
doc/bogofilter-tuning.HOWTO doc/bogofilter-SA-2002-01 METHODS \
doc/README.tdb
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
- ${INSTALL_MAN} ${WRKSRC}/trio/AUTHORS ${DOCSDIR}/AUTHORS.trio
+ ${INSTALL_DATA} ${WRKSRC}/trio/AUTHORS ${DOCSDIR}/AUTHORS.trio
.for i in contrib/bogo.R contrib/bogofilter-qfe \
contrib/randomtrain contrib/scramble \
contrib/mime.get.rfc822 contrib/printmaildir.pl \
@@ -92,12 +75,13 @@ post-install::
${INSTALL_SCRIPT} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
.for i in contrib/README.randomtrain contrib/dot-qmail-bogofilter-default
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
${INSTALL_PROGRAM} ${WRKSRC}/contrib/bogogrep ${DOCSDIR}/contrib/
- ${INSTALL_MAN} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
- ${INSTALL_MAN} ${WRKSRC}/doc/*.xml ${DOCSDIR}/xml
- ${INSTALL_MAN} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.xml ${DOCSDIR}/xml
+ ${INSTALL_DATA} ${WRKSRC}/doc/programmer/README.freebsd ${DOCSDIR}/programmer
.endif
+ ${SETENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index ce7d89f73374..aa53627cafb9 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1,2 +1,2 @@
-MD5 (bogofilter-0.16.4.tar.bz2) = eafe4d23e3c2a01f72f854c90afb31ea
-SIZE (bogofilter-0.16.4.tar.bz2) = 614298
+MD5 (bogofilter-0.17.5.tar.bz2) = 9cdeebc3bb9edf9ef09a1b3f0bd09c42
+SIZE (bogofilter-0.17.5.tar.bz2) = 620413
diff --git a/mail/bogofilter/pkg-install b/mail/bogofilter/pkg-install
new file mode 100644
index 000000000000..c1fe0fc37f03
--- /dev/null
+++ b/mail/bogofilter/pkg-install
@@ -0,0 +1,12 @@
+if [ "$2" = "POST-INSTALL" ] && [ -e ${PKG_PREFIX}/etc/bogofilter.cf ] ; then
+cat - <<_EOF
+
+--------------------------------------------------------------------------
+The recent bogofilter versions have undergone substantial changes that can
+affect compatibility and may require that you change your configuration.
+
+See the RELEASE.NOTES-* files that shipped with bogofilter for details.
+--------------------------------------------------------------------------
+
+_EOF
+fi