aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-01-16 11:59:43 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-01-16 11:59:43 +0000
commit58c044bdc63fdbe2c1db18930d64ff3ea5f6994e (patch)
tree26633375ca23352c6cc460f02107be1ec1220a87 /mail
parent20b6b19fbf856eaeefe2526357b71898aa815ff5 (diff)
* Do not clobber plaintext manual if WITH_MUTT_HTML is undefined.
* Enable WITH_MUTT_HTML on alpha, old problem no longer applies. Submitted by: Udo Schweigert <udo.schweigert@siemens.com>
Notes
Notes: svn path=/head/; revision=53161
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt-devel/Makefile11
-rw-r--r--mail/mutt-devel/files/extra-patch-html58
-rw-r--r--mail/mutt-devel/files/patch-0258
3 files changed, 72 insertions, 55 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 6a455114b93a..a1b1f4ae0e21 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -42,7 +42,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.3.25
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= mail
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
@@ -96,13 +96,10 @@ WITH_MUTT_SSL= yes
WITH_MUTT_SLANG= yes
WITH_MUTT_IMAP= yes
WITH_MUTT_POP= yes
+WITH_MUTT_HTML= yes
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
urlview:${PORTSDIR}/textproc/urlview
-.if ${MACHINE_ARCH} != "alpha"
-# coredump in sgmls
-WITH_MUTT_HTML= yes
-.endif
.endif
.if defined(WITH_MUTT_SLANG)
@@ -851,6 +848,10 @@ post-patch::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
.endif
+.if defined(WITH_MUTT_HTML)
+post-patch::
+ ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-html
+.endif
post-install:
@strip ${PREFIX}/bin/mutt
diff --git a/mail/mutt-devel/files/extra-patch-html b/mail/mutt-devel/files/extra-patch-html
new file mode 100644
index 000000000000..9f5322073a93
--- /dev/null
+++ b/mail/mutt-devel/files/extra-patch-html
@@ -0,0 +1,58 @@
+--- doc/Makefile.in.orig2 Tue Jan 15 17:22:04 2002
++++ doc/Makefile.in Tue Jan 15 17:09:45 2002
+@@ -60,13 +60,16 @@
+ topsrcdir_DOCFILES = COPYRIGHT GPL INSTALL ChangeLog \
+ README NEWS TODO README.SECURITY README.SSL
+
+-all:
++all: muttrc.man try-html try-txt try-latin1
+
+ try-html: ../makedoc
+- test -f manual.html || $(MAKE) manual.html || cp $(srcdir)/manual*.html ./
++ rm -f *.html && $(MAKE) manual.html || cp $(srcdir)/manual*.html ./
+
+ try-txt: ../makedoc
+- test -f manual.txt || $(MAKE) manual.txt || cp $(srcdir)/manual.txt ./
++ $(MAKE) manual.txt || cp $(srcdir)/manual.txt ./
++
++try-latin1:
++ $(MAKE) manual.latin1 || cp $(srcdir)/manual.latin1 ./
+
+ install: all instdoc
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man1
+@@ -80,10 +83,10 @@
+ ./instdoc $(srcdir)/mbox.man $(DESTDIR)$(mandir)/man5/mbox.5
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)
+ for f in $(srcdir_DOCFILES) ; do \
+- $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir) ; \
++ $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir) ; \
+ done
+ for f in $(topsrcdir_DOCFILES) ; do \
+- $(INSTALL) -m 644 $(top_srcdir)/$$f $(DESTDIR)$(docdir) ; \
++ $(INSTALL) -m 644 $(top_srcdir)/$$f $(DESTDIR)$(docdir) ; \
+ done
+ $(INSTALL) -m 644 manual.txt $(DESTDIR)$(docdir) || true
+ # $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)/html
+@@ -99,14 +102,18 @@
+
+ check:
+ manual.txt: manual.sgml
+- if sgml2txt -c latin manual ; then \
+- uniq < manual.txt | expand > _manual.txt ; \
+- rm manual.txt ; \
++ if sgmlfmt -f ascii manual; then \
++ uniq < manual.ascii | expand > _manual.txt ; \
++ rm -f manual.txt manual.ascii; \
+ mv _manual.txt manual.txt ;\
+ fi
+
+ manual.html: manual.sgml
+- sgml2html manual || true
++ @# sgml2html manual || true
++ sgmlfmt -f html manual || true
++
++manual.latin1: manual.sgml
++ sgmlfmt -f latin1 manual || true
+
+ manual.ps: manual.sgml
+ sgml2latex --output=ps manual || true
diff --git a/mail/mutt-devel/files/patch-02 b/mail/mutt-devel/files/patch-02
index 75695db5632b..6c9282a76a88 100644
--- a/mail/mutt-devel/files/patch-02
+++ b/mail/mutt-devel/files/patch-02
@@ -1,35 +1,16 @@
---- doc/Makefile.in.orig Wed Mar 29 11:42:49 2000
-+++ doc/Makefile.in Mon Jun 12 16:50:51 2000
-@@ -58,13 +58,16 @@
+--- doc/Makefile.in.orig Tue Nov 6 20:12:31 2001
++++ doc/Makefile.in Tue Jan 15 17:22:04 2002
+@@ -60,7 +60,7 @@
topsrcdir_DOCFILES = COPYRIGHT GPL INSTALL ChangeLog \
- README NEWS TODO README.SECURITY README.SSL README.UPGRADE
+ README NEWS TODO README.SECURITY README.SSL
-all: muttrc.man try-html try-txt
-+all: muttrc.man try-html try-txt try-latin1
++all:
try-html: ../makedoc
-- test -f manual.html || $(MAKE) manual.html || cp $(srcdir)/manual*.html ./
-+ rm -f *.html && $(MAKE) manual.html || cp $(srcdir)/manual*.html ./
-
- try-txt: ../makedoc
-- test -f manual.txt || $(MAKE) manual.txt || cp $(srcdir)/manual.txt ./
-+ $(MAKE) manual.txt || cp $(srcdir)/manual.txt ./
-+
-+try-latin1:
-+ $(MAKE) manual.latin1 || cp $(srcdir)/manual.latin1 ./
-
- install: all
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man1
-@@ -75,16 +78,16 @@
- $(INSTALL) -m 644 muttrc.man $(DESTDIR)$(mandir)/man5/muttrc.5
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)
- for f in $(srcdir_DOCFILES) ; do \
-- $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir) ; \
-+ $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir) ; \
- done
- for f in $(topsrcdir_DOCFILES) ; do \
-- $(INSTALL) -m 644 $(top_srcdir)/$$f $(DESTDIR)$(docdir) ; \
-+ $(INSTALL) -m 644 $(top_srcdir)/$$f $(DESTDIR)$(docdir) ; \
+ test -f manual.html || $(MAKE) manual.html || cp $(srcdir)/manual*.html ./
+@@ -86,10 +86,10 @@
+ $(INSTALL) -m 644 $(top_srcdir)/$$f $(DESTDIR)$(docdir) ; \
done
$(INSTALL) -m 644 manual.txt $(DESTDIR)$(docdir) || true
- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(docdir)/html
@@ -43,26 +24,3 @@
uninstall:
-rm -f $(DESTDIR)$(mandir)/man1/mutt.1
-@@ -93,14 +96,18 @@
- -rm -rf $(DESTDIR)$(docdir)
-
- manual.txt: manual.sgml
-- if sgml2txt -c latin manual ; then \
-- uniq < manual.txt | expand > _manual.txt ; \
-- rm manual.txt ; \
-+ if sgmlfmt -f ascii manual; then \
-+ uniq < manual.ascii | expand > _manual.txt ; \
-+ rm -f manual.txt manual.ascii; \
- mv _manual.txt manual.txt ;\
- fi
-
- manual.html: manual.sgml
-- sgml2html manual || true
-+ @# sgml2html manual || true
-+ sgmlfmt -f html manual || true
-+
-+manual.latin1: manual.sgml
-+ sgmlfmt -f latin1 manual || true
-
- manual.ps: manual.sgml
- sgml2latex --output=ps manual || true