aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2007-09-09 15:28:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2007-09-09 15:28:56 +0000
commit76a80c777698e4eaf51d8f2d4dfc6089bc12a93c (patch)
treec55c4643362e995e1f4cd385924c3063c96c8363 /mail
parent06252c5f09dbfc32f4bdb3ef59190a3a7b34a8c6 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/filtermail/Makefile6
-rw-r--r--mail/filtermail/distinfo6
-rw-r--r--mail/filtermail/files/patch-src::Makefile.in20
-rw-r--r--mail/filtermail/files/patch-src::rcfile.ll34
4 files changed, 6 insertions, 60 deletions
diff --git a/mail/filtermail/Makefile b/mail/filtermail/Makefile
index 6559140d5349..8064448bfb73 100644
--- a/mail/filtermail/Makefile
+++ b/mail/filtermail/Makefile
@@ -9,15 +9,15 @@
#
PORTNAME= filtermail
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.7.2
+PORTREVISION= 0
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://home.in.tum.de/baueran/%SUBDIR%/
MASTER_SITE_SUBDIR= mailfilter
DISTNAME= mailfilter-${PORTVERSION}
-MAINTAINER= stas@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Filter mail on a pop3 server: saves downloading spam
# This port is filtermail, but the author called it mailfilter. To avoid a
diff --git a/mail/filtermail/distinfo b/mail/filtermail/distinfo
index 753983c6e668..8b754924dbbd 100644
--- a/mail/filtermail/distinfo
+++ b/mail/filtermail/distinfo
@@ -1,3 +1,3 @@
-MD5 (mailfilter-0.7.1.tar.gz) = be6d603081086c8780601cb0c8e19f67
-SHA256 (mailfilter-0.7.1.tar.gz) = 1b875d423bb3cb0f74252e5209a10ca7271053d52ba0d24bacb70fad6a9630bb
-SIZE (mailfilter-0.7.1.tar.gz) = 506799
+MD5 (mailfilter-0.7.2.tar.gz) = 972aa6c6413fa22a62a8d402a24ba014
+SHA256 (mailfilter-0.7.2.tar.gz) = a54ec851787edf5100a5b61824b5035331a165a01c022f1e96eea286b43143e0
+SIZE (mailfilter-0.7.2.tar.gz) = 531872
diff --git a/mail/filtermail/files/patch-src::Makefile.in b/mail/filtermail/files/patch-src::Makefile.in
index 8d2b42da75b0..40451ac98ba4 100644
--- a/mail/filtermail/files/patch-src::Makefile.in
+++ b/mail/filtermail/files/patch-src::Makefile.in
@@ -34,23 +34,3 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/header.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/imap.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/filtermail.Po@am__quote@
-@@ -571,8 +567,8 @@
- rcparser.hh: y.tab.c
- y.tab.c: rcfile.yy
- $(YACC) -p rc $(YFLAGS) -o$@ $^; \
-- mv --force y.tab.c rcparser.cc; \
-- mv --force y.tab.h rcparser.hh; \
-+ mv -f y.tab.c rcparser.cc; \
-+ mv -f y.tab.h rcparser.hh; \
- $(CXXCOMPILE) -c rcparser.cc; \
- touch y.tab.c
-
-@@ -583,7 +579,7 @@
- rfc822parser.hh: rfc822parser.cc
- rfc822parser.cc: rfc822.yy
- $(YACC) $(YFLAGS) -p rfc -o$@ $^; \
-- mv --force y.tab.h rfc822parser.hh;\
-+ mv -f y.tab.h rfc822parser.hh;\
- $(CXXCOMPILE) -c rfc822parser.cc; \
- touch y.tab.c
-
diff --git a/mail/filtermail/files/patch-src::rcfile.ll b/mail/filtermail/files/patch-src::rcfile.ll
deleted file mode 100644
index 305346085f78..000000000000
--- a/mail/filtermail/files/patch-src::rcfile.ll
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/rcfile.ll.orig Sun Jan 25 21:56:46 2004
-+++ src/rcfile.ll Fri Mar 19 23:18:03 2004
-@@ -44,7 +44,7 @@
-
- extern "C"
- {
--#include "wordexp.h"
-+#include "glob.h"
- }
-
- using namespace std;
-@@ -125,7 +125,7 @@
-
- <INCL>[^ \t\n]+ {
- /* Include further rcfiles: */
-- wordexp_t result;
-+ glob_t result;
-
- if (include_stack_ptr >= MAX_INCLUDE_DEPTH)
- {
-@@ -136,10 +136,10 @@
-
- try
- {
-- if (wordexp (yytext, &result, 0) == 0)
-+ if (glob (yytext, 0, NULL, &result) == 0)
- {
-- sub_file = result.we_wordv[0];
-- wordfree (&result);
-+ sub_file = result.gl_pathv[0];
-+ globfree (&result);
- }
- else
- {