aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-09-22 05:09:10 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-09-22 05:09:10 +0000
commitee6042889f64e92d4e5e4f19e121a3df719e28c9 (patch)
tree52b6ca647a0382a8b92fc8d28d96bf802caa29d6 /mail
parent7a6b264fc93cafebb97de8516e2b19d018c11c68 (diff)
downloadports-ee6042889f64e92d4e5e4f19e121a3df719e28c9.tar.gz
ports-ee6042889f64e92d4e5e4f19e121a3df719e28c9.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Mail-QuoteWrap/Makefile24
-rw-r--r--mail/p5-Mail-QuoteWrap/distinfo1
-rw-r--r--mail/p5-Mail-QuoteWrap/pkg-comment1
-rw-r--r--mail/p5-Mail-QuoteWrap/pkg-descr20
-rw-r--r--mail/p5-Mail-QuoteWrap/pkg-plist5
6 files changed, 52 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index eac4e799de36..4b1b20b86d4c 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -127,6 +127,7 @@
SUBDIR += p5-Mail-ListDetector
SUBDIR += p5-Mail-MailStats
SUBDIR += p5-Mail-POP3Client
+ SUBDIR += p5-Mail-QuoteWrap
SUBDIR += p5-Mail-Sender
SUBDIR += p5-Mail-Sendmail
SUBDIR += p5-Mail-Tools
diff --git a/mail/p5-Mail-QuoteWrap/Makefile b/mail/p5-Mail-QuoteWrap/Makefile
new file mode 100644
index 000000000000..a3833a0620f5
--- /dev/null
+++ b/mail/p5-Mail-QuoteWrap/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Mail-QuoteWrap
+# Date created: Fri Sep 21 21:56:03 PDT 2001
+# Whom: Michael Haro <mharo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-QuoteWrap
+PORTVERSION= 0.01
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+DISTNAME= MailQuoteWrap${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mharo@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mail::QuoteWrap.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-QuoteWrap/distinfo b/mail/p5-Mail-QuoteWrap/distinfo
new file mode 100644
index 000000000000..f810fc182c76
--- /dev/null
+++ b/mail/p5-Mail-QuoteWrap/distinfo
@@ -0,0 +1 @@
+MD5 (MailQuoteWrap0.01.tgz) = 6b1c81ee49b04156e914ce2aa87ea070
diff --git a/mail/p5-Mail-QuoteWrap/pkg-comment b/mail/p5-Mail-QuoteWrap/pkg-comment
new file mode 100644
index 000000000000..d39eb0f3c3bc
--- /dev/null
+++ b/mail/p5-Mail-QuoteWrap/pkg-comment
@@ -0,0 +1 @@
+Provides wrapping functionality for quoted Email and Usenet messages
diff --git a/mail/p5-Mail-QuoteWrap/pkg-descr b/mail/p5-Mail-QuoteWrap/pkg-descr
new file mode 100644
index 000000000000..9e0444ca840a
--- /dev/null
+++ b/mail/p5-Mail-QuoteWrap/pkg-descr
@@ -0,0 +1,20 @@
+A Mail::QuoteWrap object expects its text member to contain a reference
+to a list of lines of text, such as the output of methods like body
+News::Article(). It can then produce quotified output, optionally
+prepended with the quote mark designated by output_quotechar, within the
+width specified by columns.
+
+Mail::QuoteWrap specificially does not solve the following problems:
+
+It does not handle munged quote characters, such as those produced by the
+AOHell newsreader or similar gunge:
+ >> This >is a second-generation quote, but it
+ > looks >>like a nasty mix of first- and second->
+ > generation >>material.
+
+It does not automatically detect and bypass news or mail headers. That
+is not the role of this object.
+
+It assumes a paragraph structure to the quoted text and doesn't try to
+enforce any other. If you want a module that detects document structure
+and deals well with it, look at Text::Autoformat.
diff --git a/mail/p5-Mail-QuoteWrap/pkg-plist b/mail/p5-Mail-QuoteWrap/pkg-plist
new file mode 100644
index 000000000000..92a055039a40
--- /dev/null
+++ b/mail/p5-Mail-QuoteWrap/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Mail/QuoteWrap.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/QuoteWrap/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/QuoteWrap
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Mail 2>/dev/null || true