aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-09-09 07:14:44 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-09-09 07:14:44 +0000
commit6b5e94369dc9f3f7c0773bb3fdf681b7d2b0bd86 (patch)
treeb8a8a2c85d0ff25c4bca5f0f3c9fc332fde07407 /mail
parent224bc704362a8dffba854f2f2aa7421c99f089d2 (diff)
downloadports-6b5e94369dc9f3f7c0773bb3fdf681b7d2b0bd86.tar.gz
ports-6b5e94369dc9f3f7c0773bb3fdf681b7d2b0bd86.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/moztraybiff/Makefile5
-rw-r--r--mail/moztraybiff/files/patch-components_Makefile22
2 files changed, 12 insertions, 15 deletions
diff --git a/mail/moztraybiff/Makefile b/mail/moztraybiff/Makefile
index e4d2e30839c1..c7b203cb4960 100644
--- a/mail/moztraybiff/Makefile
+++ b/mail/moztraybiff/Makefile
@@ -7,6 +7,7 @@
PORTNAME= moztraybiff
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= http://mozdev.oregonstate.edu/moztraybiff/
DISTNAME= mozTrayBiff-${PORTVERSION}
@@ -14,9 +15,9 @@ DISTNAME= mozTrayBiff-${PORTVERSION}
MAINTAINER= adamw@FreeBSD.org
COMMENT= New mail tray icon for Thunderbird
-BUILD_DEPENDS= ${X11BASE}/lib/thunderbird/lib/thunderbird-${TBVER}/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird \
+BUILD_DEPENDS= ${X11BASE}/lib/thunderbird/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird \
zip:${PORTSDIR}/archivers/zip
-RUN_DEPENDS= ${X11BASE}/lib/thunderbird/lib/thunderbird-${TBVER}/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird
+RUN_DEPENDS= ${X11BASE}/lib/thunderbird/components/libwidget_gtk2.so:${PORTSDIR}/mail/thunderbird
.if !exists(../thunderbird/Makefile)
BROKEN= ${PORTNAME} needs the Thunderbird port in order to build
diff --git a/mail/moztraybiff/files/patch-components_Makefile b/mail/moztraybiff/files/patch-components_Makefile
index 7f744d234f67..583bc78d89da 100644
--- a/mail/moztraybiff/files/patch-components_Makefile
+++ b/mail/moztraybiff/files/patch-components_Makefile
@@ -1,15 +1,11 @@
---- components/Makefile.orig Sun Apr 24 10:25:02 2005
-+++ components/Makefile Tue May 17 18:08:15 2005
-@@ -69,10 +69,10 @@ ${COMPONENT_NAME}.xpt: nsIMessengerFreeD
- LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpt_link $@ $<
+--- components/Makefile.orig Sun Apr 24 09:25:02 2005
++++ components/Makefile Fri Sep 9 01:47:59 2005
+@@ -27,7 +27,7 @@
+ $(shell pkg-config --libs $(GTK_PACKAGE))
- %.xpt: %.idl
-- LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -m typelib -e $@ $<
-+ LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -I$(shell thunderbird-config --prefix)/share/idl/thunderbird-$(TBVER) -m typelib -e $@ $<
-
- %.h: %.idl
-- LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -m header -e $@ $<
-+ LD_LIBRARY_PATH=$(MOZILLA_UTIL_PREFIX):`pwd` $(MOZILLA_UTIL_PREFIX)/xpidl $(MOZILLA_IDLFLAGS) -I$(shell thunderbird-config --prefix)/share/idl/thunderbird-$(TBVER) -m header -e $@ $<
-
- nsIMessengerFreeDesktopIntegration.xpt: nsIMessengerFreeDesktopIntegration.idl
+ MOZ_INCLUDES := \
+- $(shell $(MOZILLA_CONFIG) --cflags)
++ $(shell $(MOZILLA_CONFIG) --cflags) $(shell $(REAL_CONFIG) --cflags)
+ CFLAGS += \
+ -fPIC