aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-10-05 19:57:56 +0000
committerAde Lovett <ade@FreeBSD.org>2010-10-05 19:57:56 +0000
commit7e80cde3289d108a73c54656f4fde354dd2fb09e (patch)
treeb85b705571d426ca1d0ff74b6af8f029081a6a39 /mail
parent6abe3f75658b0457864b49c9fdaf298b79f2c447 (diff)
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter/Makefile2
-rw-r--r--mail/dspam-devel/Makefile2
-rw-r--r--mail/kshowmail/Makefile2
-rw-r--r--mail/kshowmail/files/patch-admin-cvs.sh7
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/mutt/Makefile2
-rw-r--r--mail/mutt14/Makefile2
-rw-r--r--mail/postfix-gps/Makefile2
-rw-r--r--mail/vmailmgr/Makefile3
9 files changed, 15 insertions, 9 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index e05670a4fdcc..e41fc87f41a0 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -28,7 +28,7 @@ USE_BZIP2= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
-USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:267 autoheader:267
+USE_AUTOTOOLS= aclocal:111 automake:111 autoconf:267 autoheader:267
ACLOCAL_ARGS= -Im4
.include <bsd.port.pre.mk>
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index bc4fcc9fe354..92c7fd3481f2 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -98,7 +98,7 @@ OPTIONS+= LIGHTTPD "RUN_DEPEND on LightHTTPD, not Apache" off
USE_PERL5= yes
USE_AUTOTOOLS= libtool:22
.ifdef(SNAP_DATE)
-USE_AUTOTOOLS+= autoconf:267:env automake:19
+USE_AUTOTOOLS+= autoconf:267:env automake:111
.endif
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/mail/kshowmail/Makefile b/mail/kshowmail/Makefile
index f96d13da8b48..f19f028a2338 100644
--- a/mail/kshowmail/Makefile
+++ b/mail/kshowmail/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= mimelib.1:${PORTSDIR}/deskutils/kdepim3
USE_KDELIBS_VER= 3
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:267:env automake:19:env libtool:22:env
+USE_AUTOTOOLS= autoconf:267:env automake:111:env libtool:22:env
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
diff --git a/mail/kshowmail/files/patch-admin-cvs.sh b/mail/kshowmail/files/patch-admin-cvs.sh
new file mode 100644
index 000000000000..b62efbb3b767
--- /dev/null
+++ b/mail/kshowmail/files/patch-admin-cvs.sh
@@ -0,0 +1,7 @@
+--- admin/cvs.sh.orig 2007-05-17 13:12:38.000000000 -0500
++++ admin/cvs.sh 2010-10-02 14:47:03.000000000 -0500
+@@ -70,3 +70,3 @@
+ ;;
+- automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10*)
++ automake*1.6.* | automake*1.7* | automake*1.8* | automake*1.9* | automake*1.10* | automake*1.11* )
+ echo "*** $AUTOMAKE_STRING found."
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 104069096d75..57161f8ab41d 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -165,7 +165,7 @@ CONFIGURE_ARGS= --disable-fcntl --with-ssl=${OPENSSLBASE} \
CONFIGURE_ARGS+= ${MUTT_CONFIGURE_ARGS}
.endif
-USE_AUTOTOOLS= automake:110 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
USE_OPENSSL= yes
PLIST= ${WRKDIR}/PLIST
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 44231bdc8c88..0a170a3bc088 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -93,7 +93,7 @@ RUN_DEPENDS+= slrnface:${PORTSDIR}/news/slrnface
DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:19 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-pop --enable-imap --disable-fcntl \
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 44231bdc8c88..0a170a3bc088 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -93,7 +93,7 @@ RUN_DEPENDS+= slrnface:${PORTSDIR}/news/slrnface
DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:19 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-pop --enable-imap --disable-fcntl \
diff --git a/mail/postfix-gps/Makefile b/mail/postfix-gps/Makefile
index ff9a8dcc11b6..4a8b1b7c8e0f 100644
--- a/mail/postfix-gps/Makefile
+++ b/mail/postfix-gps/Makefile
@@ -26,7 +26,7 @@ SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/release-${PORTVERSION}
-USE_AUTOTOOLS= automake:19 autoconf:267
+USE_AUTOTOOLS= automake:111 autoconf:267
AUTOMAKE_ARGS= --add-missing
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
diff --git a/mail/vmailmgr/Makefile b/mail/vmailmgr/Makefile
index 1e3bd3a66190..8d0e1843d9bc 100644
--- a/mail/vmailmgr/Makefile
+++ b/mail/vmailmgr/Makefile
@@ -25,11 +25,10 @@ MAN8= vmailmgrd.8
# get python paths (PYTHON_SITELIBDIR) in case we install the python API
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:267 autoheader:267 automake:110 aclocal:110
+USE_AUTOTOOLS= autoconf:267 autoheader:267 automake:111 aclocal:111
USE_PYTHON= yes
USE_PERL5_BUILD= yes
AUTOMAKE_ARGS+= --add-missing -Wno-portability
-USE_AUTOTOOLS= aclocal:110 autoconf:267 automake:110
MAKE_JOBS_SAFE= yes
OPTIONS= PYTHONLIB "Install the Python API" Off