aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 23:34:16 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 23:34:16 +0000
commitbdd556264ea392245e2b5af29a4a913ae9ee4085 (patch)
tree98bb05f695dd7182a606262556814db91003022b /mail
parentc0b3ecac4483b2524287317171c79548d9842905 (diff)
downloadports-bdd556264ea392245e2b5af29a4a913ae9ee4085.tar.gz
ports-bdd556264ea392245e2b5af29a4a913ae9ee4085.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/courier/Makefile6
-rw-r--r--mail/dovecot-devel/Makefile2
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/exim/Makefile4
-rw-r--r--mail/listmanager/Makefile21
-rw-r--r--mail/mutt-devel/Makefile2
-rw-r--r--mail/postfix-current/pkg-install34
-rw-r--r--mail/postfix/pkg-install35
-rw-r--r--mail/postfix1/pkg-install34
-rw-r--r--mail/postfix21/pkg-install34
-rw-r--r--mail/postfix22/pkg-install34
-rw-r--r--mail/postfix23/pkg-install34
-rw-r--r--mail/postfix24/pkg-install35
-rw-r--r--mail/postfix25/pkg-install35
-rw-r--r--mail/postfix26/pkg-install35
-rw-r--r--mail/postfix27/pkg-install35
-rw-r--r--mail/postfix28/pkg-install35
-rw-r--r--mail/qpopper/Makefile4
18 files changed, 125 insertions, 296 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 073508b0b85c..4fa2594e59cc 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -257,12 +257,6 @@ CONFIGURE_ARGS+=--with-ipv6
CONFIGURE_ARGS+=--without-ipv6
.endif
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-maildir__maildirfilter.c \
- ${FILESDIR}/extrapatch-webmail__folder.c \
- ${FILESDIR}/extrapatch-webmail__newmsg.c
-.endif
-
pre-everything::
@${ECHO_MSG} "===> --------------------------------------------------------"
@${ECHO_MSG} "===> Run 'make config' to (re)configure ${PKGNAME}"
diff --git a/mail/dovecot-devel/Makefile b/mail/dovecot-devel/Makefile
index db3605bfa3a2..d2741f74c7b7 100644
--- a/mail/dovecot-devel/Makefile
+++ b/mail/dovecot-devel/Makefile
@@ -66,7 +66,7 @@ CONFIGURE_ARGS+= --without-ssl
## IPv6 support
#
-.if defined(WITHOUT_IPV6) || ${OSVERSION} <= 400014
+.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
.endif
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index db3605bfa3a2..d2741f74c7b7 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -66,7 +66,7 @@ CONFIGURE_ARGS+= --without-ssl
## IPv6 support
#
-.if defined(WITHOUT_IPV6) || ${OSVERSION} <= 400014
+.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --disable-ipv6
.endif
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 846a3d00cb85..3193cf1955bc 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -551,10 +551,6 @@ PLIST_SUB+= DAEMON="@comment "
.error EXIMON_ONLY is not user settable
.endif
-.if ${OSVERSION} < 400014
-WITHOUT_IPV6= yes
-.endif
-
.if !defined(WITHOUT_IPV6)
SEDLIST+= -e 's,^\# (HAVE_IPV6=),\1,'
.endif
diff --git a/mail/listmanager/Makefile b/mail/listmanager/Makefile
index 23a381420377..a1e12b4701d5 100644
--- a/mail/listmanager/Makefile
+++ b/mail/listmanager/Makefile
@@ -11,24 +11,15 @@ CATEGORIES= mail
MASTER_SITES= http://www.listmanager.org/v${PORTVERSION}/ \
http://www.listmanager.org/
DISTNAME= ${PORTNAME}
-DIST_SUBDIR= ${PORTNAME}
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
-.if ${OSVERSION} >= 440000
EXTRACT_SUFX= .freebsd44
-.else
-EXTRACT_SUFX= .freebsd35
-.endif
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} INSTALL help.tar.gz listmanager.8 ack
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= gshapiro@FreeBSD.org
COMMENT= Fully-featured mailing list manager
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKDIR}
@@ -44,10 +35,10 @@ pre-patch:
(cd ${WRKSRC} && ${TAR} xfz help.tar.gz)
post-patch:
- @ for file in listmanager.cf pkg-message setup; do \
+ @ for f in listmanager.cf pkg-message setup; do \
${SED} -e "s|@@VARPREFIX@@|${LISTMANAGER_HOME}|g" \
-e "s|@@INSPREFIX@@|${PREFIX}|g" \
- < ${FILESDIR}/$$file.in > ${WRKSRC}/$$file; \
+ < ${FILESDIR}/$$f.in > ${WRKSRC}/$$f; \
done
do-install:
@@ -65,4 +56,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index e9d5153d97f1..dd170d3bd1da 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -295,7 +295,7 @@ USE_ICONV= yes
XML_USED= no
.endif
.if defined(MUTT_USES_NCURSES)
-.if ${OSVERSION} < 400000 || defined(WITH_MUTT_NCURSES_PORT)
+.if defined(WITH_MUTT_NCURSES_PORT)
MUTT_USES_NCURSES_PORT= yes
.endif
.endif
diff --git a/mail/postfix-current/pkg-install b/mail/postfix-current/pkg-install
index 9d50ad8ff1dd..c9367b344499 100644
--- a/mail/postfix-current/pkg-install
+++ b/mail/postfix-current/pkg-install
@@ -152,29 +152,15 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
diff --git a/mail/postfix/pkg-install b/mail/postfix/pkg-install
index 9d50ad8ff1dd..e5a832109dee 100644
--- a/mail/postfix/pkg-install
+++ b/mail/postfix/pkg-install
@@ -152,29 +152,16 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
+fi
diff --git a/mail/postfix1/pkg-install b/mail/postfix1/pkg-install
index 1ef1fb5b2089..e95e57d20a01 100644
--- a/mail/postfix1/pkg-install
+++ b/mail/postfix1/pkg-install
@@ -141,29 +141,15 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" n; then
- mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" n; then
+ mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
diff --git a/mail/postfix21/pkg-install b/mail/postfix21/pkg-install
index 45633f0dfc1b..ab10d3b4865b 100644
--- a/mail/postfix21/pkg-install
+++ b/mail/postfix21/pkg-install
@@ -155,29 +155,15 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
diff --git a/mail/postfix22/pkg-install b/mail/postfix22/pkg-install
index fe0c6c6f0243..30b1a214b64e 100644
--- a/mail/postfix22/pkg-install
+++ b/mail/postfix22/pkg-install
@@ -153,29 +153,15 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
diff --git a/mail/postfix23/pkg-install b/mail/postfix23/pkg-install
index 9d50ad8ff1dd..c9367b344499 100644
--- a/mail/postfix23/pkg-install
+++ b/mail/postfix23/pkg-install
@@ -152,29 +152,15 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
diff --git a/mail/postfix24/pkg-install b/mail/postfix24/pkg-install
index 9d50ad8ff1dd..e5a832109dee 100644
--- a/mail/postfix24/pkg-install
+++ b/mail/postfix24/pkg-install
@@ -152,29 +152,16 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
+fi
diff --git a/mail/postfix25/pkg-install b/mail/postfix25/pkg-install
index 9d50ad8ff1dd..e5a832109dee 100644
--- a/mail/postfix25/pkg-install
+++ b/mail/postfix25/pkg-install
@@ -152,29 +152,16 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
+fi
diff --git a/mail/postfix26/pkg-install b/mail/postfix26/pkg-install
index 9d50ad8ff1dd..e5a832109dee 100644
--- a/mail/postfix26/pkg-install
+++ b/mail/postfix26/pkg-install
@@ -152,29 +152,16 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
+fi
diff --git a/mail/postfix27/pkg-install b/mail/postfix27/pkg-install
index 9d50ad8ff1dd..e5a832109dee 100644
--- a/mail/postfix27/pkg-install
+++ b/mail/postfix27/pkg-install
@@ -152,29 +152,16 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
+fi
diff --git a/mail/postfix28/pkg-install b/mail/postfix28/pkg-install
index 9d50ad8ff1dd..e5a832109dee 100644
--- a/mail/postfix28/pkg-install
+++ b/mail/postfix28/pkg-install
@@ -152,29 +152,16 @@ replace() {
}
if [ x"$2" = xPOST-INSTALL -a -z "${PACKAGE_BUILDING}" ]; then
- if [ -x /sbin/sysctl ]; then
- OSVERSION=`/sbin/sysctl -n kern.osreldate`
- else
- OSVERSION=`/usr/sbin/sysctl -n kern.osreldate`
- fi
- if [ ${OSVERSION} -ge 400014 ]; then
- if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
- /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
- echo "#" > /etc/mail/mailer.conf
- echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
- echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "#" >> /etc/mail/mailer.conf
- echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
- fi
- else
- if yesno "Would you like to replace {sendmail,mailq,newaliases} with Postfix versions" n; then
- replace /usr/sbin/sendmail ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/mailq ${PKG_PREFIX}/sbin/sendmail
- replace /usr/bin/newaliases ${PKG_PREFIX}/sbin/sendmail
- echo "Done."
- fi
+ if yesno "Would you like to activate Postfix in /etc/mail/mailer.conf" ${DEFAULT_REPLACE_MAILERCONF}; then
+ /bin/mv -f /etc/mail/mailer.conf /etc/mail/mailer.conf.old
+ echo "#" > /etc/mail/mailer.conf
+ echo -n "# Execute the Postfix sendmail program" >> /etc/mail/mailer.conf
+ echo ", named ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "#" >> /etc/mail/mailer.conf
+ echo "sendmail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "send-mail ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "mailq ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
+ echo "newaliases ${PKG_PREFIX}/sbin/sendmail" >> /etc/mail/mailer.conf
fi
fi
+fi
diff --git a/mail/qpopper/Makefile b/mail/qpopper/Makefile
index 5987c6c1bb72..9105c7088fed 100644
--- a/mail/qpopper/Makefile
+++ b/mail/qpopper/Makefile
@@ -60,10 +60,6 @@ OPTIONS= APOP_ONLY "build with APOP authentication only" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400014
-WITHOUT_IPV6= yes
-.endif
-
.if !defined(WITHOUT_IPV6)
PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
PATCHFILES= qpopper4.0.9-ipv6-20060626.diff.gz