aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2007-07-30 09:42:28 +0000
commit4942ce5a7d8a3d0cbebaf4d202011850d1f7569f (patch)
treedb1f21912f461000d609ddcd5d130946bcfe9e09 /mail
parentb4be9b354e86bd790925c5a9a2e67df8ba20bc00 (diff)
downloadports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.tar.gz
ports-4942ce5a7d8a3d0cbebaf4d202011850d1f7569f.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/gmail-notify/Makefile3
-rw-r--r--mail/gmail-notify/files/Makefile.in (renamed from mail/gmail-notify/files/Makefile)2
-rw-r--r--mail/mailman/Makefile1
-rw-r--r--mail/mixminion/Makefile2
-rw-r--r--mail/py-spambayes/files/patch-python2557
-rw-r--r--mail/py-spf/Makefile1
-rw-r--r--mail/py-turbomail/Makefile2
-rw-r--r--mail/py-twistedMail/Makefile1
8 files changed, 67 insertions, 2 deletions
diff --git a/mail/gmail-notify/Makefile b/mail/gmail-notify/Makefile
index 4fba0aa38388..4dd2574e24a6 100644
--- a/mail/gmail-notify/Makefile
+++ b/mail/gmail-notify/Makefile
@@ -29,10 +29,11 @@ EXTRAS_WRKSRC!= cd ${PORTSDIR}/x11-toolkits/py-gnome-extras && ${MAKE} -V WRKSRC
post-patch:
${SED} -e 's|@DATADIR@|${DATADIR}|' ${FILESDIR}/gmail-notifier > ${WRKSRC}/gmail-notifier
+ ${SED} -e 's|@PYTHON_INCLUDEDIR@|${PYTHON_INCLUDEDIR}|' ${FILESDIR}/Makefile.in > ${WRKSRC}/Makefile
pre-configure:
${CP} ${EXTRAS_WRKSRC}/egg/tray/eggtrayicon.[ch] ${EXTRAS_WRKSRC}/egg/tray/trayicon* ${WRKSRC}
- ${CP} ${FILESDIR}/config.h ${FILESDIR}/Makefile ${WRKSRC}
+ ${CP} ${FILESDIR}/config.h ${WRKSRC}
${RM} ${WRKSRC}/pytrayicon.so
do-install:
diff --git a/mail/gmail-notify/files/Makefile b/mail/gmail-notify/files/Makefile.in
index e41173e1bc5c..f74e771bba28 100644
--- a/mail/gmail-notify/files/Makefile
+++ b/mail/gmail-notify/files/Makefile.in
@@ -1,7 +1,7 @@
# $FreeBSD$
# Makefile to build trayicon.so
-CFLAGS = `pkg-config --cflags gtk+-2.0 pygtk-2.0` -I${LOCALBASE}/include/python2.4/ -I. -Wall -I${LOCALBASE}/share/pygtk/2.0 -I${LOCALBASE}/libdata/pkgconfig -DEGG_COMPILATION -fPIC
+CFLAGS = `pkg-config --cflags gtk+-2.0 pygtk-2.0` -I@PYTHON_INCLUDEDIR@ -I. -Wall -I${LOCALBASE}/share/pygtk/2.0 -I${LOCALBASE}/libdata/pkgconfig -DEGG_COMPILATION -fPIC
LDFLAGS = `pkg-config --libs gtk+-2.0 pygtk-2.0`
DEFS_DIR= ${LOCALBASE}/share/pygtk/2.0/defs/
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index effc37829e84..00d09813b87c 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -161,6 +161,7 @@ pre-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
+ @${RM} -f ${MAILMANDIR}/pythonlib/*.egg-info
.for dir in cron scripts
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${MAILMANDIR}/${dir}
.endfor
diff --git a/mail/mixminion/Makefile b/mail/mixminion/Makefile
index fb01820e715c..72b01c420b4a 100644
--- a/mail/mixminion/Makefile
+++ b/mail/mixminion/Makefile
@@ -15,6 +15,8 @@ COMMENT= A Type III Anonymous Remailer
USE_OPENSSL= yes
USE_PYTHON= 2.0+
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_PKGVERSION= ${DISTVERSION}
MAN1= mixminion.1
MAN5= mixminiond.conf.5 mixminionrc.5
diff --git a/mail/py-spambayes/files/patch-python25 b/mail/py-spambayes/files/patch-python25
new file mode 100644
index 000000000000..5c35df105b78
--- /dev/null
+++ b/mail/py-spambayes/files/patch-python25
@@ -0,0 +1,57 @@
+--- spambayes/Corpus.py.orig Thu Jul 26 13:14:51 2007
++++ spambayes/Corpus.py Thu Jul 26 13:15:11 2007
+@@ -1,5 +1,7 @@
+ #! /usr/local/bin/python2.5
+
++from __future__ import generators
++
+ '''Corpus.py - Spambayes corpus management framework.
+
+ Classes:
+@@ -78,8 +80,6 @@
+
+ __author__ = "Tim Stone <tim@fourstonesExpressions.com>"
+ __credits__ = "Richie Hindle, Tim Peters, all the spambayes contributors."
+-
+-from __future__ import generators
+
+ try:
+ True, False
+--- spambayes/FileCorpus.py.orig Thu Jul 26 13:14:55 2007
++++ spambayes/FileCorpus.py Thu Jul 26 13:15:21 2007
+@@ -1,5 +1,7 @@
+ #! /usr/local/bin/python2.5
+
++from __future__ import generators
++
+ """FileCorpus.py - Corpus composed of file system artifacts
+
+ Classes:
+@@ -81,8 +83,6 @@
+
+ __author__ = "Tim Stone <tim@fourstonesExpressions.com>"
+ __credits__ = "Richie Hindle, Tim Peters, all the spambayes contributors."
+-
+-from __future__ import generators
+
+ from spambayes import Corpus
+ from spambayes import message
+--- spambayes/message.py.orig Thu Jul 26 13:15:02 2007
++++ spambayes/message.py Thu Jul 26 13:15:29 2007
+@@ -1,5 +1,7 @@
+ #! /usr/local/bin/python2.5
+
++from __future__ import generators
++
+ """message.py - Core Spambayes classes.
+
+ Classes:
+@@ -74,8 +76,6 @@
+
+ __author__ = "Tim Stone <tim@fourstonesExpressions.com>"
+ __credits__ = "Mark Hammond, Tony Meyer, all the spambayes contributors."
+-
+-from __future__ import generators
+
+ try:
+ True, False
diff --git a/mail/py-spf/Makefile b/mail/py-spf/Makefile
index a3bd9b14ba27..4e04493df9dd 100644
--- a/mail/py-spf/Makefile
+++ b/mail/py-spf/Makefile
@@ -20,6 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/DNS/__init__.py:${PORTSDIR}/dns/py-dns
DIST_SUBDIR= python
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= pyspf
DOCSDIR?= ${PREFIX}/share/doc/py-${PORTNAME}
diff --git a/mail/py-turbomail/Makefile b/mail/py-turbomail/Makefile
index 7e106f716f0c..b00d74316179 100644
--- a/mail/py-turbomail/Makefile
+++ b/mail/py-turbomail/Makefile
@@ -29,6 +29,8 @@ SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
USE_PYTHON= 2.4+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= TurboMail
+PYDISTUTILS_NOEGGINFO= yes # XXX convert easy_install support to bsd.python.mk's
EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
PYTURBOMAIL_EGG= TurboMail-${PORTVERSION}-py${PYTHON_VER}.egg
diff --git a/mail/py-twistedMail/Makefile b/mail/py-twistedMail/Makefile
index 79e8bb44b2b5..cb1e98f3e89a 100644
--- a/mail/py-twistedMail/Makefile
+++ b/mail/py-twistedMail/Makefile
@@ -22,5 +22,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Twisted_Mail
.include <bsd.port.mk>