aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2018-07-03 09:30:58 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2018-07-03 09:30:58 +0000
commit830abdbbbe024bdabc05419203db6b8f042f136c (patch)
tree092638217e3f3fcf8843826280f053991460062c /mail
parent7a343bbe42868a76ef1f5db9add6d955fe8ca853 (diff)
downloadports-830abdbbbe024bdabc05419203db6b8f042f136c.tar.gz
ports-830abdbbbe024bdabc05419203db6b8f042f136c.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/roundcube-identity_smtp/Makefile32
-rw-r--r--mail/roundcube-identity_smtp/distinfo3
-rw-r--r--mail/roundcube-identity_smtp/pkg-descr4
-rw-r--r--mail/roundcube-identity_smtp/pkg-plist12
5 files changed, 52 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6d15eba2708c..23949dbef645 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -604,6 +604,7 @@
SUBDIR += roundcube-contextmenu
SUBDIR += roundcube-groupvice
SUBDIR += roundcube-html5_notifier
+ SUBDIR += roundcube-identity_smtp
SUBDIR += roundcube-login_info
SUBDIR += roundcube-markasjunk2
SUBDIR += roundcube-mobilecube
diff --git a/mail/roundcube-identity_smtp/Makefile b/mail/roundcube-identity_smtp/Makefile
new file mode 100644
index 000000000000..f66230ab3971
--- /dev/null
+++ b/mail/roundcube-identity_smtp/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= identity_smtp
+PORTVERSION= 20170914
+CATEGORIES= mail
+PKGNAMEPREFIX= roundcube-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= meta@FreeBSD.org
+COMMENT= Roundcube plugin to setup different SMTP settings per identity
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= php:flavors
+NO_BUILD= yes
+NO_ARCH= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= deflomu
+GH_PROJECT= Roundcube-SMTP-per-Identity-Plugin
+GH_TAGNAME= b14e295
+
+PLUGINDIR= ${WWWDIR:S,/${PORTNAME}$$,,}/roundcube/plugins/${PORTNAME}
+RCDIR_REL= ${WWWDIR_REL:S,/${PORTNAME}$$,,}/roundcube
+PLIST_SUB= RCDIR_REL="${RCDIR_REL}"
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PLUGINDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${PLUGINDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/roundcube-identity_smtp/distinfo b/mail/roundcube-identity_smtp/distinfo
new file mode 100644
index 000000000000..1d118fec501c
--- /dev/null
+++ b/mail/roundcube-identity_smtp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530597809
+SHA256 (deflomu-Roundcube-SMTP-per-Identity-Plugin-20170914-b14e295_GH0.tar.gz) = c3aace65776386bc06dc0dc7c111386185fcbb82705e86b57328f894e3550567
+SIZE (deflomu-Roundcube-SMTP-per-Identity-Plugin-20170914-b14e295_GH0.tar.gz) = 4875
diff --git a/mail/roundcube-identity_smtp/pkg-descr b/mail/roundcube-identity_smtp/pkg-descr
new file mode 100644
index 000000000000..e88b12412a6d
--- /dev/null
+++ b/mail/roundcube-identity_smtp/pkg-descr
@@ -0,0 +1,4 @@
+This roundcube plugin allows to setup identities with different SMTP servers
+than server's default.
+
+WWW: https://github.com/deflomu/Roundcube-SMTP-per-Identity-Plugin
diff --git a/mail/roundcube-identity_smtp/pkg-plist b/mail/roundcube-identity_smtp/pkg-plist
new file mode 100644
index 000000000000..8c03758600bf
--- /dev/null
+++ b/mail/roundcube-identity_smtp/pkg-plist
@@ -0,0 +1,12 @@
+%%RCDIR_REL%%/plugins/identity_smtp/LICENSE
+%%RCDIR_REL%%/plugins/identity_smtp/README.markdown
+%%RCDIR_REL%%/plugins/identity_smtp/composer.json
+%%RCDIR_REL%%/plugins/identity_smtp/crowdin.yaml
+%%RCDIR_REL%%/plugins/identity_smtp/identity_smtp.js
+%%RCDIR_REL%%/plugins/identity_smtp/identity_smtp.php
+%%RCDIR_REL%%/plugins/identity_smtp/localization/ca_ES.inc
+%%RCDIR_REL%%/plugins/identity_smtp/localization/de_DE.inc
+%%RCDIR_REL%%/plugins/identity_smtp/localization/en_US.inc
+%%RCDIR_REL%%/plugins/identity_smtp/localization/es_ES.inc
+%%RCDIR_REL%%/plugins/identity_smtp/localization/fr_FR.inc
+%%RCDIR_REL%%/plugins/identity_smtp/localization/ja_JP.inc