aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPeter Wemm <peter@FreeBSD.org>1998-07-08 10:49:32 +0000
committerPeter Wemm <peter@FreeBSD.org>1998-07-08 10:49:32 +0000
commit8a4bfb5b1609956e03738c2689ffa7b7401ee984 (patch)
treea9710264437ad74ba9e1cbc262e879ff9fa3b5d4 /mail
parent3ecb0f40c135a77328d6f9a6147e866450fd897c (diff)
downloadports-8a4bfb5b1609956e03738c2689ffa7b7401ee984.tar.gz
ports-8a4bfb5b1609956e03738c2689ffa7b7401ee984.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/exmh2/Makefile9
-rw-r--r--mail/exmh2/distinfo4
-rw-r--r--mail/exmh2/pkg-plist1
-rw-r--r--mail/exmh2/scripts/install4
4 files changed, 13 insertions, 5 deletions
diff --git a/mail/exmh2/Makefile b/mail/exmh2/Makefile
index 6ff657ab6c3d..843d47dd404a 100644
--- a/mail/exmh2/Makefile
+++ b/mail/exmh2/Makefile
@@ -3,7 +3,7 @@
# Date released: 1 Jan 97
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.27 1998/03/20 09:28:05 markm Exp $
+# $Id: Makefile,v 1.28 1998/07/03 23:07:01 steve Exp $
#
DISTNAME= exmh-2.0.2
@@ -11,18 +11,21 @@ CATEGORIES= mail tk80
MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/exmh/
EXTRACT_SUFX= .tar.Z
-PATCH_SITES= http://sunscript.sun.com/exmh/patches/2.0.1/
+PATCH_SITES= http://www.beedub.com/exmh/patches/2.0.2/ \
+ http://www.beedub.com/exmh/patches/2.0.1/
#PATCHFILES= utils.patch folderNew.patch extrasInit.patch exec.patch \
# app-defaults.patch pgpMisc.patch seditMime.patch mime.patch \
# bindings.patch html_bindings.patch find.patch mh.patch \
# pgp.patch
# User contributed and "new features". Some not useable as-is.
-PATCHFILES+= seditpost.patch inc.patch next.patch
+PATCHFILES+= seditpost.patch inc.patch next.patch \
+ uri.patch extrasInit.patch folder.patch seditExtras.patch
# XXX pgpExec.patch has got confused paths (supplied as patch-as)
# XXX newsgroups.patch is relative to a different directory (patch-at)
# XXX MDN.patch doesn't apply (patch-au)
# XXX post.from.patch doesn't apply (patch-av)
+# XXX date.patch doesn't apply (spammed whitespace) (patch-ax)
.if defined(PATCH_DEBUG)
PATCH_DIST_ARGS= -d ${WRKSRC}/lib -E ${PATCH_DIST_STRIP}
diff --git a/mail/exmh2/distinfo b/mail/exmh2/distinfo
index 2209426187ff..a5be6f423f3e 100644
--- a/mail/exmh2/distinfo
+++ b/mail/exmh2/distinfo
@@ -2,3 +2,7 @@ MD5 (exmh-2.0.2/exmh-2.0.2.tar.Z) = 2e4d0e7aa57570c9c68c7383a201bd08
MD5 (exmh-2.0.2/seditpost.patch) = a3181a3878bb5705762b4f4954ea6c51
MD5 (exmh-2.0.2/inc.patch) = 075c71257a13c90d7e77ee46afa7b55b
MD5 (exmh-2.0.2/next.patch) = 9286b98e2967654cf864f0a889bbe8d7
+MD5 (exmh-2.0.2/uri.patch) = 4957606b4c81a28c17df0ad7a72662e5
+MD5 (exmh-2.0.2/extrasInit.patch) = 4b564e5398a404fb467cba53355e8f0b
+MD5 (exmh-2.0.2/folder.patch) = 62255d71c19026a15a3d53c1c72ed03a
+MD5 (exmh-2.0.2/seditExtras.patch) = 1b2c50f9e81444df0e81b0473005ae52
diff --git a/mail/exmh2/pkg-plist b/mail/exmh2/pkg-plist
index f91e2e96c626..1e0f1dc586ae 100644
--- a/mail/exmh2/pkg-plist
+++ b/mail/exmh2/pkg-plist
@@ -2,6 +2,7 @@ bin/exmh
bin/exmh-async
bin/exmh-bg
bin/ftp.expect
+lib/exmh-2.0.2/PgpDecryptExpect
lib/exmh-2.0.2/addr.tcl
lib/exmh-2.0.2/aliases.tcl
lib/exmh-2.0.2/app-defaults
diff --git a/mail/exmh2/scripts/install b/mail/exmh2/scripts/install
index 796553a06b82..1ff93a3c18d1 100644
--- a/mail/exmh2/scripts/install
+++ b/mail/exmh2/scripts/install
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# $Id: install,v 1.1.1.1 1996/10/10 15:00:53 peter Exp $
+# $Id: install,v 1.2 1996/12/31 21:27:03 peter Exp $
#
VERSION="`sed -ne 's/^set vers \(.*\)/\1/p' ${WRKSRC}/exmh.install`"
@@ -23,7 +23,7 @@ then
mkdir ${PREFIX}/lib/exmh-${VERSION}
fi
-LIBFILES='lib/*.tcl lib/*.bitmap lib/help.* lib/tclIndex lib/app-defaults* lib/*.mask lib/*.exp lib/mime.types lib/*.au'
+LIBFILES='lib/*.tcl lib/*.bitmap lib/help.* lib/tclIndex lib/app-defaults lib/app-defaults-* lib/*.mask lib/*.exp lib/mime.types lib/*.au lib/PgpDecryptExpect'
echo "install -c -o bin -g bin -m 444 ${LIBFILES} ${PREFIX}/lib/exmh-${VERSION}"
install -c -o bin -g bin -m 444 ${LIBFILES} ${PREFIX}/lib/exmh-${VERSION}