aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-18 19:53:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-10-18 19:53:05 +0000
commitab01d529d276e79f99a3b5146347f7ae474abe58 (patch)
tree6283eadac970460ac8fb6749b1075d6f845151de /mail
parentbf675463be004753349a4b290fe0277021364ce8 (diff)
downloadports-ab01d529d276e79f99a3b5146347f7ae474abe58.tar.gz
ports-ab01d529d276e79f99a3b5146347f7ae474abe58.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Mail-Box-IMAP4/Makefile28
-rw-r--r--mail/p5-Mail-Box-IMAP4/distinfo3
-rw-r--r--mail/p5-Mail-Box-IMAP4/pkg-descr8
-rw-r--r--mail/p5-Mail-Box-IMAP4/pkg-plist27
5 files changed, 67 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 006b1e1b1480..44ab0981aaa0 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -379,6 +379,7 @@
SUBDIR += p5-Mail-Audit
SUBDIR += p5-Mail-Audit-Attach
SUBDIR += p5-Mail-Box
+ SUBDIR += p5-Mail-Box-IMAP4
SUBDIR += p5-Mail-Box-IMAP4-SSL
SUBDIR += p5-Mail-Box-Parser-C
SUBDIR += p5-Mail-Bulkmail
diff --git a/mail/p5-Mail-Box-IMAP4/Makefile b/mail/p5-Mail-Box-IMAP4/Makefile
new file mode 100644
index 000000000000..e776cb55fe0a
--- /dev/null
+++ b/mail/p5-Mail-Box-IMAP4/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Mail-Box-IMAP4
+PORTVERSION= 3.003
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Handle IMAP4 folders as client
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Digest-HMAC>=0:security/p5-Digest-HMAC \
+ p5-Mail-Box>=3:mail/p5-Mail-Box \
+ p5-Mail-IMAPClient>=0:mail/p5-Mail-IMAPClient \
+ p5-Mail-Message>=3:mail/p5-Mail-Message \
+ p5-Mail-Transport>=3:mail/p5-Mail-Transport
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Box-IMAP4/distinfo b/mail/p5-Mail-Box-IMAP4/distinfo
new file mode 100644
index 000000000000..d9edeb72f31d
--- /dev/null
+++ b/mail/p5-Mail-Box-IMAP4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539194728
+SHA256 (Mail-Box-IMAP4-3.003.tar.gz) = 15600a571043a55e84df3e00c6ffb82a22881f201042cf7894cbb2d41e7bdd96
+SIZE (Mail-Box-IMAP4-3.003.tar.gz) = 42724
diff --git a/mail/p5-Mail-Box-IMAP4/pkg-descr b/mail/p5-Mail-Box-IMAP4/pkg-descr
new file mode 100644
index 000000000000..ef12872aca54
--- /dev/null
+++ b/mail/p5-Mail-Box-IMAP4/pkg-descr
@@ -0,0 +1,8 @@
+Maintain a folder which has its messages stored on a remote server. The
+communication between the client application and the server is implemented using
+the IMAP4 protocol. This class uses Mail::Transport::IMAP4 to hide the transport
+of information, and focusses solely on the correct handling of messages within a
+IMAP4 folder. More than one IMAP4 folder can be handled by one single IMAP4
+connection.
+
+WWW: https://metacpan.org/release/Mail-Box-IMAP4
diff --git a/mail/p5-Mail-Box-IMAP4/pkg-plist b/mail/p5-Mail-Box-IMAP4/pkg-plist
new file mode 100644
index 000000000000..ef630a9b4084
--- /dev/null
+++ b/mail/p5-Mail-Box-IMAP4/pkg-plist
@@ -0,0 +1,27 @@
+%%SITE_PERL%%/Mail/Box/IMAP4.pm
+%%SITE_PERL%%/Mail/Box/IMAP4.pod
+%%SITE_PERL%%/Mail/Box/IMAP4/Head.pm
+%%SITE_PERL%%/Mail/Box/IMAP4/Head.pod
+%%SITE_PERL%%/Mail/Box/IMAP4/Message.pm
+%%SITE_PERL%%/Mail/Box/IMAP4/Message.pod
+%%SITE_PERL%%/Mail/Server/IMAP4.pm
+%%SITE_PERL%%/Mail/Server/IMAP4.pod
+%%SITE_PERL%%/Mail/Server/IMAP4/Fetch.pm
+%%SITE_PERL%%/Mail/Server/IMAP4/Fetch.pod
+%%SITE_PERL%%/Mail/Server/IMAP4/List.pm
+%%SITE_PERL%%/Mail/Server/IMAP4/List.pod
+%%SITE_PERL%%/Mail/Server/IMAP4/Search.pm
+%%SITE_PERL%%/Mail/Server/IMAP4/Search.pod
+%%SITE_PERL%%/Mail/Server/IMAP4/User.pm
+%%SITE_PERL%%/Mail/Server/IMAP4/User.pod
+%%SITE_PERL%%/Mail/Transport/IMAP4.pm
+%%SITE_PERL%%/Mail/Transport/IMAP4.pod
+%%PERL5_MAN3%%/Mail::Box::IMAP4.3.gz
+%%PERL5_MAN3%%/Mail::Box::IMAP4::Head.3.gz
+%%PERL5_MAN3%%/Mail::Box::IMAP4::Message.3.gz
+%%PERL5_MAN3%%/Mail::Server::IMAP4.3.gz
+%%PERL5_MAN3%%/Mail::Server::IMAP4::Fetch.3.gz
+%%PERL5_MAN3%%/Mail::Server::IMAP4::List.3.gz
+%%PERL5_MAN3%%/Mail::Server::IMAP4::Search.3.gz
+%%PERL5_MAN3%%/Mail::Server::IMAP4::User.3.gz
+%%PERL5_MAN3%%/Mail::Transport::IMAP4.3.gz