aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-13 22:08:27 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-13 22:08:27 +0000
commitc18c7b4aec2f3fbb5fe6e343a19af2420be8afe4 (patch)
tree9a25e213d4a9b3a8b74de4f12ee2364ccd9750b3 /mail
parentb6f50e35e222a63516fea6f9c509850c6d214c48 (diff)
downloadports-c18c7b4aec2f3fbb5fe6e343a19af2420be8afe4.tar.gz
ports-c18c7b4aec2f3fbb5fe6e343a19af2420be8afe4.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/bogofilter/Makefile6
-rw-r--r--mail/bogofilter/distinfo4
-rw-r--r--mail/bogofilter/files/patch-tests-nolocalconfig68
3 files changed, 74 insertions, 4 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 007cc0c5f424..9d7b7d8cbec7 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bogofilter
-PORTVERSION= 0.96.5
+PORTVERSION= 0.96.6
PORTREVISION?= 0
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -15,11 +15,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER?= matthias.andree@gmx.de
COMMENT= Fast, teachable, learning spam detector
+LIB_DEPENDS?= db-4.3:${PORTSDIR}/databases/db43
+
OPTIONS= GSL "Link with system-wide GSL dynamically (recommended)" on
OPTIONS+= UNICODE "Normalize tokens to Unicode (UTF-8)" on
-LIB_DEPENDS?= db-4.3:${PORTSDIR}/databases/db43
-
CONFLICTS?= bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
USE_BZIP2= yes
diff --git a/mail/bogofilter/distinfo b/mail/bogofilter/distinfo
index dedf4784334f..8ca521ef0008 100644
--- a/mail/bogofilter/distinfo
+++ b/mail/bogofilter/distinfo
@@ -1 +1,3 @@
-MD5 (bogofilter-0.96.5.tar.bz2) = 77ec9fc84f51a183800a615b59c97da8
+MD5 (bogofilter-0.96.6.tar.bz2) = 24ce45bac5dc7e8ec6bb2f68e5d64a73
+SHA256 (bogofilter-0.96.6.tar.bz2) = b74d6889fa11a1b5b9b59826de4f859cebe9088786728c630a74465da36831ab
+SIZE (bogofilter-0.96.6.tar.bz2) = 746286
diff --git a/mail/bogofilter/files/patch-tests-nolocalconfig b/mail/bogofilter/files/patch-tests-nolocalconfig
new file mode 100644
index 000000000000..8551c6e96aa8
--- /dev/null
+++ b/mail/bogofilter/files/patch-tests-nolocalconfig
@@ -0,0 +1,68 @@
+--- ./src/tests/t.maint 16 Sep 2005 20:57:29 -0000 1.32
++++ ./src/tests/t.maint 13 Nov 2005 16:45:48 -0000 1.33
+@@ -36,10 +36,10 @@
+ echo initial: `$BOGOUTIL -d $WORDLIST | wc -l` > $OUT
+
+ for cnt in 0 1 2 3 ; do
+- $BOGOUTIL -c $cnt -m $WORDLIST
+- echo "count $cnt ->" `$BOGOUTIL -d $WORDLIST | wc -l` >> $OUT
++ $BOGOUTIL -C -c $cnt -m $WORDLIST
++ echo "count $cnt ->" `$BOGOUTIL -C -d $WORDLIST | wc -l` >> $OUT
+ if [ $verbose -ne 0 ]; then
+- $BOGOUTIL -d $WORDLIST > $OUT.$cnt
++ $BOGOUTIL -C -d $WORDLIST > $OUT.$cnt
+ fi
+ done
+
+--- ./src/tests/t.regtest 16 Mar 2005 12:18:22 -0000 1.9
++++ ./src/tests/t.regtest 13 Nov 2005 16:45:48 -0000 1.10
+@@ -30,10 +30,10 @@
+ fi
+
+ if [ -f $BOGOFILTER_DIR/goodlist.${DB_EXT} ] ; then
+- g=`$BOGOUTIL -d $BOGOFILTER_DIR/goodlist.${DB_EXT} | grep -v " 0 " | tee $TMPDIR/good.$T.out | wc -l`
+- s=`$BOGOUTIL -d $BOGOFILTER_DIR/spamlist.${DB_EXT} | grep -v " 0 " | tee $TMPDIR/spam.$T.out | wc -l`
++ g=`$BOGOUTIL -C -d $BOGOFILTER_DIR/goodlist.${DB_EXT} | grep -v " 0 " | tee $TMPDIR/good.$T.out | wc -l`
++ s=`$BOGOUTIL -C -d $BOGOFILTER_DIR/spamlist.${DB_EXT} | grep -v " 0 " | tee $TMPDIR/spam.$T.out | wc -l`
+ else
+- $BOGOUTIL -d $BOGOFILTER_DIR/wordlist.${DB_EXT} > $TMPDIR/word.$T.out
++ $BOGOUTIL -C -d $BOGOFILTER_DIR/wordlist.${DB_EXT} > $TMPDIR/word.$T.out
+ g=`grep -v " 0$" < $TMPDIR/word.$T.out | tee $TMPDIR/good.$T.out | wc -l`
+ s=`grep -v " 0 " < $TMPDIR/word.$T.out | tee $TMPDIR/spam.$T.out | wc -l`
+ fi
+--- ./src/tests/t.systest 16 Mar 2005 12:18:22 -0000 1.14
++++ ./src/tests/t.systest 13 Nov 2005 16:45:48 -0000 1.15
+@@ -57,7 +57,7 @@
+ $BOGOFILTER $OPTS -n < ${SYSTEST}/inputs/good.mbx
+ for f in $BOGOFILTER_DIR/*.${DB_EXT} ; do
+ n=`basename $f .${DB_EXT}`
+- $BOGOUTIL -d $BOGOFILTER_DIR/$n.${DB_EXT} > $BOGOFILTER_DIR/$n.txt
++ $BOGOUTIL -C -d $BOGOFILTER_DIR/$n.${DB_EXT} > $BOGOFILTER_DIR/$n.txt
+ done
+ if [ $verbose -ne 0 ]; then
+ ls -l $BOGOFILTER_DIR/*list.txt
+--- ./src/tests/t.MH 16 Mar 2005 12:18:22 -0000 1.12
++++ ./src/tests/t.MH 13 Nov 2005 16:45:48 -0000 1.13
+@@ -24,7 +24,7 @@
+ $BOGOFILTER -C -D -s $v -B $TMPDIR/spam
+ wordlist=".MSG_COUNT Lotus Magazine Min Service connection more most set that unsubscribe"
+
+-$BOGOUTIL -w $WORDLIST $wordlist >$OUT || rm -f $OUT
++$BOGOUTIL -C -w $WORDLIST $wordlist >$OUT || rm -f $OUT
+
+ if [ $verbose -eq 0 ]; then
+ cmp $CORRECT $OUT
+--- ./src/tests/t.bulkmode 29 Jun 2005 03:11:25 -0000 1.18
++++ ./src/tests/t.bulkmode 13 Nov 2005 16:45:48 -0000 1.19
+@@ -27,9 +27,11 @@
+ }
+
+ if [ -d $BOGOFILTER_DIR ] ; then rm -f $BOGOFILTER_DIR/* ; else : ; fi
++
+ mkdir -p $BOGOFILTER_DIR
+ $BOGOFILTER -C -s < ${SYSTEST}/inputs/spam.mbx
+ $BOGOFILTER -C -n < ${SYSTEST}/inputs/good.mbx
++
+ #for f in $BOGOFILTER_DIR/*.${DB_EXT} ; do
+ # o=`echo $f | sed s@.${DB_EXT}@.txt@`
+ # $BOGOUTIL -d $f > $o