aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:32:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-04 10:32:49 +0000
commit7117487ddb38fee864033b869ed6b65f7094a29c (patch)
tree72a8cb20efc8916ac1fe7ec801ddfe0d2d0136bf /mail
parent1f1a5f1e120cc7ffd0b13ccf1e289a157ca7e5dd (diff)
downloadports-7117487ddb38fee864033b869ed6b65f7094a29c.tar.gz
ports-7117487ddb38fee864033b869ed6b65f7094a29c.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/imap-uw/Makefile32
-rw-r--r--mail/lbdb/Makefile25
-rw-r--r--mail/mew/Makefile22
-rw-r--r--mail/mimedefang/Makefile16
-rw-r--r--mail/offlineimap/Makefile23
-rw-r--r--mail/py-ppolicy/Makefile25
-rw-r--r--mail/qsf/Makefile23
-rw-r--r--mail/quickml/Makefile18
-rw-r--r--mail/rabl_client/Makefile16
-rw-r--r--mail/rabl_server/Makefile18
-rw-r--r--mail/scam-backscatter/Makefile21
-rw-r--r--mail/spmfilter-clamav/Makefile10
-rw-r--r--mail/spmfilter-spamassassin/Makefile8
-rw-r--r--mail/spmfilter/Makefile39
-rw-r--r--mail/sqlgrey/Makefile32
-rw-r--r--mail/ssmtp/Makefile23
16 files changed, 149 insertions, 202 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 349424f2be76..c649bd9a59ad 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: imap-uw
-# Date created: 9 Jan 1997
-# Whom: pst
-#
+# Created by: pst
# $FreeBSD$
-#
PORTNAME= imap
PORTVERSION= 2007f
@@ -37,23 +33,25 @@ ALL_TARGET= bsf
# This port must have the same SSL settings as mail/cclient, which it depends on
# To make MBX format the default mailbox format, change the settings of cclient
-OPTIONS= SSL "Compile with SSL support" on \
- SSL_AND_PLAINTEXT "Allow plain text passwords and SSL" off \
- DRAC "Dynamically open MTA for relaying" off \
- NETSCAPE_BRAIN_DAMAGE "See Makefile for documentation" off
+OPTIONS_DEFINE= SSL SSL_AND_PLAINTEXT DRAC NETSCAPE_BRAIN_DAMAGE DOCS
+OPTIONS_DEFAULT= SSL
+SSL_DESC= Compile with SSL support
+SSL_AND_PLAINTEXT_DESC= Allow plain text passwords and SSL
+DRAC_DESC= Dynamically open MTA for relaying
+NETSCAPE_BRAIN_DAMAGE_DESC= See Makefile for documentation
.include <bsd.port.options.mk>
-.if defined(WITH_DRAC)
+.if ${PORT_OPTIONS:MDRAC}
BUILD_DEPENDS= ${LOCALBASE}/lib/libdrac.a:${PORTSDIR}/mail/drac
MAKE_ARGS+= WITH_DRAC=yes
.endif
-.if defined(WITHOUT_SSL)
+.if ! ${PORT_OPTIONS:MSSL}
MAKE_ARGS+= SSLTYPE=none SSLDIR=${OPENSSLBASE}
.else
USE_OPENSSL= yes
-.if defined(WITH_SSL_AND_PLAINTEXT)
+.if ${PORT_OPTIONS:MSSL_AND_PLAINTEXT}
MAKE_ARGS+= SSLTYPE=unix
.else
MAKE_ARGS+= SSLTYPE=unix.nopwd
@@ -61,7 +59,7 @@ MAKE_ARGS+= SSLTYPE=unix.nopwd
.endif
# Define this to get somewhat better interoperability with Netscape.
-.if defined(WITH_NETSCAPE_BRAIN_DAMAGE)
+.if ${PORT_OPTIONS:MNETSCAPE_BRAIN_DAMAGE}
MAKE_ARGS+= WITH_NETSCAPE_BRAIN_DAMAGE=yes
.endif
# See src/imapd/Makefile for more information about these three options.
@@ -74,7 +72,7 @@ post-patch:
pre-build:
@${SH} ${PKGREQ}.rev ${LOCALBASE}/include/c-client/portrevision.h ${PORTVERSION}
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${SH} ${PKGREQ}.ssl ${LOCALBASE}/include/c-client/portrevision.h yes
.else
@${SH} ${PKGREQ}.ssl ${LOCALBASE}/include/c-client/portrevision.h no
@@ -100,7 +98,7 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.if defined(WITH_DRAC)
+.if ${PORT_OPTIONS:MDRAC}
@${ECHO} "================================================================================"
@${ECHO} "To have DRAC working, you must create ${PREFIX}/etc/dracd.host, containing"
@${ECHO} "the hostname of the DRAC server:"
@@ -108,7 +106,7 @@ post-install:
@${ECHO} "localhost"
@${ECHO} "================================================================================"
.endif
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
@${ECHO}
@${ECHO} "To create and install a new SSL certificate for imapd and ipop3d, type \"make"
@${ECHO} "cert\". Or install manually in ${PREFIX}/certs."
@@ -119,7 +117,7 @@ post-install:
@${ECHO} "imaps stream tcp nowait root ${PREFIX}/libexec/imapd imapd"
@${ECHO} "================================================================================"
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} -m 0755 -p ${DOCSDIR}
@${TAR} -C ${WRKSRC}/docs -cf - . | \
(umask 022; ${TAR} -C ${DOCSDIR} -xf -)
diff --git a/mail/lbdb/Makefile b/mail/lbdb/Makefile
index 8a3181175f34..1cae65f6a444 100644
--- a/mail/lbdb/Makefile
+++ b/mail/lbdb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lbdb
-# Date created: 2 February 2000
-# Whom: mwest@uct.ac.za
-#
+# Created by: mwest@uct.ac.za
# $FreeBSD$
-#
PORTNAME= lbdb
PORTVERSION= 0.37
@@ -17,9 +13,10 @@ COMMENT= Set of tools for use with mutt's external mail address query feature
RUN_DEPENDS= gsed:${PORTSDIR}/textproc/gsed \
p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
-OPTIONS= ABOOK "Enable abook address book support" off \
- EVOLUTION "Enable Ximan Evolution support" off \
- GPG "Enable GNU Privacy Guard support" off
+OPTIONS_DEFINE= ABOOK EVOLUTION GPG
+ABOOK_DESC= abook address book support
+EVOLUTION_DESC= Ximan Evolution support
+GPG_DESC= GNU Privacy Guard support
WRKSRC= ${WRKDIR}/lbdb-${PORTVERSION}
GNU_CONFIGURE= yes
@@ -28,13 +25,13 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --sysconfdir=${PREFIX}/etc \
USE_GMAKE= yes
USE_PERL5= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if exists (/usr/bin/getent)
WITH_GETENT= yes
.endif
-.if defined(WITH_GPG)
+.if ${PORT_OPTIONS:MGPG}
BUILD_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
PLIST_SUB+= GPG=""
@@ -42,7 +39,7 @@ PLIST_SUB+= GPG=""
PLIST_SUB+= GPG="@comment "
.endif
-.if defined(WITH_ABOOK)
+.if ${PORT_OPTIONS:MABOOK}
BUILD_DEPENDS+= abook:${PORTSDIR}/mail/abook
RUN_DEPENDS+= abook:${PORTSDIR}/mail/abook
PLIST_SUB+= ABOOK=""
@@ -50,7 +47,7 @@ PLIST_SUB+= ABOOK=""
PLIST_SUB+= ABOOK="@comment "
.endif
-.if defined(WITH_EVOLUTION)
+.if ${PORT_OPTIONS:MEVOLUTION}
BUILD_DEPENDS+= evolution:${PORTSDIR}/mail/evolution
RUN_DEPENDS+= evolution:${PORTSDIR}/mail/evolution
PLIST_SUB+= EVOLUTION=""
@@ -58,7 +55,7 @@ PLIST_SUB+= EVOLUTION=""
PLIST_SUB+= EVOLUTION="@comment "
.endif
-.if defined(WITH_GETENT)
+.if ${PORT_OPTIONS:MGETENT}
PLIST_SUB+= GETENT=""
.else
PLIST_SUB+= GETENT="@comment "
@@ -70,4 +67,4 @@ MAN1= nodelist2lbdb.1 lbdbq.1 lbdb-fetchaddr.1 lbdb_dotlock.1 \
post-patch:
${REINPLACE_CMD} -e 's/sed/gsed/' ${WRKSRC}/m_muttalias.sh.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/mew/Makefile b/mail/mew/Makefile
index 8b4aa567567d..d43a69d35e98 100644
--- a/mail/mew/Makefile
+++ b/mail/mew/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: Mew
-# Date created: 21 November 1997
-# Whom: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
-# Hiroto Kagotani <hiroto.kagotani@gmail.com>
-#
+# Created by: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
# $FreeBSD$
-#
PORTNAME= mew
PORTVERSION= 6.5
@@ -16,14 +11,15 @@ PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= hiroto.kagotani@gmail.com
COMMENT= Messaging in the Emacs World for emacs
-OPTIONS= DATABASE "Database feature support (with Ruby & Sqlite3)" on
+OPTIONS_DEFINE= DATABASE DOCS
+DATABASE_DESC= Database feature support (with Ruby & Sqlite3)
# emacs port setup
USE_EMACS= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_DATABASE)
+.if ${PORT_OPTIONS:MDATABASE}
RUN_DEPENDS= rubygem-sqlite3>=0:${PORTSDIR}/databases/rubygem-sqlite3
.endif
@@ -38,7 +34,7 @@ CONFIGURE_ARGS= --with-elispdir=${LOCALBASE}/${EMACS_SITE_LISPDIR}/mew \
# target name for make build and install
ALL_TARGET= all info
INSTALL_TARGET= install
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
ALL_TARGET+= jinfo
INSTALL_TARGET+=install-jinfo
.endif
@@ -46,12 +42,12 @@ INSTALL_TARGET+=install-jinfo
# manuals
MAN1= cmew.1 mew-pinentry.1 mewcat.1 mewdecode.1 mewencode.1 mewest.1 mewl.1 smew.1 incm.1
INFO= mew
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
INFO+= mew.ja
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} ; \
${INSTALL_DATA} 00* dot.* ${DOCSDIR}/ ; \
@@ -60,4 +56,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index 51498a7c2933..df8fd61d0c08 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mimedefang
-# Date created: 13 May 2002
-# Whom: Andrey V. Pevnev <andrey@mgul.ac.ru>
-#
+# Created by: Andrey V. Pevnev <andrey@mgul.ac.ru>
# $FreeBSD$
-#
PORTNAME= mimedefang
PORTVERSION= 2.73
@@ -23,7 +19,9 @@ BUILD_DEPENDS= \
p5-Mail-SpamAssassin>=3.0:${PORTSDIR}/mail/p5-Mail-SpamAssassin
RUN_DEPENDS:= ${BUILD_DEPENDS}
-OPTIONS= CLAMAV "Enable Clamav" on
+OPTIONS_DEFINE= CLAMAV EXAMPLES DOCS
+OPTIONS_DEFAULT= CLAMAV
+CLAMAV_DESC= Enable Clamav
USE_PERL5= yes
GNU_CONFIGURE= yes
@@ -61,7 +59,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
CONFIGURE_ARGS+= --with-milterinc=${LOCALBASE}/include --with-milterlib=${LOCALBASE}/lib
.endif
-.if defined (MIMEDEFANG_DISABLE_CLAMAV) || defined(WITHOUT_CLAMAV)
+.if defined (MIMEDEFANG_DISABLE_CLAMAV) || ! ${PORT_OPTIONS:MCLAMAV}
CONFIGURE_ARGS+= --disable-antivirus \
--disable-clamav \
--disable-clamd
@@ -79,7 +77,7 @@ pre-install:
post-install:
@${REINPLACE_CMD} -e 's,%%CHMOD%%,${CHMOD},g' ${WRKSRC}/examples/init-script
@${INSTALL_SCRIPT} ${WRKSRC}/examples/init-script ${PREFIX}/etc/rc.d/mimedefang
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README* ${DOCSDIR}/
.endif
@@ -89,7 +87,7 @@ post-install:
fi
.endfor
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}/examples/ && ${INSTALL_DATA} stream-by-domain-filter \
suggested-minimum-filter-for-windows-clients README ${EXAMPLESDIR}/
diff --git a/mail/offlineimap/Makefile b/mail/offlineimap/Makefile
index 9caa033c592c..853dad58b421 100644
--- a/mail/offlineimap/Makefile
+++ b/mail/offlineimap/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: offlineimap
-# Date created: 08 Aug 2002
-# Whom: nbm
-#
+# Created by: nbm
# $FreeBSD$
-#
PORTNAME= offlineimap
DISTVERSION= 6.5.4
@@ -22,7 +18,8 @@ LICENSE_COMB= dual
LICENSE_FILE_GPLv2=${WRKSRC}/COPYING
-OPTIONS= HTMLDOCS "Generate HTML documentation" Off
+OPTIONS_DEFINE= HTMLDOCS EXAMPLES
+HTMLDOCS_DESC= Generate HTML documentation
WRKSRC= ${WRKDIR}/${GITHUB_USER}-${PORTNAME}-${GITHUB_HASH}
SUB_FILES= pkg-message
@@ -53,20 +50,20 @@ EXAMPLE_DIRS= ${EXAMPLE_FILES:H:O:u:N.}
.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS) && defined(WITH_HTMLDOCS)
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MHTMLDOCS}
BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
DOC_FILES:= ${DOC_FILES} ${DOC_FILES:M*.rst:S/.rst$/.html/}
.endif
# This is needed for pkg-message.in
-.if defined(NOPORTEXAMPLES)
-SUB_LIST+= PORTEXAMPLES="@comment "
-.else
+.if ${PORT_OPTIONS:MEXAMPLES}
SUB_LIST+= PORTEXAMPLES=""
+.else
+SUB_LIST+= PORTEXAMPLES="@comment "
.endif
post-build:
-.if !defined(NOPORTDOCS) && defined(WITH_HTMLDOCS)
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MHTMLDOCS}
.for r in ${DOC_FILES:M*.rst}
@${ECHO} "Translating ${r} to HTML..."
@rst2html ${WRKSRC}/${r} ${WRKSRC}/${r:R}.html
@@ -74,7 +71,7 @@ post-build:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@for i in ${DOC_DIRS}; do \
${MKDIR} ${DOCSDIR}/$$i; \
@@ -84,7 +81,7 @@ post-install:
${INSTALL_DATA} $$i ${DOCSDIR}/$$i; \
done
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@for i in ${EXAMPLE_DIRS}; do \
${MKDIR} ${EXAMPLESDIR}/$$i; \
diff --git a/mail/py-ppolicy/Makefile b/mail/py-ppolicy/Makefile
index 94aa3827e680..13932866f92d 100644
--- a/mail/py-ppolicy/Makefile
+++ b/mail/py-ppolicy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-ppolicy
-# Date created: 27 November 2008
-# Whom: Chifeng QU <chifeng@gmail.com>
-#
+# Created by: Chifeng QU <chifeng@gmail.com>
# $FreeBSD$
-#
PORTNAME= ppolicy
PORTVERSION= 2.6.6
@@ -27,24 +23,23 @@ DOCSDIR?= ${PREFIX}/share/doc/py-${PORTNAME}
SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
SUB_FILES= pkg-message
-OPTIONS= GeoIP "Use GeoIP support" On \
- LDAP "Use LDAP support" On \
- MYSQL "Use MySQL support" Off
+OPTIONS_DEFINE= GEOIP LDAP MYSQL DOCS
+OPTIONS_DEFAULT= GEOIP LDAP
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GeoIP)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/GeoIP.so:${PORTSDIR}/net/py-GeoIP
+.if ${PORT_OPTIONS:MGEOIP}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/GEOIP.so:${PORTSDIR}/net/py-GEOIP
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=0:${PORTSDIR}/databases/py-MySQLdb
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ldap2>=2.3.1:${PORTSDIR}/net/py-ldap2
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/MODULES ${DOCSDIR}
@@ -57,4 +52,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ppolicy.tap ${PREFIX}/sbin
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
index 8387e0e8c7c2..165c1c03479f 100644
--- a/mail/qsf/Makefile
+++ b/mail/qsf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qsf
-# Date created: 15 January 2004
-# Whom: liamfoy@sepulcrum.org
-#
+# Created by: liamfoy@sepulcrum.org
# $FreeBSD$
-#
PORTNAME= qsf
PORTVERSION= 1.2.7
@@ -12,11 +8,10 @@ CATEGORIES= mail
MASTER_SITES= SF
MAINTAINER= jack@jarasoft.net
-COMMENT= A small fast spam filter intended to be used with procmail
+COMMENT= Small fast spam filter intended to be used with procmail
-OPTIONS= GDBM "GDBM support" off \
- MYSQL "MySQL support" off \
- SQLITE2 "SQLite2 support" off
+OPTIONS_DEFINE= GDBM MYSQL SQLITE2
+SQLITE2_DESC= SQLite2 support
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -27,21 +22,21 @@ PLIST_FILES= bin/qsf
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GDBM)
+.if ${PORT_OPTIONS:MGDBM}
LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
.else
CONFIGURE_ARGS+= --without-gdbm
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
.else
CONFIGURE_ARGS+= --without-mysql
.endif
-.if defined(WITH_SQLITE2)
+.if ${PORT_OPTIONS:MSQLITE2}
USE_SQLITE= 2
.else
CONFIGURE_ARGS+= --without-sqlite
@@ -50,4 +45,4 @@ CONFIGURE_ARGS+= --without-sqlite
post-patch:
@${REINPLACE_CMD} -e 's|Linux|@VERSION@|g' ${WRKSRC}/doc/quickref.1.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/quickml/Makefile b/mail/quickml/Makefile
index 9feed3e17876..43ec03749397 100644
--- a/mail/quickml/Makefile
+++ b/mail/quickml/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quickml
-# Date created: 11 June 2004
-# Whom: Yuichiro AIZAWA <yaizawa@mdbl.sfc.keio.ac.jp>
-#
+# Created by: Yuichiro AIZAWA <yaizawa@mdbl.sfc.keio.ac.jp>
# $FreeBSD$
-#
PORTNAME= quickml
PORTVERSION= 0.7
@@ -32,8 +28,10 @@ CONFIGURE_ARGS= --datadir="${PREFIX}/share/quickml" \
SUB_LIST= RUBY=${RUBY}
-OPTIONS= ANALOG "Enable quickml-analog" on \
- LIMIT "Enable Creators and Members Limitation Patch" off
+OPTIONS_DEFINE= ANALOG LIMIT DOCS
+OPTIONS_DEFAULT= ANALOG
+ANALOG_DESC= quickml-analog
+LIMIT_DESC= Creators and Members Limitation Patch
.include <bsd.port.pre.mk>
@@ -41,7 +39,7 @@ OPTIONS= ANALOG "Enable quickml-analog" on \
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ruby19-*
.endif
-.if !defined(WITHOUT_ANALOG)
+.if ${PORT_OPTIONS:MANALOG}
USE_GHOSTSCRIPT_RUN= yes
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
convert:${PORTSDIR}/graphics/ImageMagick
@@ -51,14 +49,14 @@ PLIST_SUB+= ANALOG="@comment "
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-woanalog-Makefile.in
.endif
-.if !defined(WITHOUT_LIMIT)
+.if ${PORT_OPTIONS:MLIMIT}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-limit-*
.endif
post-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/messages.ja ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ml-usage.en.rd ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/quickml.en.rd ${DOCSDIR}
diff --git a/mail/rabl_client/Makefile b/mail/rabl_client/Makefile
index e00b2474c33c..6385edfc0a0c 100644
--- a/mail/rabl_client/Makefile
+++ b/mail/rabl_client/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rabl_client
-# Date created: 2005-10-07
-# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
-#
+# Created by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
# $FreeBSD$
-#
PORTNAME= rabl_client
PORTVERSION= 1.0.0
@@ -24,11 +20,11 @@ VAR_DIR?= /var/spool/${PORTNAME}
PORTDOCS= CHANGE README RELEASE.NOTES
-OPTIONS= DEBUG "Enable DEBUG messages" off
+OPTIONS_DEFINE= DEBUG DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
CFLAGS+= -g -DDEBUG
STRIP_CMD= # empty
@@ -41,11 +37,11 @@ post-install:
${INSTALL} -o ${SHAREOWN} -g ${SHAREGRP} -m 0640 \
${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/rabl_server/Makefile b/mail/rabl_server/Makefile
index 3f30f1bc8da5..96d9236dab39 100644
--- a/mail/rabl_server/Makefile
+++ b/mail/rabl_server/Makefile
@@ -1,11 +1,5 @@
-# New ports collection makefile for: rabl_server
-# Date created: 2005-10-25
-# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
-#
+# Created by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
# $FreeBSD$
-#
-# $Tecnik: ports/mail/rabl_server/Makefile,v 1.7 2005/12/09 19:54:50 itetcu Exp $
-#
PORTNAME= rabl_server
PORTVERSION= 1.0.0
@@ -22,15 +16,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= CHANGE README RELEASE.NOTES
-OPTIONS= DEBUG "Enable DEBUG messages" off
+OPTIONS_DEFINE= DEBUG DOCS
USE_RC_SUBR= ${PORTNAME}
RABL_GROUP?= bind
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
CFLAGS+= -g -DDEBUG
STRIP_CMD= # empty
@@ -53,11 +47,11 @@ post-install:
${INSTALL} -o ${SHAREOWN} -g ${RABL_GROUP} -m 0640 \
${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/scam-backscatter/Makefile b/mail/scam-backscatter/Makefile
index 02823bc18de3..77700bd77323 100644
--- a/mail/scam-backscatter/Makefile
+++ b/mail/scam-backscatter/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: scam-backscatter
-# Date created: 2010-05-27
-# Whom: Janne Snabb <snabb@epipe.com>
-#
+# Created by: Janne Snabb <snabb@epipe.com>
# $FreeBSD$
-#
PORTNAME= scam-backscatter
PORTVERSION= 1.5.1
@@ -23,9 +19,10 @@ SUB_FILES= pkg-message
MAKEFILE= Makefile.freebsd
ALL_TARGET=
-OPTIONS= ALLDOMAINS "Verify any domain with the backend" Off \
- EHLO "Use EHLO instead of HELO in SMTP session" Off \
- USEMAILERTABLE "Use mailertable to map domains to backends" Off
+OPTIONS_DEFINE= ALLDOMAINS EHLO USEMAILERTABLE DOCS
+ALLDOMAINS_DESC= Verify any domain with the backend
+EHLO_DESC= Use EHLO instead of HELO in SMTP session
+USEMAILERTABLE_DESC= Use mailertable to map domains to backends
.include <bsd.port.options.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
@@ -37,13 +34,13 @@ LIBS+= ${SENDMAIL_LDADD}
CFLAGS+= ${PTHREAD_CFLAGS}
LIBS+= ${PTHREAD_LIBS}
-.if defined(WITH_ALLDOMAINS)
+.if ${PORT_OPTIONS:MALLDOMAINS}
CFLAGS+= -DALLDOMAINS
.endif
-.if defined(WITH_EHLO)
+.if ${PORT_OPTIONS:MEHLO}
CFLAGS+= -DEHLO
.endif
-.if defined(WITH_USEMAILERTABLE)
+.if ${PORT_OPTIONS:MUSEMAILERTABLE}
CFLAGS+= -DUSEMAILERTABLE
.endif
@@ -62,7 +59,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scam.conf ${PREFIX}/etc/mail/scam-back.conf.sample
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/INSTALL ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/License ${DOCSDIR}
diff --git a/mail/spmfilter-clamav/Makefile b/mail/spmfilter-clamav/Makefile
index 682ac80c750f..37f2fd2e760f 100644
--- a/mail/spmfilter-clamav/Makefile
+++ b/mail/spmfilter-clamav/Makefile
@@ -20,11 +20,11 @@ CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
USE_LDCONFIG= ${PREFIX}/lib/spmfilter
-OPTIONS= DEBUG "Enable Debugging" off
+OPTIONS_DEFINE= DEBUG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
.endif
@@ -38,9 +38,9 @@ post-patch:
${WRKSRC}/cmake/Modules/SMFMacros.cmake
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}/contrib
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/contrib/virus-notify.txt ${DOCSDIR}/contrib
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/spmfilter-spamassassin/Makefile b/mail/spmfilter-spamassassin/Makefile
index c911c56a2f4c..93d39a41ae03 100644
--- a/mail/spmfilter-spamassassin/Makefile
+++ b/mail/spmfilter-spamassassin/Makefile
@@ -19,11 +19,11 @@ CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
USE_LDCONFIG= ${PREFIX}/lib/spmfilter
-OPTIONS= DEBUG "Enable Debugging" off
+OPTIONS_DEFINE= DEBUG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
.endif
@@ -37,4 +37,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|' \
${WRKSRC}/cmake/Modules/SMFMacros.cmake
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/spmfilter/Makefile b/mail/spmfilter/Makefile
index 07eff4ac265f..d11ceae35d22 100644
--- a/mail/spmfilter/Makefile
+++ b/mail/spmfilter/Makefile
@@ -25,50 +25,45 @@ CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
-OPTIONS= DB4 "Enable DB4 backend" on \
- DEBUG "Enable Debugging" off \
- LDAP "Enable LDAP backend" off \
- MYSQL "Enable MYSQL backend" off \
- PGSQL "Enable PGSQL backend" off
+OPTIONS_DEFINE= DB4 DEBUG LDAP MYSQL PGSQL
+OPTIONS_DEFAULT= DB4
+DB4_DESC= DB4 backend
# Default requirement for spmfilter rc script
_REQUIRE= LOGIN
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_DB4) || defined(WITHOUT_DB4)
-CMAKE_ARGS+= -DWITHOUT_DB4=TRUE
-.else
+.if ${PORT_OPTIONS:MDB4}
USE_BDB= yes
CMAKE_ARGS+= -DDB4_INCLUDE_DIR="${BDB_INCLUDE_DIR}"
+.else
+CMAKE_ARGS+= -DWITHOUT_DB4=TRUE
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CMAKE_ARGS+= -DENABLE_DEBUG=TRUE
.endif
-.if !defined(WITH_LDAP) || defined(WITHOUT_LDAP)
-CMAKE_ARGS+= -DWITHOUT_LDAP=TRUE
-.else
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
-.if defined(WITH_OPENLDAP_VER)
+.if ${PORT_OPTIONS:MOPENLDAP_VER}
WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
.endif
_REQUIRE+= slapd
-.endif
-
-.if !defined(WITH_MYSQL) && !defined(WITH_PGSQL)
-CMAKE_ARGS+= -DWITHOUT_ZDB=TRUE
.else
-LIB_DEPENDS+= zdb:${PORTSDIR}/databases/libzdb
+CMAKE_ARGS+= -DWITHOUT_LDAP=TRUE
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
+LIB_DEPENDS+= zdb:${PORTSDIR}/databases/libzdb
USE_MYSQL= yes
_REQUIRE+= mysql
+.else
+CMAKE_ARGS+= -DWITHOUT_ZDB=TRUE
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
_REQUIRE+= postgresql
.endif
@@ -96,4 +91,4 @@ post-install:
${CP} -p ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index 98c3d1791d94..e0e3d1cd7f7e 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sqlgrey
-# Date created: 17 Feb 2005
-# Whom: mat
-#
+# Created by: mat
# $FreeBSD$
-#
PORTNAME= sqlgrey
PORTVERSION= 1.8.0
@@ -36,30 +32,28 @@ PKGDEINSTALL= ${PKGINSTALL}
MAN1= sqlgrey.1
-.if !defined(NOPORTDOCS)
-PORTDOCS= Changelog FAQ HOWTO README TODO
-.endif
+OPTIONS_DEFINE= PGSQL MYSQL SQLITE STATS DOCS
+STATS_DESC= Depend on Date::Calc for logstats.pl script
-OPTIONS= PGSQL "PostgreSQL backend" off \
- MYSQL "MySQL backend" off \
- SQLITE "SQLite backend" off \
- STATS "Depend on Date::Calc for logstats.pl script" off
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= Changelog FAQ HOWTO README TODO
+.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
-.if defined(WITH_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
-.if defined(WITH_STATS)
+.if ${PORT_OPTIONS:MSTATS}
RUN_DEPENDS+= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
.endif
@@ -77,7 +71,7 @@ do-install:
@[ "${i}" = "dyn_fqdn.regexp" ] || [ "${i}" = "smtp_server.regexp" ] || [ "${i}" = "sqlgrey.conf" ] || ${TOUCH} ${PREFIX}/${ETCDIR}/${i}.local
@[ -f ${PREFIX}/${ETCDIR}/${i} ] || ${INSTALL_DATA} ${WRKSRC}/etc/${i} ${PREFIX}/${ETCDIR}/${i}
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
@@ -86,4 +80,4 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/ssmtp/Makefile b/mail/ssmtp/Makefile
index d3bc977348a1..0f65fce644ae 100644
--- a/mail/ssmtp/Makefile
+++ b/mail/ssmtp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ssmtp
-# Date created: 9 Jan 2001
-# Whom: Tomasz Paszkowski <ns88@k.pl>
-#
+# Created by: Tomasz Paszkowski <ns88@k.pl>
# $FreeBSD$
-#
PORTNAME= ssmtp
PORTVERSION= 2.64
@@ -35,26 +31,27 @@ MAILERCONF= /etc/mail/mailer.conf
MAN8= ssmtp.8
MAN5= ssmtp.conf.5
-OPTIONS= LOGFILE "Enable log file" off \
- IPV6 "Enable IPv6 support" on \
- USERPREFS "Enable user defined revaliases" on \
- XORIGIP "Add X-Originating-IP header" on \
+OPTIONS_DEFINE= LOGFILE IPV6 USERPREFS XORIGIP
+OPTIONS_DEFINE= USERPREFS XORIGIP
+LOGFILE_DESC= log file
+USERPREFS_DESC= user defined revaliases
+XORIGIP_DESC= Add X-Originating-IP header
.include <bsd.port.options.mk>
-.if defined(WITH_LOGFILE)
+.if ${PORT_OPTIONS:MLOGFILE}
CONFIGURE_ARGS+= --enable-logfile
.endif
-.if defined(WITH_XORIGIP)
+.if ${PORT_OPTIONS:MXORIGIP}
EXTRA_PATCHES= ${FILESDIR}/remote-addr.patch
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-inet6
.endif
-.if !defined(WITHOUT_USERPREFS)
+.if ${PORT_OPTIONS:MUSERPREFS}
CFLAGS+= -DUSERPREFS
pre-everything::
@${ECHO_CMD} "If you don't want to let your users set their own revalias address"