aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /mail
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
downloadports-b59621d3ae883bef429a8fae6073bfa293a55222.tar.gz
ports-b59621d3ae883bef429a8fae6073bfa293a55222.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/p5-Email-MIME/Makefile3
-rw-r--r--mail/p5-FuzzyOcr/Makefile8
-rw-r--r--mail/p5-Mail-DKIM/Makefile9
-rw-r--r--mail/p5-Mail-Graph/Makefile10
-rw-r--r--mail/p5-Mail-SpamAssassin/Makefile4
-rw-r--r--mail/p5-Net-POP3-SSLWrapper/Makefile9
-rw-r--r--mail/p5-SES/Makefile8
7 files changed, 41 insertions, 10 deletions
diff --git a/mail/p5-Email-MIME/Makefile b/mail/p5-Email-MIME/Makefile
index 4ef98b788979..ce01cbf23b9c 100644
--- a/mail/p5-Email-MIME/Makefile
+++ b/mail/p5-Email-MIME/Makefile
@@ -28,4 +28,7 @@ MAN3= Email::MIME.3 \
Email::MIME::Header.3 \
Email::MIME::Modifier.3
+regression-test: build
+ cd ${WRKSRC}/ && ${MAKE} test
+
.include <bsd.port.mk>
diff --git a/mail/p5-FuzzyOcr/Makefile b/mail/p5-FuzzyOcr/Makefile
index 7026a17b9ffa..a2a61fd4c391 100644
--- a/mail/p5-FuzzyOcr/Makefile
+++ b/mail/p5-FuzzyOcr/Makefile
@@ -50,6 +50,12 @@ PLIST_FILES= ${SA_CONFIGDIR}/FuzzyOcr.pm \
%%EXAMPLESDIR%%/FuzzyOcr.cf %%EXAMPLESDIR%%/FuzzyOcr.words
PLIST_DIRS= %%EXAMPLESDIR%%
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=2.16:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/bin,${LOCALBASE}/bin,g' \
-e 's,/bin/grep,/usr/bin/grep,g' \
@@ -76,4 +82,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-DKIM/Makefile b/mail/p5-Mail-DKIM/Makefile
index 92943e80f7e6..b9906ec7c3cc 100644
--- a/mail/p5-Mail-DKIM/Makefile
+++ b/mail/p5-Mail-DKIM/Makefile
@@ -43,4 +43,11 @@ MAN3= Mail::DKIM.3 \
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/dkim*.pl ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-Graph/Makefile b/mail/p5-Mail-Graph/Makefile
index 7754fc86b5ec..f2de44cc19bd 100644
--- a/mail/p5-Mail-Graph/Makefile
+++ b/mail/p5-Mail-Graph/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
EXAMPLESCRIPT= samples/*pl
@@ -40,4 +40,10 @@ post-install:
${INSTALL_SCRIPT} ${EXAMPLEOUTPUT} ${EXAMPLESDIR}/output && \
${INSTALL_SCRIPT} ${EXAMPLEARCHIVE} ${EXAMPLESDIR}/archive
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-SpamAssassin/Makefile b/mail/p5-Mail-SpamAssassin/Makefile
index 5de3253243c5..9f8ac6059e2b 100644
--- a/mail/p5-Mail-SpamAssassin/Makefile
+++ b/mail/p5-Mail-SpamAssassin/Makefile
@@ -62,10 +62,6 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 501200
-IGNORE= requires perl version ${USE_PERL5_RUN}. See ${PORTSDIR}/UPDATING, entry 20120311
-.endif
-
.if defined (WITH_SPAMC)
CONFIGURE_ARGS+= BUILD_SPAMC=yes
.else
diff --git a/mail/p5-Net-POP3-SSLWrapper/Makefile b/mail/p5-Net-POP3-SSLWrapper/Makefile
index f8e2cc8725b2..d9a7df191faa 100644
--- a/mail/p5-Net-POP3-SSLWrapper/Makefile
+++ b/mail/p5-Net-POP3-SSLWrapper/Makefile
@@ -21,4 +21,11 @@ PERL_CONFIGURE= yes
MAN3= Net::POP3::SSLWrapper.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-SES/Makefile b/mail/p5-SES/Makefile
index 4dd0fb742f99..efbfc12eb505 100644
--- a/mail/p5-SES/Makefile
+++ b/mail/p5-SES/Makefile
@@ -43,4 +43,10 @@ do-install:
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/SES.pm ${PREFIX}/${SITE_PERL_REL}/
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>