aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-01-01 10:11:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-01-01 10:11:34 +0000
commit26b4c8f71f91d22e081b27814782686edde0c90a (patch)
tree1c321c39372c25d8634e75b5c8e08edc676b296d /mail
parent548f16bd1a2915f08878b716eed92ff3267e6de2 (diff)
downloadports-26b4c8f71f91d22e081b27814782686edde0c90a.tar.gz
ports-26b4c8f71f91d22e081b27814782686edde0c90a.zip
Revert r559792 to unbreak INDEX and bulk -a
It seems a lot of reverse dependencies were missed With hat: portmgr
Notes
Notes: svn path=/head/; revision=559822
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/getmail/Makefile43
-rw-r--r--mail/getmail/distinfo3
-rw-r--r--mail/getmail/files/patch-setup.py42
-rw-r--r--mail/getmail/pkg-descr20
-rw-r--r--mail/getmail/pkg-message14
6 files changed, 123 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index df27b3284b6e..69d8d7e2b004 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -134,6 +134,7 @@
SUBDIR += findmaildirs
SUBDIR += geary
SUBDIR += gensig
+ SUBDIR += getmail
SUBDIR += getmail6
SUBDIR += gmime2
SUBDIR += gmime2-sharp
diff --git a/mail/getmail/Makefile b/mail/getmail/Makefile
new file mode 100644
index 000000000000..7d4aef7c1629
--- /dev/null
+++ b/mail/getmail/Makefile
@@ -0,0 +1,43 @@
+# Created by: Yukihiro Nakai <nakai@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= getmail
+DISTVERSION= 5.15
+CATEGORIES= mail python
+MASTER_SITES= http://pyropus.ca/software/getmail/old-versions/
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= POP3/IMAP4 mail retriever with Maildir and command delivery
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/docs/COPYING
+
+DEPRECATED= Uses deprecated version of python
+EXPIRATION_DATE= 2020-12-31
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
+
+CONFLICTS= py*-getmail6
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+PORTDOCS= *.css *.html *.txt BUGS CHANGELOG README THANKS TODO
+PORTEXAMPLES= getmailrc-examples
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install:
+ @${CHMOD} -R 644 ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/getmailcore/*
+
+post-install-DOCS-on:
+ @${CP} ${WRKSRC}/README ${WRKSRC}/docs/
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/docs/,} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/getmailrc-examples ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/getmail/distinfo b/mail/getmail/distinfo
new file mode 100644
index 000000000000..6f2fcac01e68
--- /dev/null
+++ b/mail/getmail/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608495568
+SHA256 (getmail-5.15.tar.gz) = d453805ffc3f8fe2586ee705733bd666777e53693125fdb149494d22bd14162a
+SIZE (getmail-5.15.tar.gz) = 199733
diff --git a/mail/getmail/files/patch-setup.py b/mail/getmail/files/patch-setup.py
new file mode 100644
index 000000000000..cded78cdebf4
--- /dev/null
+++ b/mail/getmail/files/patch-setup.py
@@ -0,0 +1,42 @@
+--- setup.py.orig 2009-01-08 21:55:25 UTC
++++ setup.py
+@@ -39,12 +39,11 @@ GETMAILDOCDIR = os.path.join(
+ datadir or prefix,
+ 'share',
+ 'doc',
+- 'getmail-%s' % __version__
++ 'getmail'
+ )
+
+ GETMAILMANDIR = os.path.join(
+ datadir or prefix,
+- 'share',
+ 'man',
+ 'man1'
+ )
+@@ -98,25 +97,6 @@ setup(
+ 'getmail_mbox'
+ ],
+ data_files=[
+- (GETMAILDOCDIR, [
+- './README',
+- './getmail.spec',
+- 'docs/BUGS',
+- 'docs/COPYING',
+- 'docs/CHANGELOG',
+- 'docs/TODO',
+- 'docs/THANKS',
+- 'docs/configuration.html',
+- 'docs/configuration.txt',
+- 'docs/documentation.html',
+- 'docs/documentation.txt',
+- 'docs/faq.html',
+- 'docs/faq.txt',
+- 'docs/getmaildocs.css',
+- 'docs/getmailrc-examples',
+- 'docs/troubleshooting.html',
+- 'docs/troubleshooting.txt',
+- ]),
+ (GETMAILMANDIR, [
+ 'docs/getmail.1',
+ 'docs/getmail_fetch.1',
diff --git a/mail/getmail/pkg-descr b/mail/getmail/pkg-descr
new file mode 100644
index 000000000000..b6035ba24cbc
--- /dev/null
+++ b/mail/getmail/pkg-descr
@@ -0,0 +1,20 @@
+A POP3 and IMAP4 mail retriever with reliable Maildir and command delivery.
+
+Summary of features:
+- Retrieve mail from an unlimited number of POP3/IMAP4 mailboxes and servers.
+- Support for POP3-over-SSL and IMAP-over-SSL, as well as SDPS
+ WARNING: even with SSL, "no certificate or key validation is done." so
+ that getmail does not detect or protect from man-in-the-middle attacks.
+- Support for multidrop or domain mailboxes.
+- Safe and reliable delivery to qmail-style Maildirs, as well as program
+ (pipe) delivery for use with arbitrary external MDAs. Includes an MDA
+ for mbox files that supports mboxrd format and fcntl-type flock locking.
+- Does not destroy information by rewriting mail headers.
+- Does not cause mail loops by doing SMTP injection, and therefore does
+ not require that you run an MTA (like qmail or sendmail) on your host.
+- Can remember which mail it has already retrieved, and can be set to
+ only download new messages.
+- Written in Python, and therefore easy to extend or customize.
+- Simple to install, configure, and use.
+
+WWW: http://pyropus.ca/software/getmail/
diff --git a/mail/getmail/pkg-message b/mail/getmail/pkg-message
new file mode 100644
index 000000000000..3c4d4878ffec
--- /dev/null
+++ b/mail/getmail/pkg-message
@@ -0,0 +1,14 @@
+[
+{ type: install
+ message: <<EOM
+The getmail rc file (configuration file) format has changed since
+version 3.x. If you are upgrading from version 3, you will need
+to write a new configuration file based on the contents of your old one.
+The new file format resembles the old in many ways.
+
+Each account you retrieve mail from will require a separate rc file,
+but getmail can operate with multiple rc files simultaneously
+if you wish to retrieve mail from multiple accounts.
+EOM
+}
+]