aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2004-08-30 15:25:10 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2004-08-30 15:25:10 +0000
commit1f66719d73eb64420e9bf630d2fd3d616703b416 (patch)
tree7f7fbc9687c79b15600e5ec18eee2b607b10743d /mail
parent1f5e7f45926e8ea4b4ad63c02318ea8ecfc10473 (diff)
downloadports-1f66719d73eb64420e9bf630d2fd3d616703b416.tar.gz
ports-1f66719d73eb64420e9bf630d2fd3d616703b416.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/cyrus-imapd22/Makefile15
-rw-r--r--mail/cyrus-imapd23/Makefile15
-rw-r--r--mail/cyrus-imapd24/Makefile15
3 files changed, 33 insertions, 12 deletions
diff --git a/mail/cyrus-imapd22/Makefile b/mail/cyrus-imapd22/Makefile
index d20a1da87f8c..28b359062ac9 100644
--- a/mail/cyrus-imapd22/Makefile
+++ b/mail/cyrus-imapd22/Makefile
@@ -38,28 +38,29 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
+OPTIONS= AUTH_KRB5 "Use Kerberos5 authorization module" off
.if defined(WITH_BDB_VER)
USE_BDB_VER= ${WITH_BDB_VER}
.else
USE_BDB_VER= 3
.endif
.if ${USE_BDB_VER} == 3
-OPTIONS= BDB_3 "Use BerkeleyDB v3" on \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" on \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 4
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" on \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 41
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" on \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 42
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" on
@@ -182,10 +183,16 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE}
CONFIGURE_ARGS+=--with-snmp=no
.endif
+.if defined(WITH_AUTH_KRB5) && defined(WITH_LDAP_PTLOADER)
+BROKEN= "AUTH_KRB5 and LDAP_PTLOADER are exclusive. Run 'make config' again!"
+.endif
.if defined(WITH_LDAP_PTLOADER)
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-auth=pts --with-pts=ldap --with-ldap=${LOCALBASE}
PLIST_SUB+= LDAP_PTLOADER=""
+.elif defined(WITH_AUTH_KRB5)
+CONFIGURE_ARGS+=--with-auth=krb5
+PLIST_SUB+= LDAP_PTLOADER="@comment "
.else
CONFIGURE_ARGS+=--with-auth=unix
PLIST_SUB+= LDAP_PTLOADER="@comment "
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index d20a1da87f8c..28b359062ac9 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -38,28 +38,29 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
+OPTIONS= AUTH_KRB5 "Use Kerberos5 authorization module" off
.if defined(WITH_BDB_VER)
USE_BDB_VER= ${WITH_BDB_VER}
.else
USE_BDB_VER= 3
.endif
.if ${USE_BDB_VER} == 3
-OPTIONS= BDB_3 "Use BerkeleyDB v3" on \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" on \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 4
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" on \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 41
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" on \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 42
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" on
@@ -182,10 +183,16 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE}
CONFIGURE_ARGS+=--with-snmp=no
.endif
+.if defined(WITH_AUTH_KRB5) && defined(WITH_LDAP_PTLOADER)
+BROKEN= "AUTH_KRB5 and LDAP_PTLOADER are exclusive. Run 'make config' again!"
+.endif
.if defined(WITH_LDAP_PTLOADER)
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-auth=pts --with-pts=ldap --with-ldap=${LOCALBASE}
PLIST_SUB+= LDAP_PTLOADER=""
+.elif defined(WITH_AUTH_KRB5)
+CONFIGURE_ARGS+=--with-auth=krb5
+PLIST_SUB+= LDAP_PTLOADER="@comment "
.else
CONFIGURE_ARGS+=--with-auth=unix
PLIST_SUB+= LDAP_PTLOADER="@comment "
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index d20a1da87f8c..28b359062ac9 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -38,28 +38,29 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-openssl=${OPENSSLBASE} \
--with-perl=${PERL5}
+OPTIONS= AUTH_KRB5 "Use Kerberos5 authorization module" off
.if defined(WITH_BDB_VER)
USE_BDB_VER= ${WITH_BDB_VER}
.else
USE_BDB_VER= 3
.endif
.if ${USE_BDB_VER} == 3
-OPTIONS= BDB_3 "Use BerkeleyDB v3" on \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" on \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 4
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" on \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 41
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" on \
BDB_42 "Use BerkeleyDB v4.2" off
.elif ${USE_BDB_VER} == 42
-OPTIONS= BDB_3 "Use BerkeleyDB v3" off \
+OPTIONS+= BDB_3 "Use BerkeleyDB v3" off \
BDB_4 "Use BerkeleyDB v4" off \
BDB_41 "Use BerkeleyDB v4.1" off \
BDB_42 "Use BerkeleyDB v4.2" on
@@ -182,10 +183,16 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE}
CONFIGURE_ARGS+=--with-snmp=no
.endif
+.if defined(WITH_AUTH_KRB5) && defined(WITH_LDAP_PTLOADER)
+BROKEN= "AUTH_KRB5 and LDAP_PTLOADER are exclusive. Run 'make config' again!"
+.endif
.if defined(WITH_LDAP_PTLOADER)
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-auth=pts --with-pts=ldap --with-ldap=${LOCALBASE}
PLIST_SUB+= LDAP_PTLOADER=""
+.elif defined(WITH_AUTH_KRB5)
+CONFIGURE_ARGS+=--with-auth=krb5
+PLIST_SUB+= LDAP_PTLOADER="@comment "
.else
CONFIGURE_ARGS+=--with-auth=unix
PLIST_SUB+= LDAP_PTLOADER="@comment "