aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-09 20:11:54 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-09-09 20:11:54 +0000
commit53aa9a57a67b54b5ba0b729b72350653189043c2 (patch)
tree5d35274e74eb0849187e6211b82c80f8ba911f88 /mail
parentbb1ba1be4adbd6c3debe5ea7fac1039165479880 (diff)
downloadports-53aa9a57a67b54b5ba0b729b72350653189043c2.tar.gz
ports-53aa9a57a67b54b5ba0b729b72350653189043c2.zip
Notes
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/spamoracle/Makefile30
-rw-r--r--mail/spamoracle/distinfo1
-rw-r--r--mail/spamoracle/pkg-comment1
-rw-r--r--mail/spamoracle/pkg-descr11
-rw-r--r--mail/spamoracle/pkg-plist3
6 files changed, 47 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ed8856b76022..eaf054bb255b 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -237,6 +237,7 @@
SUBDIR += sonicmail
SUBDIR += spamass-milter
SUBDIR += spambnc
+ SUBDIR += spamoracle
SUBDIR += spamprobe
SUBDIR += spruce
SUBDIR += squirrelmail
diff --git a/mail/spamoracle/Makefile b/mail/spamoracle/Makefile
new file mode 100644
index 000000000000..186b6d9037c0
--- /dev/null
+++ b/mail/spamoracle/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: SpamOracle
+# Date created: Mon Sep 9 18:31:45 UTC 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spamoracle
+PORTVERSION= 1.1
+CATEGORIES= mail
+MASTER_SITES= http://cristal.inria.fr/~xleroy/software/
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|^(CPP=)gcc[[:space:]]+-E|\1${CPP}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/spamoracle/distinfo b/mail/spamoracle/distinfo
new file mode 100644
index 000000000000..aa403bfe770e
--- /dev/null
+++ b/mail/spamoracle/distinfo
@@ -0,0 +1 @@
+MD5 (spamoracle-1.1.tar.gz) = 4cbc3a28d79d2759940e45c708e662dd
diff --git a/mail/spamoracle/pkg-comment b/mail/spamoracle/pkg-comment
new file mode 100644
index 000000000000..99976bcf9640
--- /dev/null
+++ b/mail/spamoracle/pkg-comment
@@ -0,0 +1 @@
+procmail spam filter written in ML using Bayesian classification
diff --git a/mail/spamoracle/pkg-descr b/mail/spamoracle/pkg-descr
new file mode 100644
index 000000000000..e8511e5f6853
--- /dev/null
+++ b/mail/spamoracle/pkg-descr
@@ -0,0 +1,11 @@
+[ excerpt from developer's site ]
+
+SpamOracle, a.k.a. "Saint Peter", is a tool to help detect and
+filter away "spam" (unsolicited commercial e-mail). It proceeds by
+statistical analysis of the words that appear in the e-mail, comparing
+the frequencies of words with those found in a user-provided corpus
+of known spam and known legitimate e-mail. The classification
+algorithm is based on Bayes' formula, and is described in Paul
+Graham's paper, A plan for spam.
+
+WWW: http://cristal.inria.fr/~xleroy/software.html
diff --git a/mail/spamoracle/pkg-plist b/mail/spamoracle/pkg-plist
new file mode 100644
index 000000000000..014d8f848cd1
--- /dev/null
+++ b/mail/spamoracle/pkg-plist
@@ -0,0 +1,3 @@
+bin/spamoracle
+%%PORTDOCS%%share/doc/spamoracle/README
+%%PORTDOCS%%@dirrm share/doc/spamoracle