aboutsummaryrefslogtreecommitdiff
path: root/math/PDL
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-12 02:58:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-12 02:58:25 +0000
commit9a28f4914c06d3cc0b808ca0be2678945b936db2 (patch)
tree51b12fe99d83a485b0b031bc56822da8ac487ef7 /math/PDL
parent47b48b53675b78c6a32835002e5e9e31627f7dc7 (diff)
downloadports-9a28f4914c06d3cc0b808ca0be2678945b936db2.tar.gz
ports-9a28f4914c06d3cc0b808ca0be2678945b936db2.zip
Notes
Diffstat (limited to 'math/PDL')
-rw-r--r--math/PDL/Makefile84
-rw-r--r--math/PDL/distinfo2
-rw-r--r--math/PDL/files/patch-Graphics:PLplot:Makefile.PL11
-rw-r--r--math/PDL/files/patch-aa24
-rw-r--r--math/PDL/files/patch-gg12
-rw-r--r--math/PDL/pkg-descr16
6 files changed, 149 insertions, 0 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
new file mode 100644
index 000000000000..10868aecd74b
--- /dev/null
+++ b/math/PDL/Makefile
@@ -0,0 +1,84 @@
+# ex:ts=8
+# New ports collection makefile for: PDL
+# Date created: 08 February 1999
+# Whom: Anton Berezin <tobez@plab.ku.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PDL
+PORTVERSION= 2.4.1
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
+ ${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
+MASTER_SITE_SUBDIR= ${PORTNAME}:cpan \
+ ${PORTNAME:L}:sf
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:cpan \
+ ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl Data Language
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
+ ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77 \
+ ${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
+ ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter
+LIB_DEPENDS= plplotd.9:${PORTSDIR}/math/plplot \
+ fftw.2:${PORTSDIR}/math/fftw \
+ gsl.5:${PORTSDIR}/math/gsl
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
+ ${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+
+USE_GL= yes
+PERL_CONFIGURE= yes
+PLIST_FILES= bin/pdldoc bin/perldl bin/pptemplate \
+ ${SITE_PERL:S,^${PREFIX}/,,}/${PERL_ARCH}/Inline/Pdlpp.pm \
+ ${SITE_PERL:S,^${PREFIX}/,,}/${PERL_ARCH}/Inline/MakePdlppInstallable.pm
+
+.if defined(KITCHEN_SINK)
+RUN_DEPENDS+= ppmtogif:${PORTSDIR}/graphics/netpbm \
+ mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+ saoimage:${PORTSDIR}/astro/saoimage
+.endif
+
+.SILENT:
+
+.if !defined(KITCHEN_SINK)
+pre-extract:
+ ${ECHO} "You can build additional functionality into PDL by defining KITCHEN_SINK"
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "alpha"
+BROKEN= test script t/flexraw.t fails all 26 tests
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif # ${PERL_LEVEL} < 500601
+
+post-patch:
+ @${GREP} -lR "/usr/local/bin/perl" ${WRKSRC} | ${XARGS} \
+ ${PERL} -pi -e "s!/usr/local/bin/perl!${PERL}!"
+
+test:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} make test
+
+# autogen plist
+post-install:
+ @(cd ${WRKSRC}/blib/man3 ; \
+ ${FIND} *.3 | ${SED} "s,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/," \
+ >> ${TMPPLIST} ; \
+ cd ${WRKSRC}/blib/man1 ; \
+ ${FIND} *.1 | ${SED} "s,^,man/man1/," >> ${TMPPLIST})
+ @(${FIND} ${SITE_PERL}/${PERL_ARCH}/PDL* -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST} ; \
+ ${FIND} ${SITE_PERL}/${PERL_ARCH}/PDL* -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST} ; \
+ ${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/PDL -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST} ; \
+ ${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/PDL -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST})
+
+.include <bsd.port.post.mk>
diff --git a/math/PDL/distinfo b/math/PDL/distinfo
new file mode 100644
index 000000000000..c13dca63cdb0
--- /dev/null
+++ b/math/PDL/distinfo
@@ -0,0 +1,2 @@
+MD5 (PDL-2.4.1.tar.gz) = 0d57eb5ccb4d9e63103622e1e1144793
+SIZE (PDL-2.4.1.tar.gz) = 2086341
diff --git a/math/PDL/files/patch-Graphics:PLplot:Makefile.PL b/math/PDL/files/patch-Graphics:PLplot:Makefile.PL
new file mode 100644
index 000000000000..8fdc9dbd99df
--- /dev/null
+++ b/math/PDL/files/patch-Graphics:PLplot:Makefile.PL
@@ -0,0 +1,11 @@
+--- Graphics/PLplot/Makefile.PL.orig Fri Mar 12 08:38:52 2004
++++ Graphics/PLplot/Makefile.PL Fri Mar 12 08:39:43 2004
+@@ -164,7 +164,7 @@
+ 'PLplot.pm PLplot.xs PLplot.o PLplot.c PLplot.bs *.xfig temp* OPTIONS! Makefile.old'},
+ );
+
+-sub MY::postamble { pdlpp_postamble($package); }
++sub MY::postamble { pdlpp_postamble_int($package); }
+
+ sub compileAndRun {
+ my $flags = shift;
diff --git a/math/PDL/files/patch-aa b/math/PDL/files/patch-aa
new file mode 100644
index 000000000000..3f96ba43a2d0
--- /dev/null
+++ b/math/PDL/files/patch-aa
@@ -0,0 +1,24 @@
+--- perldl.conf.orig Wed Mar 10 14:23:59 2004
++++ perldl.conf Wed Mar 10 14:25:31 2004
+@@ -82,9 +82,9 @@
+ # OPENGL_DEFINE => '',
+ #
+ # Let perl try to figure it out
+- OPENGL_LIBS => undef,
+- OPENGL_INC => undef,
+- OPENGL_DEFINE => undef,
++ OPENGL_LIBS => '-L/usr/X11R6/lib -lGL -lGLU -lXext -lX11',
++ OPENGL_INC => '-I/usr/X11R6/include',
++ OPENGL_DEFINE => '-DGL_GLEXT_LEGACY',
+ # Whether or not to build the Karma interface module
+
+ WITH_KARMA => undef, # Leave it up to PDL to decide
+@@ -141,7 +141,7 @@
+ # about curses to fix it
+ # - 1 builds, 0 or undef does not build
+ #
+- WITH_IO_BROWSER => 0,
++ WITH_IO_BROWSER => 1,
+ );
+
+
diff --git a/math/PDL/files/patch-gg b/math/PDL/files/patch-gg
new file mode 100644
index 000000000000..0177b9bd2496
--- /dev/null
+++ b/math/PDL/files/patch-gg
@@ -0,0 +1,12 @@
+--- Basic/Math/mconf.h.orig Wed Sep 25 00:57:31 2002
++++ Basic/Math/mconf.h Wed Sep 25 00:58:06 2002
+@@ -89,7 +89,9 @@
+ #endif
+ #if defined __alpha && ! defined __linux
+ #include <float.h>
++#ifndef __FreeBSD__
+ #include <nan.h>
++#endif
+ #endif
+ #ifndef NANARG
+ #define NANARG
diff --git a/math/PDL/pkg-descr b/math/PDL/pkg-descr
new file mode 100644
index 000000000000..aac3a429d9d7
--- /dev/null
+++ b/math/PDL/pkg-descr
@@ -0,0 +1,16 @@
+PDL (``Perl Data Language'') gives standard perl the ability to
+COMPACTLY store and SPEEDILY manipulate the large N-dimensional data
+arrays which are the bread and butter of scientific computing.
+
+The idea is to turn perl in to a free, array-oriented, numerical
+language in the same sense as commerical packages like IDL and
+MatLab. One can write simple perl expressions to manipulate entire
+numerical arrays all at once. For example, using PDL the perl variable
+$a can hold a 1024x1024 floating point image, it only takes 4Mb of
+memory to store it and expressions like $a=sqrt($a)+2 would manipulate
+the whole image in a few seconds.
+
+A simple interactive shell (perldl) is provided for command line use
+together with a module (PDL) for use in perl scripts.
+
+WWW: http://pdl.perl.org/