aboutsummaryrefslogtreecommitdiff
path: root/math/R-cran-conquer/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2020-07-11 11:40:15 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2020-07-11 11:40:15 +0000
commit5ca7e5b7ec85c7fad5559bfaa61fe24ecebce10c (patch)
tree85caf91755bbeb3fa770955715b4df47818d9283 /math/R-cran-conquer/Makefile
parenteea6653222afb9e63555dd65d8a18d115de80763 (diff)
Notes
Diffstat (limited to 'math/R-cran-conquer/Makefile')
-rw-r--r--math/R-cran-conquer/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/math/R-cran-conquer/Makefile b/math/R-cran-conquer/Makefile
new file mode 100644
index 000000000000..ada85a46759f
--- /dev/null
+++ b/math/R-cran-conquer/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= conquer
+PORTVERSION= 1.0.1
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Convolution-Type Smoothed Quantile Regression
+
+LICENSE= GPLv3
+
+CRAN_DEPENDS= R-cran-Rcpp>=1.0.3:devel/R-cran-Rcpp \
+ R-cran-matrixStats>0:math/R-cran-matrixStats \
+ R-cran-RcppArmadillo>0:math/R-cran-RcppArmadillo
+BUILD_DEPENDS= ${CRAN_DEPENDS}
+RUN_DEPENDS= ${CRAN_DEPENDS}
+
+USES= compiler:c++11-lang cran:auto-plist,compiles
+
+.include <bsd.port.mk>