aboutsummaryrefslogtreecommitdiff
path: root/math/R/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-02-14 01:45:28 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-02-14 01:45:28 +0000
commit7d595db8f3bb87643a85a37df92248296be126f4 (patch)
tree90eb5c2b6ef15174feef1f348bfa1034aca54c92 /math/R/Makefile
parent7deb85057f19502967e9d016af0c1cf7df7d2b38 (diff)
Notes
Diffstat (limited to 'math/R/Makefile')
-rw-r--r--math/R/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 791877baa451..99c7ec70a152 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -72,9 +72,15 @@ check-all: build
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-CONFIGURE_ARGS+=--with-lapack="-lalapack -lcblas" --with-blas="-lf77blas"
+CONFIGURE_ARGS+=--with-blas="-lf77blas -latlas"
+# A workaround to prevent hangs up during the build.
+.if ${ARCH} != "i386"
+CONFIGURE_ARGS+=--with-lapack="-lalapack -lcblas"
PLIST_SUB+= BLAS="@comment "
.else
+PLIST_SUB+= BLAS=""
+.endif
+.else
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
CONFIGURE_ARGS+=--with-blas="-lblas"
PLIST_SUB+= BLAS=""