aboutsummaryrefslogtreecommitdiff
path: root/math/R/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-08-27 18:58:59 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-08-27 18:58:59 +0000
commit12bc304ddb8502a25467586734f8b38613c26996 (patch)
tree3cc82d22a87c5e0e2a445b7f1079a54bc264984a /math/R/Makefile
parenta043e36f79c00fbdac0201607387174be600bbdc (diff)
downloadports-12bc304ddb8502a25467586734f8b38613c26996.tar.gz
ports-12bc304ddb8502a25467586734f8b38613c26996.zip
Notes
Diffstat (limited to 'math/R/Makefile')
-rw-r--r--math/R/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 49dee5d31690..63d654930914 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -8,6 +8,7 @@
PORTNAME?= R
PORTVERSION= 2.13.1
+PORTREVISION= 1
CATEGORIES= math lang
MASTER_SITES= http://cran.r-project.org/src/base/R-2/ \
ftp://cran.r-project.org/pub/R/src/base/R-2/ \
@@ -31,8 +32,6 @@ DISTNAME= R-${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT?= A language for statistical computing and graphics
-BROKEN= fails to package
-
.if defined(LIBRMATH_SLAVEPORT)
BUILD_WRKSRC= ${WRKSRC}/src/nmath/standalone
CONFIGURE_ARGS = --disable-nls --with-ICU=no --with-cairo=no --with-iconv=no \
@@ -51,7 +50,7 @@ CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
OPTIONS= ATLAS "Use ATLAS instead of BLAS/LAPACK" off \
ICU "Improve collation in multibyte locales with ICU" on \
NLS "Build with NLS support" on \
- PCRE_PORT "Use PCRE port instead of bundled source" on \
+ PCRE_PORT "Use PCRE port instead of bundled source" off \
THREADS "Build a multithreaded R" on
.if !defined(LIBR_SLAVEPORT)
OPTIONS+= GHOSTSCRIPT "Enable the [dev2]bitmap() graphics devices" on \
@@ -131,6 +130,7 @@ PLIST_SUB+= NLS="@comment "
.if defined(WITHOUT_PCRE_PORT)
CONFIGURE_ARGS+= --without-system-pcre
.else
+BROKEN = WITH_PCRE_PORT breaks document generation with pcre 8.13
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-system-pcre
.endif