aboutsummaryrefslogtreecommitdiff
path: root/math/aamath
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-30 13:32:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-30 13:32:17 +0000
commitc1c2b81120ff576d804c179a07d7c1aea644f058 (patch)
treec3abe3fd2584314e8e17add2b6903db4e5321ecd /math/aamath
parent529c45a08a3ad261c781585ef3c9f5318b6596bf (diff)
downloadports-c1c2b81120ff576d804c179a07d7c1aea644f058.tar.gz
ports-c1c2b81120ff576d804c179a07d7c1aea644f058.zip
Notes
Diffstat (limited to 'math/aamath')
-rw-r--r--math/aamath/Makefile14
-rw-r--r--math/aamath/files/patch-clang69
2 files changed, 74 insertions, 9 deletions
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
index 75dc582b7fb1..75b84fa1d0e9 100644
--- a/math/aamath/Makefile
+++ b/math/aamath/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: aamath
-# Date created: 2005-06-23
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
-#
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
-#
PORTNAME= aamath
PORTVERSION= 0.3
PORTREVISION= 1
CATEGORIES= math textproc
-MASTER_SITES= http://fuse.superglue.se/aamath/
+MASTER_SITES= http://fuse.superglue.se/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Renders ASCII art from mathematical expressions
@@ -17,11 +13,11 @@ COMMENT= Renders ASCII art from mathematical expressions
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_JOBS_SAFE= yes
-PLIST_FILES+= bin/${PORTNAME}
-MAN1= aamath.1
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/math/aamath/files/patch-clang b/math/aamath/files/patch-clang
new file mode 100644
index 000000000000..27e95177fc9b
--- /dev/null
+++ b/math/aamath/files/patch-clang
@@ -0,0 +1,69 @@
+--- expr.cc.orig 2005-03-08 02:00:02.000000000 +0000
++++ expr.cc 2012-11-30 13:52:13.000000000 +0000
+@@ -430,8 +430,6 @@
+ {
+ CanvasPtr canvas_down = down->render();
+
+- Size size_down = canvas_down->size();
+-
+ CanvasPtr canvas;
+
+ (*canvas)[0][0] = '-';
+@@ -1175,10 +1173,8 @@
+ int rise = get_rise();
+
+ CanvasPtr canvas_from = from->render();
+- Size size_from = canvas_from->size();
+
+ CanvasPtr canvas_to = to->render();
+- Size size_to = canvas_to->size();
+
+ CanvasPtr canvas;
+
+@@ -1192,7 +1188,7 @@
+
+ class SumSymbol : public OpSymbol {
+ public:
+- void render(Canvas& c, int r, int c) const;
++ void render(Canvas& c, int r, int i) const;
+ };
+
+ void
+@@ -1208,7 +1204,7 @@
+
+ class ProductSymbol : public OpSymbol {
+ public:
+- void render(Canvas& c, int r, int c) const;
++ void render(Canvas& c, int r, int i) const;
+ };
+
+ void
+@@ -1612,7 +1608,7 @@
+ int cols = num_cols();
+ int rows = num_rows();
+
+- CanvasPtr ec[cols * rows];
++ std::vector<CanvasPtr>ec(cols * rows);
+ Size sz[cols * rows];
+
+ int row_height[rows];
+--- expr.h.orig 2005-03-08 01:56:12.000000000 +0000
++++ expr.h 2012-11-30 13:28:57.000000000 +0000
+@@ -451,7 +451,7 @@
+
+ virtual CanvasPtr render_head() const;
+
+- void render_symbol(Canvas& c, int r, int c, int h) const;
++ void render_symbol(Canvas& c, int r, int i, int h) const;
+
+ virtual CanvasPtr render() const;
+ };
+@@ -467,7 +467,7 @@
+
+ class OpSymbol {
+ public:
+- virtual void render(Canvas& c, int r, int c) const = 0;
++ virtual void render(Canvas& c, int r, int i) const = 0;
+ };
+
+ class SumOrProduct : public OpOnFunction {