aboutsummaryrefslogtreecommitdiff
path: root/math/add
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-30 18:30:09 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-30 18:30:09 +0000
commitae3934282fa949f4fd1bfd2bb97adfff28a5a873 (patch)
tree2bf153096736a1557c46d1fb4967ecf17239e49b /math/add
parente2726d22eb0365cfdc21134dd8940fc15ae5d31c (diff)
downloadports-ae3934282fa949f4fd1bfd2bb97adfff28a5a873.tar.gz
ports-ae3934282fa949f4fd1bfd2bb97adfff28a5a873.zip
Initial import of add version 1.0.
A full-screen editing calculator. PR: 7769 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=12939
Diffstat (limited to 'math/add')
-rw-r--r--math/add/Makefile34
-rw-r--r--math/add/distinfo1
-rw-r--r--math/add/files/patch-aa19
-rw-r--r--math/add/pkg-comment1
-rw-r--r--math/add/pkg-descr7
-rw-r--r--math/add/pkg-plist7
6 files changed, 69 insertions, 0 deletions
diff --git a/math/add/Makefile b/math/add/Makefile
new file mode 100644
index 000000000000..db85789a50d2
--- /dev/null
+++ b/math/add/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: add
+# Version required: 1.0
+# Date created: 20 August 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= add
+PKGNAME= add-1.0
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.clark.net/pub/dickey/add/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+WRKSRC= ${WRKDIR}/add-970526
+
+GNU_CONFIGURE= yes
+MAKEFILE= makefile
+MAN1= add.1
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/add ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/add.1 ${PREFIX}/man/man1
+ @ ${MKDIR} ${PREFIX}/share/add
+ @ ${INSTALL_DATA} ${WRKSRC}/add.hlp ${PREFIX}/share/add
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/add
+.for file in CHANGES COPYING README
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/add
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/add/distinfo b/math/add/distinfo
new file mode 100644
index 000000000000..386080c25edf
--- /dev/null
+++ b/math/add/distinfo
@@ -0,0 +1 @@
+MD5 (add.tar.gz) = e26287b7a26c3b54ab5933de1e7fecab
diff --git a/math/add/files/patch-aa b/math/add/files/patch-aa
new file mode 100644
index 000000000000..8135ceb89b57
--- /dev/null
+++ b/math/add/files/patch-aa
@@ -0,0 +1,19 @@
+--- makefile.in.orig Tue Dec 26 16:59:01 1995
++++ makefile.in Fri Aug 28 12:57:09 1998
+@@ -32,7 +32,7 @@
+
+ SHELL = /bin/sh
+
+-DEFINES = -DHAVE_CONFIG_H -DRELEASE=$(RELEASE) @DEFINES@
++DEFINES = -DHAVE_CONFIG_H -DADD_HELPFILE=\"@prefix@/share/add/add.hlp\" -DRELEASE=$(RELEASE) @DEFINES@
+ INCLUDES = -I. -I$(srcdir) @INCLUDES@
+ CPPFLAGS = $(DEFINES) $(INCLUDES) @CPPFLAGS@
+
+@@ -52,7 +52,6 @@
+ all: $(THIS)
+
+ $(THIS): $(OBJ)
+- -mv $(THIS) o$(THIS)
+ $(LINK) $(CFLAGS) $(LDFLAGS) -o $(THIS) $(OBJ) $(LIBS)
+
+ $(OBJ): $(THIS).h screen.h
diff --git a/math/add/pkg-comment b/math/add/pkg-comment
new file mode 100644
index 000000000000..e65560accded
--- /dev/null
+++ b/math/add/pkg-comment
@@ -0,0 +1 @@
+Full-screen editing calculator.
diff --git a/math/add/pkg-descr b/math/add/pkg-descr
new file mode 100644
index 000000000000..ba19d7076536
--- /dev/null
+++ b/math/add/pkg-descr
@@ -0,0 +1,7 @@
+Add is a fixed-point calculator that operates as a full-screen editor.
+Add performs fixed-point computation. It is designed for use as a
+checkbook or expense-account balancing tool. Add maintains a running
+result for each operation. You may scroll to any position in the
+expression list and modify the list.
+
+http://www.clark.net/pub/dickey/add/add.html
diff --git a/math/add/pkg-plist b/math/add/pkg-plist
new file mode 100644
index 000000000000..64e17577ae9a
--- /dev/null
+++ b/math/add/pkg-plist
@@ -0,0 +1,7 @@
+bin/add
+share/add/add.hlp
+share/doc/add/CHANGES
+share/doc/add/COPYING
+share/doc/add/README
+@dirrm share/add
+@dirrm share/doc/add