aboutsummaryrefslogtreecommitdiff
path: root/math/algotutor/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2013-06-13 06:11:34 +0000
committerKevin Lo <kevlo@FreeBSD.org>2013-06-13 06:11:34 +0000
commit5793bef17fa2c9e96cebbd1465dd359437fc547b (patch)
tree483111c7eaaad535adb3c077bd853372b7d1f175 /math/algotutor/Makefile
parent22cd07b467563b910210b7430e14769060b8133a (diff)
downloadports-5793bef17fa2c9e96cebbd1465dd359437fc547b.tar.gz
ports-5793bef17fa2c9e96cebbd1465dd359437fc547b.zip
Notes
Diffstat (limited to 'math/algotutor/Makefile')
-rw-r--r--math/algotutor/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index 1e12fabf574b..7669439a86d6 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -1,19 +1,14 @@
-# New ports collection makefile for: algotutor
-# Date created: 19 January 2005
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= algotutor
PORTVERSION= 0.8.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
-MASTER_SITES= http://saturn.stu.edu.tw/~ckhung/dl/
+MASTER_SITES= http://www.cyut.edu.tw/~ckhung/dl/
EXTRACT_SUFX= .tgz
MAINTAINER= kevlo@FreeBSD.org
-COMMENT= An interactive tutorial for algorithms and data structures
+COMMENT= Interactive tutorial for algorithms and data structures
BUILD_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -31,6 +26,8 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
post-patch:
${REINPLACE_CMD} -e 's,#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/algotutor
${PERL} -pi -e "s'!!PREFIX!!'${PREFIX}'g" ${WRKSRC}/algotutor
+ ${REINPLACE_CMD} -e 's,!!PERL_VERSION!!,${PERL_VERSION},' \
+ ${WRKSRC}/algotutor
do-install:
${MKDIR} ${SITE_PERL}/algotutor