aboutsummaryrefslogtreecommitdiff
path: root/math/algotutor
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-06-13 07:01:20 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-06-13 07:01:20 +0000
commit61b8c71a60e36f0f3db9d37aa919972c4adbacf0 (patch)
treee9dc47b30f70ebbec11dee2c06c44512a9c42c47 /math/algotutor
parentc86f37ff4d5bdd1e89e9e4b598bfad6f5a292168 (diff)
Notes
Diffstat (limited to 'math/algotutor')
-rw-r--r--math/algotutor/Makefile2
-rw-r--r--math/algotutor/files/patch-algotutor2
2 files changed, 2 insertions, 2 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index 42351bb9be53..e304a089cb2e 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -26,7 +26,7 @@ LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
post-patch:
${REINPLACE_CMD} -e 's,#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/algotutor
${PERL} -pi -e "s'!!PREFIX!!'${PREFIX}'g" ${WRKSRC}/algotutor
- ${REINPLACE_CMD} -e 's,!!PERL_VER!!,${PERL_VER},' \
+ ${REINPLACE_CMD} -e 's,!!SITE_PERL!!,${SITE_PERL},' \
${WRKSRC}/algotutor
do-install:
diff --git a/math/algotutor/files/patch-algotutor b/math/algotutor/files/patch-algotutor
index 7eda362ab7de..a12946b54e00 100644
--- a/math/algotutor/files/patch-algotutor
+++ b/math/algotutor/files/patch-algotutor
@@ -5,7 +5,7 @@
use strict;
use Getopt::Std;
-use lib '/usr/share/perl5/algotutor';
-+use lib '!!PREFIX!!/lib/perl5/site_perl/!!PERL_VER!!/algotutor';
++use lib '!!SITE_PERL!!/algotutor';
BEGIN {
my ($path) = $0 =~ m#(.*/)#;