aboutsummaryrefslogtreecommitdiff
path: root/math/amath/Makefile
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-03-18 14:42:11 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-03-18 14:42:11 +0000
commit65a3b7bf0e35c6577fcd6da4e58712b7c45bd00b (patch)
treea8d5564bf6d4e33f9c43c9bfe07bfe01e7878ff4 /math/amath/Makefile
parent00f1c7bcaa416bcadd260c3fa9a3a46c54abd6f4 (diff)
downloadports-65a3b7bf0e35c6577fcd6da4e58712b7c45bd00b.tar.gz
ports-65a3b7bf0e35c6577fcd6da4e58712b7c45bd00b.zip
Notes
Diffstat (limited to 'math/amath/Makefile')
-rw-r--r--math/amath/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/math/amath/Makefile b/math/amath/Makefile
index e6dd29137218..f703c4f1b6c7 100644
--- a/math/amath/Makefile
+++ b/math/amath/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= amath
-PORTVERSION= 1.6.4
+PORTVERSION= 1.7.0
CATEGORIES= math
MASTER_SITES= http://suyai.innolan.net/
@@ -11,16 +11,18 @@ COMMENT= Simple command line calculator
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+USES= gmake
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --pkgconfig=libdata/pkgconfig
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
MAKE_ARGS= CC=${CC} CXX=${CXX}
-PLIST_FILES= bin/${PORTNAME}
-
-BROKEN_aarch64= Fails to compile: must define endianness
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
-do-test:
- ${WRKSRC}/${PORTNAME} test
+ALL_TARGET= static
+TEST_TARGET= test
+
+post-install:
+ ${LN} -sf libamathapp.so ${STAGEDIR}${PREFIX}/lib/amath/libamathapp.so.1
+ ${LN} -sf libamathcplex.so ${STAGEDIR}${PREFIX}/lib/amath/libamathcplex.so.1
+ ${LN} -sf libamathc.so ${STAGEDIR}${PREFIX}/lib/amath/libamathc.so.1
+ ${LN} -sf libamath.so ${STAGEDIR}${PREFIX}/lib/amath/libamath.so.1
.include <bsd.port.mk>