aboutsummaryrefslogtreecommitdiff
path: root/math/apc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /math/apc
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'math/apc')
-rw-r--r--math/apc/Makefile4
-rw-r--r--math/apc/files/patch-aa25
2 files changed, 17 insertions, 12 deletions
diff --git a/math/apc/Makefile b/math/apc/Makefile
index ee7b8b1378d1..6b8cf58ff4a4 100644
--- a/math/apc/Makefile
+++ b/math/apc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= apc
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= arved
@@ -17,7 +17,7 @@ COMMENT= An xforms based Auto Payment Calculator
LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
-USE_X_PREFIX= yes
+USE_XORG= x11 xpm
MAN1= apc.1
MANCOMPRESSED= yes
PLIST_FILES= bin/apc
diff --git a/math/apc/files/patch-aa b/math/apc/files/patch-aa
index 9d55486bc273..b5315b810a3d 100644
--- a/math/apc/files/patch-aa
+++ b/math/apc/files/patch-aa
@@ -1,16 +1,21 @@
---- Makefile.orig Mon Oct 13 15:25:38 1997
-+++ Makefile Tue Jul 2 01:04:00 2002
-@@ -1,8 +1,11 @@
+--- ./Makefile.orig 1997-10-13 21:25:38.000000000 +0200
++++ ./Makefile 2008-04-13 18:59:23.000000000 +0200
+@@ -1,10 +1,13 @@
# New Makefile for apc (13 October 1997)
#
-CFLAGS+=-DOS=\"$(OSTYPE)\" -I${X11BASE}/include
-+.if exists(${X11BASE}/include/X11/forms.h)
-+XFORMSINC=-I${X11BASE}/include/X11
-+.endif
-+CFLAGS+=-DOS=\"$(OSTYPE)\" -I${X11BASE}/include ${XFORMSINC}
- LDFLAGS+=-L${X11BASE}/lib
+-LDFLAGS+=-L${X11BASE}/lib
-LDADD+=-lxforms -lX11 -lm
+-BINDIR=${X11BASE}/bin
+-MANDIR=${X11BASE}/man/man
++.if exists(${LOCALBASE}/include/X11/forms.h)
++XFORMSINC=-I${LOCALBASE}/include/X11
++.endif
++CFLAGS+=-DOS=\"$(OSTYPE)\" -I${LOCALBASE}/include ${XFORMSINC}
++LDFLAGS+=-L${LOCALBASE}/lib
+LDADD+=-lforms -lX11 -lm -lXpm
- BINDIR=${X11BASE}/bin
- MANDIR=${X11BASE}/man/man
++BINDIR=${LOCALBASE}/bin
++MANDIR=${LOCALBASE}/man/man
PROG= apc
+ SRCS= about.c apc.c calculate.c main.c mathfun.c setfns.c
+