aboutsummaryrefslogtreecommitdiff
path: root/math/aribas
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-20 14:04:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-20 14:04:09 +0000
commitfdf638f9b97f374d5654310030a3e800847528b0 (patch)
treed3b6a512c12ef64621dbaa006f0759ded5bbb08d /math/aribas
parent7c8d35e329f02775cee68c5c3223836cb6424490 (diff)
downloadports-fdf638f9b97f374d5654310030a3e800847528b0.tar.gz
ports-fdf638f9b97f374d5654310030a3e800847528b0.zip
Notes
Diffstat (limited to 'math/aribas')
-rw-r--r--math/aribas/Makefile40
-rw-r--r--math/aribas/distinfo3
-rw-r--r--math/aribas/pkg-descr8
3 files changed, 51 insertions, 0 deletions
diff --git a/math/aribas/Makefile b/math/aribas/Makefile
new file mode 100644
index 000000000000..3302ccfdd56b
--- /dev/null
+++ b/math/aribas/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: aribas
+# Date created: 2007-06-19
+# Whom: Lars Engels <lars.engels@0x20.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aribas
+PORTVERSION= 1.53
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.mathematik.uni-muenchen.de/pub/forster/aribas/ \
+ http://bsd-geek.de/FreeBSD/distfiles/
+
+MAINTAINER= lars.engels@0x20.net
+COMMENT= Interpreter for big integer/multi-precision floating point arithmetic
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+PLIST_FILES= bin/aribas
+PORTDOCS= README aribas.doc aribas.man aribas.tut
+PORTEXAMPLES= README factor.ari pi.ari queens.ari
+MAN1= aribas.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CC/d;' \
+ -e '/^CFLAGS/s/-O//' ${BUILD_WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/aribas ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/aribas/distinfo b/math/aribas/distinfo
new file mode 100644
index 000000000000..5b394509df13
--- /dev/null
+++ b/math/aribas/distinfo
@@ -0,0 +1,3 @@
+MD5 (aribas-1.53.tar.gz) = 80efac1c3233e9c5dbe6190e444026fd
+SHA256 (aribas-1.53.tar.gz) = f267a1b58d4f9d68a635931963066b8b789eb719cd69b1ed04cb2860bd2a3d62
+SIZE (aribas-1.53.tar.gz) = 283085
diff --git a/math/aribas/pkg-descr b/math/aribas/pkg-descr
new file mode 100644
index 000000000000..b09080936d36
--- /dev/null
+++ b/math/aribas/pkg-descr
@@ -0,0 +1,8 @@
+ARIBAS is an interactive interpreter for big integer arithmetic and
+multi-precision floating point arithmetic with a Pascal/Modula like
+syntax. It has several builtin functions for algorithmic number
+theory like gcd, Jacobi symbol, Rabin probabilistic prime test,
+continued fraction and quadratic sieve factorization, Pollard rho
+factorization, etc.
+
+WWW: http://www.mathematik.uni-muenchen.de/~forster/sw/adownload.html