aboutsummaryrefslogtreecommitdiff
path: root/math/arpack-ng/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
commit8d6597e0bb9591c40fc6d0c6e2159fca51178d56 (patch)
treed3548a0f08ca434f11cb4415a93d98037409413b /math/arpack-ng/Makefile
parenta9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (diff)
downloadports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.tar.gz
ports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.zip
Notes
Diffstat (limited to 'math/arpack-ng/Makefile')
-rw-r--r--math/arpack-ng/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/arpack-ng/Makefile b/math/arpack-ng/Makefile
index ef3070da8c9f..d1960efb0d07 100644
--- a/math/arpack-ng/Makefile
+++ b/math/arpack-ng/Makefile
@@ -31,7 +31,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
OPTIONS_DEFINE= DOCS MPI
OPTIONS_SUB= yes
MPI_CONFIGURE_ENABLE= mpi
-MPI_LIB_DEPENDS= libmpich.so.8:${PORTSDIR}/net/mpich2
+MPI_LIB_DEPENDS= libmpich.so.8:net/mpich2
MPI_CONFLICTS_INSTALL+= arpack-ng-3.*
MPI_CONFLICTS_INSTALL_OFF+= arpack-ng-mpich-3.*
@@ -46,16 +46,16 @@ WITH_BLAS?= blas
.if ${WITH_BLAS} == "gotoblas"
BLAS= -lgoto2p
LAPACK= -lgoto2p
-LIB_DEPENDS+= libgoto2p.so:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= libgoto2p.so:math/gotoblas
.elif ${WITH_BLAS} == "atlas"
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
-LIB_DEPENDS+= libptf77blas.so:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libptf77blas.so:math/atlas
.elif ${WITH_BLAS} == "blas"
BLAS= -lblas
LAPACK= -llapack
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
- liblapack.so:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:math/blas \
+ liblapack.so:math/lapack
.else
IGNORE= unknown value of WITH_BLAS: ${WITH_BLAS}
.endif