aboutsummaryrefslogtreecommitdiff
path: root/math/arpack-ng
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2012-06-27 05:58:22 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2012-06-27 05:58:22 +0000
commitfeb3539c1254d671dfb61846e9ae931231f05b9f (patch)
tree6d2da96f62a69820a20f3cd08552f6ba2eb00f63 /math/arpack-ng
parent19c24d28a3056d175fa08b67c79453d1fefe848a (diff)
downloadports-feb3539c1254d671dfb61846e9ae931231f05b9f.tar.gz
ports-feb3539c1254d671dfb61846e9ae931231f05b9f.zip
Add arpack-ng 3.1.1, revised Argand library for solving large-scale
eigenvalue problems.
Notes
Notes: svn path=/head/; revision=300064
Diffstat (limited to 'math/arpack-ng')
-rw-r--r--math/arpack-ng/Makefile86
-rw-r--r--math/arpack-ng/distinfo2
-rw-r--r--math/arpack-ng/pkg-descr3
3 files changed, 91 insertions, 0 deletions
diff --git a/math/arpack-ng/Makefile b/math/arpack-ng/Makefile
new file mode 100644
index 000000000000..dc58e9f5d6a1
--- /dev/null
+++ b/math/arpack-ng/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: arpack-ng
+# Date created: 26 June 2012
+# Whom: bf <bf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arpack-ng
+PORTVERSION= 3.1.1
+CATEGORIES= math
+MASTER_SITES= http://forge.scilab.org/index.php/p/arpack-ng/downloads/get/ \
+ LOCAL/bf
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= bf@FreeBSD.org
+COMMENT= Revised Argand library for solving large-scale eigenvalue problems
+
+LICENSE= BSD
+
+USE_FORTRAN= yes
+USE_LDCONFIG= yes
+
+CONFLICTS= arpack-[0-9]*
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS = --disable-mpi --with-blas="${BLAS}" \
+ --with-lapack="${LAPACK}"
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/dnsimp \
+ lib/libarpack.a \
+ lib/libarpack.la \
+ lib/libarpack.so \
+ lib/libarpack.so.2 \
+ libdata/pkgconfig/arpack.pc
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PORTDOCS= *
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+PORTEXAMPLES= *
+.endif
+
+WITH_BLAS?= blas
+
+.if ${WITH_BLAS} == "gotoblas"
+BLAS= -lgoto2p
+LAPACK = -lgoto2p
+LIB_DEPENDS+= goto2p:${PORTSDIR}/math/gotoblas
+.elif ${WITH_BLAS} == "atlas"
+BLAS= -lptf77blas
+LAPACK = -lalapack -lptcblas
+LIB_DEPENDS+= ptf77blas:${PORTSDIR}/math/atlas
+.elif ${WITH_BLAS} == "blas"
+BLAS= -lblas
+LAPACK = -llapack
+LIB_DEPENDS+= blas:${PORTSDIR}/math/blas \
+ lapack:${PORTSDIR}/math/lapack
+.else
+IGNORE = unknown value of WITH_BLAS: ${WITH_BLAS}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's|\(libdir\)(/pkgconfig)|(prefix)/libdata\1|' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/DOCUMENTS && ${COPYTREE_SHARE} \* ${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/EXAMPLES && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
+.endif
+
+check regression-test test: build
+ @cd ${WRKSRC}/TESTS ; \
+ ${SETENV} LD_LIBRARY_PATH="${WRKSRC}/.libs:/lib:${LOCALBASE}/lib" \
+ ./dnsimp
+
+.include <bsd.port.post.mk>
diff --git a/math/arpack-ng/distinfo b/math/arpack-ng/distinfo
new file mode 100644
index 000000000000..c545c95a654b
--- /dev/null
+++ b/math/arpack-ng/distinfo
@@ -0,0 +1,2 @@
+SHA256 (arpack-ng_3.1.1.tar.gz) = be250947a7d6eac7dff8c058102fce9922c524aa06be2a090b6e0bb2d1e228cd
+SIZE (arpack-ng_3.1.1.tar.gz) = 1295404
diff --git a/math/arpack-ng/pkg-descr b/math/arpack-ng/pkg-descr
new file mode 100644
index 000000000000..091434ec2f67
--- /dev/null
+++ b/math/arpack-ng/pkg-descr
@@ -0,0 +1,3 @@
+ARPACK-NG is a collection of Fortran77 subroutines designed to solve
+large-scale eigenvalue problems. It is a fork of the Rice University
+ARPACK, and is jointly-maintained by Debian, Octave, and Scilab.