aboutsummaryrefslogtreecommitdiff
path: root/math/arpack
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-05-05 11:39:23 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-05-05 11:39:23 +0000
commit621e11e202bae5b86ce3f4f538c47b56f50c93ec (patch)
tree94c0a44559dc8099d4ac8a6cd5fe4daa2e051af5 /math/arpack
parentf113f69db8db489b3c20b3e1d1b7f7d149eeb3f9 (diff)
downloadports-621e11e202bae5b86ce3f4f538c47b56f50c93ec.tar.gz
ports-621e11e202bae5b86ce3f4f538c47b56f50c93ec.zip
Notes
Diffstat (limited to 'math/arpack')
-rw-r--r--math/arpack/Makefile56
-rw-r--r--math/arpack/distinfo2
-rw-r--r--math/arpack/files/patch-Armake.inc52
-rw-r--r--math/arpack/pkg-descr22
-rw-r--r--math/arpack/pkg-plist6
5 files changed, 138 insertions, 0 deletions
diff --git a/math/arpack/Makefile b/math/arpack/Makefile
new file mode 100644
index 000000000000..a3bdc4989673
--- /dev/null
+++ b/math/arpack/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: arpack
+# Date created: 31 Jan 2003
+# Whom: Pedro F. Giffuni
+#
+# $FreeBSD$
+#
+
+PORTNAME= arpack
+PORTVERSION= 96
+CATEGORIES= math
+MASTER_SITES= http://www.caam.rice.edu/software/ARPACK/SRC/
+DISTFILES= ${PORTNAME}${PORTVERSION}.tar.gz patch.tar.Z
+
+PATCH_SITES= http://www.caam.rice.edu/software/ARPACK/SRC/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Argand Library (serial version)
+
+DIST_SUBDIR= arpack
+
+WRKSRC= ${WRKDIR}/ARPACK
+ALL_TARGET= lib
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/f2c:${PORTSDIR}/lang/f2c
+
+MAKE_ENV= HOME=${WRKSRC}
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+pre-patch:
+ @(cd ${WRKSRC}; tar -xzf ${DISTDIR}/${DIST_SUBDIR}/patch.tar.Z)
+
+post-patch:
+ @${REINPLACE_CMD} -e 's+%FC%+${FC}+g;' ${WRKSRC}/ARmake.inc
+ @${REINPLACE_CMD} -e 's+%FFLAGS%+${FFLAGS}+g;' ${WRKSRC}/ARmake.inc
+
+do-install:
+ ${INSTALL} ${WRKSRC}/libarpack.a ${PREFIX}/lib
+ (${MKDIR} ${WRKSRC}/include ;\
+ cd ${WRKSRC}/include ;\
+ f2c -C++ -P ${WRKSRC}/SRC/*.f ;\
+ f2c -C++ -P ${WRKSRC}/BLAS/*.f ;\
+ f2c -C++ -P ${WRKSRC}/LAPACK/*.f ;\
+ ${CAT} *.P | ${GREP} -v :ref: > arpack.h)
+ ${INSTALL_DATA} ${WRKSRC}/include/arpack.h ${PREFIX}/include
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} $(PREFIX)/share/doc/arpack
+ -${GZIP_CMD} ${GZIP} ${WRKSRC}/DOCUMENTS/ex-*.doc
+ ${CP} $(WRKSRC)/DOCUMENTS/ex-*.doc.gz $(PREFIX)/share/doc/arpack/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/arpack/distinfo b/math/arpack/distinfo
new file mode 100644
index 000000000000..62beba3e4e3c
--- /dev/null
+++ b/math/arpack/distinfo
@@ -0,0 +1,2 @@
+MD5 (arpack/arpack96.tar.gz) = fffaa970198b285676f4156cebc8626e
+MD5 (arpack/patch.tar.Z) = f323dafc1610d45fb98987cf76a7d344
diff --git a/math/arpack/files/patch-Armake.inc b/math/arpack/files/patch-Armake.inc
new file mode 100644
index 000000000000..c81b622d72c7
--- /dev/null
+++ b/math/arpack/files/patch-Armake.inc
@@ -0,0 +1,52 @@
+--- ARmake.inc.orig Sat Apr 27 04:12:57 1996
++++ ARmake.inc Mon May 5 20:12:25 2003
+@@ -25,14 +25,14 @@
+ # | other than your home directory. |
+ # %--------------------------------------%
+ #
+-home = $(HOME)/ARPACK
++home = $(HOME)
+ #
+ # %--------------------------------------%
+ # | The platform identifier to suffix to |
+ # | the end of library names |
+ # %--------------------------------------%
+ #
+-PLAT = SUN4
++PLAT = FBSD
+ #
+ # %------------------------------------------------------%
+ # | The directories to find the various pieces of ARPACK |
+@@ -57,9 +57,9 @@
+ # | The name of the libraries to be created/linked to |
+ # %---------------------------------------------------%
+ #
+-ARPACKLIB = $(home)/libarpack_$(PLAT).a
+-LAPACKLIB =
+-BLASLIB =
++ARPACKLIB = $(home)/libarpack.a
++LAPACKLIB = $(home)/liblapack.a
++BLASLIB = $(home)/libblas.a
+ #
+ ALIBS = $(ARPACKLIB) $(LAPACKLIB) $(BLASLIB)
+ #
+@@ -101,8 +101,8 @@
+ # | for your system. |
+ # %-----------------------------------------%
+ #
+-FC = f77
+-FFLAGS = -O -cg89
++FC = %FC%
++FFLAGS = %FFLAGS%
+
+ LDFLAGS =
+ CD = cd
+@@ -112,7 +112,7 @@
+ LN = ln
+ LNFLAGS = -s
+
+-MAKE = /bin/make
++MAKE ?= /usr/bin/make
+
+ RM = rm
+ RMFLAGS = -f
diff --git a/math/arpack/pkg-descr b/math/arpack/pkg-descr
new file mode 100644
index 000000000000..54629b06b161
--- /dev/null
+++ b/math/arpack/pkg-descr
@@ -0,0 +1,22 @@
+ARPACK is a collection of Fortran77 subroutines designed to solve large
+scale eigenvalue problems.
+
+The package is designed to compute a few eigenvalues and corresponding
+eigenvectors of a general n by n matrix A. It is most appropriate for large
+sparse or structured matrices A where structured means that a matrix-vector
+product w <- Av requires order n rather than the usual order n**2 floating
+point operations. This software is based upon an algorithmic variant of the
+Arnoldi process called the Implicitly Restarted Arnoldi Method (IRAM). When
+the matrix A is symmetric it reduces to a variant of the Lanczos process
+called the Implicitly Restarted Lanczos Method (IRLM). These variants may be
+viewed as a synthesis of the Arnoldi/Lanczos process with the Implicitly
+Shifted QR technique that is suitable for large scale problems. For many
+standard problems, a matrix factorization is not required. Only the action
+of the matrix on a vector is needed. ARPACK software is capable of solving
+large scale symmetric, nonsymmetric, and generalized eigenproblems from
+significant application areas. The software is designed to compute a few (k)
+eigenvalues with user specified features such as those of largest real part
+or largest magnitude. Storage requirements are on the order of n*k locations.
+No auxiliary storage is required. A set of Schur basis vectors for the desired
+k-dimensional eigen-space is computed which is numerically orthogonal to working
+precision. Numerically accurate eigenvectors are available on request.
diff --git a/math/arpack/pkg-plist b/math/arpack/pkg-plist
new file mode 100644
index 000000000000..471adb3849f9
--- /dev/null
+++ b/math/arpack/pkg-plist
@@ -0,0 +1,6 @@
+include/arpack.h
+lib/libarpack.a
+share/doc/arpack/ex-complex.doc.gz
+share/doc/arpack/ex-nonsym.doc.gz
+share/doc/arpack/ex-sym.doc.gz
+@dirrm share/doc/arpack