aboutsummaryrefslogtreecommitdiff
path: root/math/asymptote/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-18 17:49:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-18 17:49:19 +0000
commit389d040f5ccd72111f70a168c52faf1ef6742b68 (patch)
tree9cfb69174d7ade4ef5052de6f02e6ea094612773 /math/asymptote/Makefile
parent6f8061cd64722cc458543d5e7c0796e06e282176 (diff)
downloadports-389d040f5ccd72111f70a168c52faf1ef6742b68.tar.gz
ports-389d040f5ccd72111f70a168c52faf1ef6742b68.zip
Notes
Diffstat (limited to 'math/asymptote/Makefile')
-rw-r--r--math/asymptote/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 630e67327ab4..abd33c149201 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asymptote
-PORTVERSION= 0.91
-PORTREVISION= 1
+PORTVERSION= 0.92
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,9 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= nivit@email.it
COMMENT= A powerful script-based vector graphics language
-LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc \
- fftw3.3:${PORTSDIR}/math/fftw3
-BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3
+BUILD_DEPENDS= ${NOEXISTENT}:${PORTSDIR}/devel/boehm-gc:fetch \
+ convert:${PORTSDIR}/graphics/ImageMagick \
latex:${PORTSDIR}/print/teTeX \
makeinfo:${PORTSDIR}/textproc/texi2html \
${MKTEXLSR}:${PORTSDIR}/print/teTeX \
@@ -35,7 +34,7 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gc=system \
+CONFIGURE_ARGS= --enable-gc=${GCVERSION} \
--with-latex=${LOCALBASE}/share/texmf-local/tex/latex
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
@@ -55,6 +54,11 @@ ALL_TARGET+= doc
INSTALL_TARGET+= install-doc
.endif
+LN_OPTS= -sf
+
+GCVERSION= 6.6
+GC_DISTNAME= gc${GCVERSION}.tar.gz
+
post-install:
@${CAT} ${PKGMESSAGE}
@@ -64,4 +68,8 @@ post-install:
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
+pre-configure:
+ @cd ${WRKSRC}; \
+ ${LN} ${LN_OPTS} ${DISTDIR}/${GC_DISTNAME} ${GC_DISTNAME}
+
.include <bsd.port.post.mk>