aboutsummaryrefslogtreecommitdiff
path: root/math/asymptote
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-06-15 11:03:29 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-06-15 11:03:29 +0000
commitecf5be1635860a3f03c31ec3aa5667c16e91aa3c (patch)
treea954d3cb8b4bccc866752a3149f5522caaec26b8 /math/asymptote
parentd36bca93933830aa09ff052d6699afe551615631 (diff)
downloadports-ecf5be1635860a3f03c31ec3aa5667c16e91aa3c.tar.gz
ports-ecf5be1635860a3f03c31ec3aa5667c16e91aa3c.zip
Notes
Diffstat (limited to 'math/asymptote')
-rw-r--r--math/asymptote/Makefile58
-rw-r--r--math/asymptote/distinfo6
-rw-r--r--math/asymptote/files/patch-runtime.in11
-rw-r--r--math/asymptote/files/patch-xstream.h23
-rw-r--r--math/asymptote/pkg-plist2
5 files changed, 70 insertions, 30 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 2492caa0c9a3..76007719132b 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= asymptote
-PORTVERSION= 2.41
-PORTREVISION= 4
+PORTVERSION= 2.44
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -14,17 +13,38 @@ COMMENT= Powerful script-based vector graphics language
LICENSE= GPLv3 LGPL3
LICENSE_COMB= dual
-LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
- libsigsegv.so:devel/libsigsegv
+ONLY_FOR_ARCHS= amd64 i386
+
+LIB_DEPENDS= libsigsegv.so:devel/libsigsegv
RUN_DEPENDS= animate:graphics/ImageMagick \
gv:print/gv \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
-ALL_TARGET= asy asy-keywords.el
+USES= compiler:c++14-lang gettext-runtime ghostscript gmake ncurses perl5 python \
+ shebangfix tar:tgz
+SHEBANG_FILES= GUI/*.py
+USE_GL= gl glu glut
+USE_PERL5= build
+USE_TEX= dvipsk formats
-CONFIGURE_ARGS= --enable-gc=system
CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+
+MAKE_ENV= ASYMPTOTE_HOME=${WRKDIR} HOME=${WRKDIR}
+MAKE_JOBS_UNSAFE= yes
+
+ALL_TARGET= asy asy-keywords.el
+INSTALL_TARGET= install-asy
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFAULT= FFTW GSL MANPAGES READLINE
+OPTIONS_DEFINE= BDWGC DOCS EXAMPLES FFTW GSL MANPAGES OFFSCREEN READLINE
+
+BDWGC_LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded
+BDWGC_DESC= Enable Boehm-Demers-Weiser garbage collector
+BDWGC_CONFIGURE_ENABLE= gc=${LOCALBASE}
DOCS_ALL_TARGET= html
DOCS_BUILD_DEPENDS= texi2dvi:print/texinfo
@@ -35,15 +55,10 @@ FFTW_CONFIGURE_ENABLE= fftw
FFTW_DESC= Use FFTW to compute the Discrete Fourier Transform
FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
-GNU_CONFIGURE= yes
GSL_CONFIGURE_ENABLE= gsl
GSL_DESC= Enable GNU Scientific library
GSL_LIB_DEPENDS= libgsl.so:math/gsl
-INSTALL_TARGET= install-asy
-
-MAKE_ENV= ASYMPTOTE_HOME=${WRKDIR} HOME=${WRKDIR}
-MAKE_JOBS_UNSAFE= yes
MANPAGES_ALL_TARGET= man
MANPAGES_BUILD_DEPENDS= texi2dvi:print/texinfo
MANPAGES_INFO= asy-faq
@@ -52,32 +67,21 @@ MANPAGE_INSTALL_TARGET= install-man
OFFSCREEN_CONFIGURE_ENABLE= offscreen
OFFSCREEN_DESC= Enable offscreen rendering using OSMesa library
OFFSCREEN_LIB_DEPENDS= libOSMesa.so:graphics/libosmesa
-ONLY_FOR_ARCHS= amd64 i386
-OPTIONS_DEFAULT= FFTW GSL MANPAGES READLINE
-OPTIONS_DEFINE= DOCS EXAMPLES FFTW GSL MANPAGES OFFSCREEN READLINE
READLINE_CONFIGURE_ENABLE= readline
-READLINE_DESC= ${LIBEDIT_DESC}
-READLINE_USES= readline
-
-SHEBANG_FILES= GUI/*.py
-
-USES= gettext-runtime ghostscript gmake ncurses perl5 python \
- shebangfix tar:tgz
-USE_GL= glut
-USE_PERL5= build
-USE_TEX= dvipsk formats
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+READLINE_USES= readline:port
post-patch:
@${REINPLACE_CMD} 's/-lgc/-lgc-threaded/' ${WRKSRC}/configure
@${REINPLACE_CMD} 's,/usr/lib/libgs.so,${LOCALBASE}/lib/libgs.so,' \
${WRKSRC}/settings.cc
+ @${REINPLACE_CMD} 's,makeinfo,${LOCALBASE}/bin/makeinfo,' \
+ ${WRKSRC}/doc/png/Makefile.in
+
# Fix the python interpreter in the generated file share/asymptote/GUI/xasyVersion.py:
@${REINPLACE_CMD} 's,/usr/bin/env python,${PYTHON_CMD},' ${WRKSRC}/Makefile.in
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asy
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asy
.include <bsd.port.mk>
diff --git a/math/asymptote/distinfo b/math/asymptote/distinfo
index ccc6ea1880ba..052afdf816d0 100644
--- a/math/asymptote/distinfo
+++ b/math/asymptote/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500975929
-SHA256 (asymptote-2.41.src.tgz) = 1d6e7e89fb5293fad7d836fb0477f785a113f689bd71f37a05af18ff0c5eeef0
-SIZE (asymptote-2.41.src.tgz) = 3516426
+TIMESTAMP = 1527856340
+SHA256 (asymptote-2.44.src.tgz) = 6f9bd2f1ed2835aa69ec382fefbec55ba5ec859341a42a543631a7f04ada49e7
+SIZE (asymptote-2.44.src.tgz) = 3549129
diff --git a/math/asymptote/files/patch-runtime.in b/math/asymptote/files/patch-runtime.in
new file mode 100644
index 000000000000..cc77688859b0
--- /dev/null
+++ b/math/asymptote/files/patch-runtime.in
@@ -0,0 +1,11 @@
+--- runtime.in.orig 2018-06-03 13:52:26 UTC
++++ runtime.in
+@@ -85,7 +85,7 @@ stringarray2* => stringArray2()
+ #include "process.h"
+ #include "arrayop.h"
+
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ extern "C" int isnan(double);
+ #endif
+
diff --git a/math/asymptote/files/patch-xstream.h b/math/asymptote/files/patch-xstream.h
new file mode 100644
index 000000000000..fb97b38e644d
--- /dev/null
+++ b/math/asymptote/files/patch-xstream.h
@@ -0,0 +1,23 @@
+--- xstream.h.orig 2018-06-10 15:14:47 UTC
++++ xstream.h
+@@ -31,7 +31,7 @@
+ #define quad_t long long
+ #define u_quad_t unsigned long long
+
+-#if defined(__CYGWIN__) || defined(__FreeBSD__)
++#if defined(__CYGWIN__)
+ #include <sys/select.h>
+ #define u_char unsigned char
+ #define u_int unsigned int
+@@ -41,6 +41,11 @@ extern "C" int fseeko(FILE *, off_t, int
+ extern "C" off_t ftello(FILE *);
+ #endif
+
++#ifdef __FreeBSD__
++#define xdr_longlong_t xdr_int64_t
++#define xdr_u_longlong_t xdr_u_int64_t
++#endif
++
+ #ifdef _POSIX_SOURCE
+ #undef _POSIX_SOURCE
+ #include <rpc/rpc.h>
diff --git a/math/asymptote/pkg-plist b/math/asymptote/pkg-plist
index c1226420223b..55209735b220 100644
--- a/math/asymptote/pkg-plist
+++ b/math/asymptote/pkg-plist
@@ -160,6 +160,7 @@ man/man1/xasy.1x.gz
%%DATADIR%%/plain_strings.asy
%%DATADIR%%/plain_xasy.asy
%%DATADIR%%/pstoedit.asy
+%%DATADIR%%/rational.asy
%%DATADIR%%/reload.js
%%DATADIR%%/roundedpath.asy
%%DATADIR%%/simplex.asy
@@ -360,6 +361,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/limit.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lineargraph.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lineargraph0.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/linearregression.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lines.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/linetype.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lmfit1.asy