aboutsummaryrefslogtreecommitdiff
path: root/math/asymptote
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-05-04 05:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-05-04 05:20:31 +0000
commit55ba82c629a110f34819be090b42c0a7c1bc5c7c (patch)
tree2e971df78e45afbe4daa63cf15a5b262d013a96d /math/asymptote
parent79801aef19076749ff7f22f969f3864f44a3ae2f (diff)
downloadports-55ba82c629a110f34819be090b42c0a7c1bc5c7c.tar.gz
ports-55ba82c629a110f34819be090b42c0a7c1bc5c7c.zip
Fix shebangs
Reviewed by: mat Approved by: mat Differential Revision: https://reviews.freebsd.org/D10527
Notes
Notes: svn path=/head/; revision=440084
Diffstat (limited to 'math/asymptote')
-rw-r--r--math/asymptote/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 75e7308e991c..253a88b4304a 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asymptote
PORTVERSION= 2.37
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -35,11 +35,14 @@ MAKE_JOBS_UNSAFE= yes
ONLY_FOR_ARCHS= i386 amd64
-USES= gettext-runtime ghostscript gmake ncurses perl5 python tar:tgz
+USES= gettext-runtime ghostscript gmake ncurses perl5 python \
+ shebangfix tar:tgz
USE_GL= glut
USE_PERL5= build
USE_TEX= dvipsk formats
+SHEBANG_FILES= GUI/*.py
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
# Options
@@ -84,6 +87,8 @@ post-patch:
@${REINPLACE_CMD} 's/-lgc/-lgc-threaded/' ${WRKSRC}/configure
@${REINPLACE_CMD} 's,/usr/lib/libgs.so,${LOCALBASE}/lib/libgs.so,' \
${WRKSRC}/settings.cc
+# Fix the python interpreter in the generated file share/asymptote/GUI/xasyVersion.py:
+ @${REINPLACE_CMD} 's,/usr/bin/env python,${PYTHON_CMD},' ${WRKSRC}/Makefile.in
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asy