aboutsummaryrefslogtreecommitdiff
path: root/math/asymptote
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-18 17:49:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-18 17:49:19 +0000
commit389d040f5ccd72111f70a168c52faf1ef6742b68 (patch)
tree9cfb69174d7ade4ef5052de6f02e6ea094612773 /math/asymptote
parent6f8061cd64722cc458543d5e7c0796e06e282176 (diff)
downloadports-389d040f5ccd72111f70a168c52faf1ef6742b68.tar.gz
ports-389d040f5ccd72111f70a168c52faf1ef6742b68.zip
Notes
Diffstat (limited to 'math/asymptote')
-rw-r--r--math/asymptote/Makefile20
-rw-r--r--math/asymptote/distinfo4
-rw-r--r--math/asymptote/files/patch-Makefile.in7
-rw-r--r--math/asymptote/files/patch-doc-Makefile15
-rw-r--r--math/asymptote/pkg-plist17
5 files changed, 43 insertions, 20 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 630e67327ab4..abd33c149201 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= asymptote
-PORTVERSION= 0.91
-PORTREVISION= 1
+PORTVERSION= 0.92
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,9 +14,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= nivit@email.it
COMMENT= A powerful script-based vector graphics language
-LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc \
- fftw3.3:${PORTSDIR}/math/fftw3
-BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3
+BUILD_DEPENDS= ${NOEXISTENT}:${PORTSDIR}/devel/boehm-gc:fetch \
+ convert:${PORTSDIR}/graphics/ImageMagick \
latex:${PORTSDIR}/print/teTeX \
makeinfo:${PORTSDIR}/textproc/texi2html \
${MKTEXLSR}:${PORTSDIR}/print/teTeX \
@@ -35,7 +34,7 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gc=system \
+CONFIGURE_ARGS= --enable-gc=${GCVERSION} \
--with-latex=${LOCALBASE}/share/texmf-local/tex/latex
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
MAKE_ENV+= ${CONFIGURE_ENV}
@@ -55,6 +54,11 @@ ALL_TARGET+= doc
INSTALL_TARGET+= install-doc
.endif
+LN_OPTS= -sf
+
+GCVERSION= 6.6
+GC_DISTNAME= gc${GCVERSION}.tar.gz
+
post-install:
@${CAT} ${PKGMESSAGE}
@@ -64,4 +68,8 @@ post-install:
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
+pre-configure:
+ @cd ${WRKSRC}; \
+ ${LN} ${LN_OPTS} ${DISTDIR}/${GC_DISTNAME} ${GC_DISTNAME}
+
.include <bsd.port.post.mk>
diff --git a/math/asymptote/distinfo b/math/asymptote/distinfo
index 55c218bc00e5..3f48d28905b3 100644
--- a/math/asymptote/distinfo
+++ b/math/asymptote/distinfo
@@ -1,2 +1,2 @@
-MD5 (asymptote-0.91.tar.gz) = ed75e68e9c4f3b2038e1f9a18ec66a57
-SIZE (asymptote-0.91.tar.gz) = 540833
+MD5 (asymptote-0.92.tar.gz) = 5aed89fae8928ba581dc6736c1ce625e
+SIZE (asymptote-0.92.tar.gz) = 554823
diff --git a/math/asymptote/files/patch-Makefile.in b/math/asymptote/files/patch-Makefile.in
index 54fd16606717..e4c156ab48b5 100644
--- a/math/asymptote/files/patch-Makefile.in
+++ b/math/asymptote/files/patch-Makefile.in
@@ -1,12 +1,11 @@
-$FreeBSD$
---- Makefile.in Mon Sep 26 07:45:47 2005
-+++ Makefile.in.port Sun Oct 2 15:01:32 2005
+--- Makefile.in Thu Oct 20 09:36:42 2005
++++ Makefile.in.port Mon Oct 24 11:00:23 2005
@@ -36,7 +36,7 @@
mandir = @mandir@
datadir = @datadir@
asydir = $(datadir)/asymptote
-exampledir = $(datadir)/doc/asymptote
+exampledir = $(datadir)/examples/asymptote
+ animationsdir = $(exampledir)/animations
latexdir = @latexdir@
INSTALL = @INSTALL@
- ASYMPTOTE_DIR = ../base
diff --git a/math/asymptote/files/patch-doc-Makefile b/math/asymptote/files/patch-doc-Makefile
index 32e8f5520a6d..82c684e045db 100644
--- a/math/asymptote/files/patch-doc-Makefile
+++ b/math/asymptote/files/patch-doc-Makefile
@@ -1,6 +1,16 @@
-$FreeBSD$
--- doc/Makefile Thu Sep 29 07:53:39 2005
-+++ doc/Makefile.port Sun Oct 2 15:05:56 2005
++++ doc/Makefile.port Mon Nov 7 22:02:27 2005
+@@ -25,8 +25,8 @@
+ latexusage.eps: latexusage.dvi
+ dvips -o latexusage.eps latexusage
+
+-latexusage.png: latexusage.dvi
+- dvipng -o latexusage.png latexusage
++latexusage.png: latexusage.eps
++ convert -density 144x144 +antialias -geometry 50%x latexusage.eps latexusage.png
+
+ latexusage.pdf: latexusage.dvi
+ dvipdf latexusage
@@ -51,7 +51,8 @@
rm -rf asymptote
@@ -11,4 +21,3 @@ $FreeBSD$
${INSTALL} -m 644 $(MANFILES) $(mandir)/man1
install: doc install-man
-
diff --git a/math/asymptote/pkg-plist b/math/asymptote/pkg-plist
index 555b622f978e..0452db4f2fad 100644
--- a/math/asymptote/pkg-plist
+++ b/math/asymptote/pkg-plist
@@ -20,15 +20,19 @@ bin/xasy
%%DATADIR%%/three.asy
%%DATADIR%%/tree.asy
%%DATADIR%%/unicode.asy
+%%PORTDOCS%%%%DOCSDIR%%/asymptote.pdf
%%EXAMPLESDIR%%/Bode.asy
%%EXAMPLESDIR%%/Gouraud.asy
%%EXAMPLESDIR%%/Pythagoras.asy
%%EXAMPLESDIR%%/PythagoreanTree.asy
+%%EXAMPLESDIR%%/animations/cube.asy
+%%EXAMPLESDIR%%/animations/wheel.asy
%%EXAMPLESDIR%%/asy-mode.el
%%EXAMPLESDIR%%/asy.vim
%%EXAMPLESDIR%%/axis3.asy
%%EXAMPLESDIR%%/bezier.asy
%%EXAMPLESDIR%%/bigsquare.asy
+%%EXAMPLESDIR%%/brokenaxis.asy
%%EXAMPLESDIR%%/cardiod.asy
%%EXAMPLESDIR%%/centroidfg.asy
%%EXAMPLESDIR%%/circles.asy
@@ -47,6 +51,7 @@ bin/xasy
%%EXAMPLESDIR%%/dragon.asy
%%EXAMPLESDIR%%/eetomumu.asy
%%EXAMPLESDIR%%/elliptic.asy
+%%EXAMPLESDIR%%/epix.asy
%%EXAMPLESDIR%%/equilateral.asy
%%EXAMPLESDIR%%/equilchord.asy
%%EXAMPLESDIR%%/errorbars.asy
@@ -69,9 +74,11 @@ bin/xasy
%%EXAMPLESDIR%%/join3.asy
%%EXAMPLESDIR%%/labelbox.asy
%%EXAMPLESDIR%%/labelsquare.asy
+%%EXAMPLESDIR%%/laserlattice.asy
%%PORTDOCS%%%%EXAMPLESDIR%%/latexusage.asy
%%EXAMPLESDIR%%/latexusage.tex
%%EXAMPLESDIR%%/latticeshading.asy
+%%EXAMPLESDIR%%/leastsquares.asy
%%EXAMPLESDIR%%/lever.asy
%%EXAMPLESDIR%%/limit.asy
%%EXAMPLESDIR%%/lineargraph.asy
@@ -112,6 +119,7 @@ bin/xasy
%%EXAMPLESDIR%%/sqrtx01.asy
%%EXAMPLESDIR%%/sqrtx01y1.asy
%%EXAMPLESDIR%%/square.asy
+%%EXAMPLESDIR%%/star.asy
%%EXAMPLESDIR%%/subpictures.asy
%%EXAMPLESDIR%%/superpath.asy
%%EXAMPLESDIR%%/surface.asy
@@ -127,16 +135,15 @@ bin/xasy
%%EXAMPLESDIR%%/wedge.asy
%%EXAMPLESDIR%%/westnile.asy
%%EXAMPLESDIR%%/westnile.csv
-%%EXAMPLESDIR%%/wheelanimation.asy
%%EXAMPLESDIR%%/workcone.asy
%%EXAMPLESDIR%%/xsin1x.asy
%%EXAMPLESDIR%%/xxsq01.asy
%%EXAMPLESDIR%%/yingyang.asy
-%%PORTDOCS%%%%DOCSDIR%%/asymptote.pdf
-share/texmf-local/tex/latex/asymptote/asymptote.sty
-@dirrm share/texmf-local/tex/latex/asymptote
@dirrm %%DATADIR%%
-@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/
+@dirrm %%EXAMPLESDIR%%/animations
+@dirrm %%EXAMPLESDIR%%
+share/texmf-local/tex/latex/asymptote/asymptote.sty
+@dirrm share/texmf-local/tex/latex/asymptote
@unexec %%MKTEXLSR%%
@exec %%MKTEXLSR%%