aboutsummaryrefslogtreecommitdiff
path: root/math/atlas-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-03-17 09:46:36 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-03-17 09:46:36 +0000
commit3718781425c1a71822528a8fa20860f51d08e384 (patch)
tree7737ec94b28e5f07e980f7c49fefc1cc1b06a31b /math/atlas-devel
parentf728044365d4e74d964dd4a9b300fbde4520b63d (diff)
downloadports-3718781425c1a71822528a8fa20860f51d08e384.tar.gz
ports-3718781425c1a71822528a8fa20860f51d08e384.zip
Notes
Diffstat (limited to 'math/atlas-devel')
-rw-r--r--math/atlas-devel/Makefile13
-rw-r--r--math/atlas-devel/files/patch-config.c32
2 files changed, 27 insertions, 18 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 6e27deb422d1..e184cfa2e292 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -43,9 +43,8 @@ post-patch:
.if !defined(WITH_OPTIMIZED_FLAGS)
@${ECHO_CMD} "You can optimize lapack sub project by setting WITH_OPTIMIZED_FLAGS=yes."
.endif
- @${REINPLACE_CMD} -e 's+%%PTHREAD_CFLAGS%%+ ${PTHREAD_CFLAGS}+' \
- ${WRKSRC}/config.c
- @${REINPLACE_CMD} -e 's+%%PTHREAD_LIBS%%+ ${PTHREAD_LIBS}+' \
+ @${REINPLACE_CMD} -e 's+%%PTHREAD_CFLAGS%%+${PTHREAD_CFLAGS}+g' \
+ -e 's+%%PTHREAD_LIBS%%+${PTHREAD_LIBS}+g' \
${WRKSRC}/config.c
.if (${MACHINE_ARCH} == "alpha")
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/alpha-patch)
@@ -70,14 +69,14 @@ ANSWER= ${ANSWER_${ARCH}}
do-configure:
@(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig && \
- ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -a NON_THREADED && \
- ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -a NON_THREADED_PIC \
+ ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a NON_THREADED && \
+ ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a NON_THREADED_PIC \
-F c '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC' \
-F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC')
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/thread-patch && \
${MAKE_ENV} ${MAKE} xconfig && \
- ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -a THREADED && \
- ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -a THREADED_PIC \
+ ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a THREADED && \
+ ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a THREADED_PIC \
-F c '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC' \
-F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC' )
diff --git a/math/atlas-devel/files/patch-config.c b/math/atlas-devel/files/patch-config.c
index 960597aaca53..b2d4ef86dd0e 100644
--- a/math/atlas-devel/files/patch-config.c
+++ b/math/atlas-devel/files/patch-config.c
@@ -1,6 +1,16 @@
---- config.c.org Tue Jan 20 22:32:38 2004
-+++ config.c Tue Jan 20 22:32:54 2004
-@@ -1188,7 +1188,9 @@
+--- config.c.orig Mon Dec 22 23:06:32 2003
++++ config.c Wed Mar 17 18:40:50 2004
+@@ -666,7 +666,8 @@
+ sprintf(ln, "%s --version", gcc);
+ if (CmndOneLine(NULL, ln, ln2) == 0)
+ {
+- *major = GetIntVers(ln2, &j);
++ j=0; for (i=0; ln2[i] && !isspace(ln[i]); i++) j++;
++ *major = GetIntVers(ln2+j, &i);
+ if (*major != -1)
+ {
+ *minor = GetIntVers(ln2+j, &i); j += i;
+@@ -1188,7 +1189,9 @@
switch(OS)
{
case OSOSX: /* don't know answer */
@@ -11,7 +21,7 @@
case OSLinux:
break;
case OSSunOS:
-@@ -1450,9 +1452,9 @@
+@@ -1450,9 +1453,9 @@
if (THREADS && OS == OSFreeBSD)
{
if (which == CPF77)
@@ -23,7 +33,7 @@
}
break;
case OSSunOS4:
-@@ -1984,8 +1986,8 @@
+@@ -1984,8 +1987,8 @@
if (OS == OSFreeBSD)
{
if (strstr(comp, "cc"))
@@ -34,7 +44,7 @@
}
}
return(*comp ? comp : NULL);
-@@ -2801,7 +2801,7 @@
+@@ -2799,7 +2802,7 @@
else if (strstr(ln, "ia64")) la = LAIA64;
else if ( strstr(ln, "i686") || strstr(ln, "i586") ||
strstr(ln, "i486") || strstr(ln, "i386") ||
@@ -43,7 +53,7 @@
}
return(la);
}
-@@ -2835,12 +2837,22 @@
+@@ -2835,12 +2838,22 @@
}
break;
case LASPARC: /* don't know */
@@ -66,7 +76,7 @@
}
break;
case LAIA64: /* don't know */
-@@ -2849,14 +2861,32 @@
+@@ -2849,14 +2862,32 @@
if (!CmndOneLine(targ, "sysctl hw.model", ln))
{
if (strstr(ln, "Pentium Pro")) mach = IntPPRO;
@@ -104,7 +114,7 @@
}
break;
default:;
-@@ -3641,8 +3671,8 @@
+@@ -3641,8 +3672,8 @@
}
if (THREADS) /* add ncpu to ARCH */
{
@@ -115,7 +125,7 @@
}
do
{
-@@ -4047,9 +4077,9 @@
+@@ -4047,9 +4078,9 @@
if (mach == IA64Itan || mach == IA64Itan2 )
fprintf(fpout, " -DATL_MAXNREG=128");
if (ASMD != ASM_None) fprintf(fpout, " -DATL_%s", ASMNAM[ASMD]);
@@ -127,7 +137,7 @@
if (mach == IA64Itan2 && strstr(CC, "icc"))
fprintf(fpout, " -DATL_IntelIccBugs");
fprintf(fpout, "\n\n");
-@@ -4080,7 +4095,7 @@
+@@ -4080,7 +4111,7 @@
if (THREADS)
{
fprintf(fpout, " -DATL_NCPU=%d", ncpu);