aboutsummaryrefslogtreecommitdiff
path: root/math/atlas-devel
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-15 12:03:27 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-15 12:03:27 +0000
commita6f3b1c3a3b08e13528c4357e3d078f787a93835 (patch)
tree9242078301a77bb7cab67630c5ddcdc74b36c0f1 /math/atlas-devel
parent1d34b36c1cdc8d621fa91fe0c6c120b3c06ce336 (diff)
downloadports-a6f3b1c3a3b08e13528c4357e3d078f787a93835.tar.gz
ports-a6f3b1c3a3b08e13528c4357e3d078f787a93835.zip
Notes
Diffstat (limited to 'math/atlas-devel')
-rw-r--r--math/atlas-devel/Makefile1
-rw-r--r--math/atlas-devel/files/blas.h4
-rw-r--r--math/atlas-devel/files/lapack.h4
3 files changed, 5 insertions, 4 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index eb219bd3fcc7..ec64938b9076 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -46,6 +46,7 @@ CCOMPILER= ${CC}
.endif
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.if ${ARCH} == "sparc64"
PICFLAG?= -fPIC
diff --git a/math/atlas-devel/files/blas.h b/math/atlas-devel/files/blas.h
index 91a230963aab..774fbaefd0d1 100644
--- a/math/atlas-devel/files/blas.h
+++ b/math/atlas-devel/files/blas.h
@@ -2,12 +2,12 @@
// based on BLAS/WRAP/fblaswr.h
// in clapack.tgz, version 3.0(September 20, 2000)
// available at http://www.netlib.org/clapack/
-// and modified by Nakata Maho <chat95@mbox.kyoto-inet.or.jp>
+// and modified by Nakata Maho <maho@FreeBSD.org>
// for C++, which requires proper prototype definitions.
extern "C"
{
-#include <g2c.h>
+#include <f2c.h>
real
sdot_(integer* N,
diff --git a/math/atlas-devel/files/lapack.h b/math/atlas-devel/files/lapack.h
index 0e677a94bd84..fd77ee5d746f 100644
--- a/math/atlas-devel/files/lapack.h
+++ b/math/atlas-devel/files/lapack.h
@@ -1,12 +1,12 @@
// lapack prototypes for C++
// based on clapack.h in clapack.tgz, version 3.0(September 20, 2000)
// available at http://www.netlib.org/clapack/
-// and modified by Nakata Maho <chat95@mbox.kyoto-inet.or.jp>
+// and modified by Nakata Maho <maho@FreeBSD.org>
// for C++, which requires proper prototype definitions.
extern "C"
{
-#include <g2c.h>
+#include <f2c.h>
/* Subroutine */ int cbdsqr_(char *uplo, integer *n, integer *ncvt, integer *
nru, integer *ncc, real *d__, real *e, complex *vt, integer *ldvt,