aboutsummaryrefslogtreecommitdiff
path: root/math/atlas
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-08-18 05:46:25 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-08-18 05:46:25 +0000
commit4559055c68e7a9fc518167261f1e190e8a759df8 (patch)
tree1a6cc4786039aaca2b7667f84936110a184fecd2 /math/atlas
parent65cd88381c00a40cde7829b144438cdd58458e42 (diff)
downloadports-4559055c68e7a9fc518167261f1e190e8a759df8.tar.gz
ports-4559055c68e7a9fc518167261f1e190e8a759df8.zip
Notes
Diffstat (limited to 'math/atlas')
-rw-r--r--math/atlas/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index 5aeb3f963694..703ef24fd05c 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -63,15 +63,11 @@ ANSWER= ${ANSWER_${ARCH}}
do-configure:
@(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig && \
${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a NON_THREADED && \
- ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a NON_THREADED_PIC \
- -F c '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC' \
- -F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC')
+ ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a NON_THREADED_PIC -C '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC -O' )
@(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/thread-patch && \
${MAKE_ENV} ${MAKE} xconfig && \
${ANSWER} | ./xconfig -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a THREADED && \
- ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a THREADED_PIC \
- -F c '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC' \
- -F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC' )
+ ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -m ${CC} -g ${CC} -x ${CC} -a THREADED_PIC -C '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC -O' )
ATLAS_LIBS1=libalapack libatlas libcblas libf77blas libtstatlas
ATLAS_LIBS2=libptcblas libptf77blas