aboutsummaryrefslogtreecommitdiff
path: root/math/blacs
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2014-03-06 02:58:44 +0000
committerMaho Nakata <maho@FreeBSD.org>2014-03-06 02:58:44 +0000
commit494ad0d2eab566366acb40387046ff782448652e (patch)
tree96ab87fc5109234cb1d00b8e7fec8e2e17c90f4a /math/blacs
parent03dc71ceacf260fdbe29ee657e1eb45ee15ae8c7 (diff)
downloadports-494ad0d2eab566366acb40387046ff782448652e.tar.gz
ports-494ad0d2eab566366acb40387046ff782448652e.zip
fix build on FreeBSD/i386 8.x
PR: 187090 Submitted by: tijl@
Notes
Notes: svn path=/head/; revision=347160
Diffstat (limited to 'math/blacs')
-rw-r--r--math/blacs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 0225330a7ae1..fc75881da11b 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -90,7 +90,7 @@ post-build:
${MV} ${WRKSRC_SHARED}/LIB/blacsCinit_MPI-FreeBSD-${DEBUG_LEVEL}.a ${WRKSRC_SHARED}/LIB/libblacs.a
${FIND} ${WRKSRC_SHARED} -name "*\.a" -exec ${MV} {} ${WRKDIR}/tmp_shared \;
cd ${WRKDIR}/tmp_shared ; for i in `ls *.a | ${SED} 's/\.a//' `; do \
- ld -Bshareable -o $${i}.so.${SVERSION} -x -soname $${i}.so.${SVERSION} --whole-archive $${i}.a ;\
+ ${LD} -Bshareable -o $${i}.so.${SVERSION} -x -soname $${i}.so.${SVERSION} --whole-archive $${i}.a ;\
${LN} -s $${i}.so.${SVERSION} $${i}.so ;\
done