aboutsummaryrefslogtreecommitdiff
path: root/math/blacs
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-10 07:23:22 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-10 07:23:22 +0000
commit4dd38568f918f992179cc1317b0b7bc35a6cedc5 (patch)
treee7624219152c159937e026b7d65f7126851106f3 /math/blacs
parentce56c53bec034494cdf00f65562e0b58fde7cab1 (diff)
downloadports-4dd38568f918f992179cc1317b0b7bc35a6cedc5.tar.gz
ports-4dd38568f918f992179cc1317b0b7bc35a6cedc5.zip
Notes
Diffstat (limited to 'math/blacs')
-rw-r--r--math/blacs/Makefile15
-rw-r--r--math/blacs/files/Bmake.inc-mpich.diff11
2 files changed, 17 insertions, 9 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index e64916419f10..568c9e324a94 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blacs
PORTVERSION= 1.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= ftp://ftp.netlib.org/blacs/
DISTNAME= BLACS
@@ -41,14 +41,11 @@ RUN_DEPENDS= ${LOCALBASE}/mpich2/bin/mpirun:${PORTSDIR}/net/mpich2
EXTRA_PATCHES+= ${FILESDIR}/Bmake.inc-mpich.diff
.endif
-pre-fetch:
- @${ECHO} "If you want to use compiler other than f77,"
- @${ECHO} "plase set NO_GNUF77=yes"
-
-F77?= f77
-.if !defined(NO_GNUF77)
-F77EXTRAFLAGS= -w -fno-globals -fugly-complex
-.endif
+WANT_FORTRAN=yes
+USE_GCC=4.2+
+MAKE_ENV= "FC=${FC}" "F77=${F77}"
+USE_GMAKE=yes
+F77EXTRAFLAGS= #-w -fno-globals -fugly-complex
DEBUG_LEVEL= 0
.if defined(WITH_OPTIMIZED_FLAGS)
diff --git a/math/blacs/files/Bmake.inc-mpich.diff b/math/blacs/files/Bmake.inc-mpich.diff
index 1b6f547a9a87..c4d362b8d6b0 100644
--- a/math/blacs/files/Bmake.inc-mpich.diff
+++ b/math/blacs/files/Bmake.inc-mpich.diff
@@ -62,3 +62,14 @@
# --------------------------------------------------------------------------
# The archiver and the flag(s) to use when building an archive (library).
# Also the ranlib routine. If your system has no ranlib, set RANLIB = echo.
+--- Bmake.inc~ Wed Jan 10 16:11:00 2007
++++ Bmake.inc Wed Jan 10 16:18:08 2007
+@@ -93,7 +93,7 @@
+ # setting for your platform, compile and run BLACS/INSTALL/xintface.
+ # Choices are: Add_, NoChange, UpCase, or f77IsF2C.
+ # ---------------------------------------------------------------------------
+- INTFACE = -Df77IsF2C
++ INTFACE = -DAdd_
+
+ # ------------------------------------------------------------------------
+ # Allows the user to vary the topologies that the BLACS default topologies