aboutsummaryrefslogtreecommitdiff
path: root/math/blas/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-14 09:43:39 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-14 09:43:39 +0000
commit96bc8048c3217bb231f2f30eadeb628134b557f5 (patch)
treec75d5bd5a6faba5d6ec73da367e4bfe5b0d4285d /math/blas/Makefile
parent637c4e8f19438274164c0673ec85af739aba205b (diff)
downloadports-96bc8048c3217bb231f2f30eadeb628134b557f5.tar.gz
ports-96bc8048c3217bb231f2f30eadeb628134b557f5.zip
Notes
Diffstat (limited to 'math/blas/Makefile')
-rw-r--r--math/blas/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 81299401a731..f04d91620d97 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -3,7 +3,7 @@
# Date created: 27 October 1994
# Whom: ljo
#
-# $Id: Makefile,v 1.19 1998/08/09 00:05:49 steve Exp $
+# $Id: Makefile,v 1.20 1998/09/28 09:44:23 asami Exp $
#
DISTNAME= blas
@@ -18,13 +18,15 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}
+.include <bsd.port.pre.mk>
+
pre-build:
${CP} ${FILESDIR}/makefile.lib ${WRKDIR}/Makefile
post-install:
${LDCONFIG} -m ${PREFIX}/lib
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libblas.so.1.0 ${PREFIX}/lib/libblas.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libblas.so.1.0 ${PREFIX}/lib/libblas.so
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>