aboutsummaryrefslogtreecommitdiff
path: root/math/blitz++/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-02-22 23:35:04 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-02-22 23:35:04 +0000
commitfd1a43f8b979d2d1b98a8c67022290ba0dfe3562 (patch)
tree56d8cb8d35cdbf6f930d7b21212cc19a63655a78 /math/blitz++/Makefile
parent0400224f7c10adefe91dc99f69d6f7862de084b3 (diff)
downloadports-fd1a43f8b979d2d1b98a8c67022290ba0dfe3562.tar.gz
ports-fd1a43f8b979d2d1b98a8c67022290ba0dfe3562.zip
Notes
Diffstat (limited to 'math/blitz++/Makefile')
-rw-r--r--math/blitz++/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index 21a61f69c05f..f5192c1036fe 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -7,30 +7,36 @@
#
PORTNAME= blitz++
-PORTVERSION= 0.7
-PORTREVISION= 1
+PORTVERSION= 0.8
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= blitz
-DISTNAME= Blitz++-${PORTVERSION}
+DISTNAME= blitz-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= olivier.saut@gmail.com
COMMENT= A C++ class library for scientific computing
+.ifndef NOPORTDOCS
+BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
+ texi2dvi:${PORTSDIR}/print/teTeX-base
+INFO= blitz
+.else
+MAKE_ARGS= NOPORTDOCS=yes
+.endif
+
USE_REINPLACE= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-cxx=gcc --enable-optimize --disable-debug
-MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+CONFIGURE_ARGS= --with-cxx=gcc
+MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
-INFO= blitz
DOCSDIR= ${PREFIX}/share/doc/blitz
+INSTALLS_SHLIB= yes
+
post-patch:
- @${FIND} ${WRKSRC}/manual -name "Makefile.in" | ${XARGS} \
- ${REINPLACE_CMD} -e 's|[(]prefix[)]|(datadir)|g'
@${REINPLACE_CMD} -e 's|g++|\$${CXX}|g ; \
s|"-ftemplate-depth-30|"\$${CXXFLAGS} -ftemplate-depth-30|g ; \
s|-O2||g' ${WRKSRC}/configure